Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Riffaz 3 months, 1 week ago.

Assigned support staff: Riffaz.

Author Posts
August 11, 2019 at 1:07 pm

renK

The original language of my website is Simplified Chinese, I hope to automatically redirect to the traditional Chinese page.
I have set the translation for the homepage and there is no JavaScript error.
But the site still doesn't have automatic redirects

August 11, 2019 at 1:32 pm #4377003

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

I hope to automatically redirect to the traditional Chinese page.
-how did you do that?
- there is no any way to do automatic redirection in WPML

If you are asking about browser redirect it will redirect based on the user's browser language: https://wpml.org/documentation/getting-started-guide/language-setup/automatic-redirect-based-on-browser-language/

What you trying to do is possible if:
you can place PHP redirect in your functions.php file or you can install a plugin to redirect another page.
There are many free plugins available to redirect a page/post to another URL. Just before installing a plugin please check the compatibility with WordPress, rating and number of active install.

Let me know if you you need anything else regarding this.

Regards,
Riffaz.

August 11, 2019 at 1:44 pm #4377007

renK

Sorry, I really want to ask for browser language redirection, and he doesn't work.

August 11, 2019 at 2:05 pm #4377015

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Did you try to check this in Incognito mode?
Are you sure your browser language is in Traditional Chinese?

WPML will do this language redirect only once and then not redirect anymore. We do this to allow visitors to switch languages still. If we always push back to the browser’s language, visitors will not be able to manually switch languages after WPML redirects them to the language set by their browser.
This single-time redirect operation resets every 24 hours (which you can change too).

You can read the full documentations here.
https://wpml.org/documentation/getting-started-guide/language-setup/automatic-redirect-based-on-browser-language/

You might also be interested in reading this documentations about 'How Browser Language Redirect Affects Google Indexing'.
https://wpml.org/documentation/getting-started-guide/language-setup/automatic-redirect-based-on-browser-language/how-browser-language-redirect-affects-google-indexing/

Can you, please test it again?
You can change the 'Remember visitors' language preference for' value in WPML -> Languages -> 'Browser language redirect' to 1 hour if 24 hours haven't passed since the last time that you have tried it.

Let me know how it goes.

August 11, 2019 at 2:23 pm #4377033

renK

HI, I am sure I am open in incognito mode and the browser language is Traditional Chinese

August 11, 2019 at 2:52 pm #4377071

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Could you please switch to the second option here hidden link and check the issue?

If that does not help, please disable all the plugins except WPML and check the issue.
Also, check after switching the theme to a default theme like twenty seventeen and check the issue.

Let me know how it goes.

Regards,

August 12, 2019 at 12:52 pm #4380963

renK

Hello
I tried disabling plugins other than WPML and switched to the twenty-seven theme, but it still doesn't work.
I have also switched to the second option.

August 13, 2019 at 2:45 pm #4388913

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Please create a new temporary admin user let me know the username and password.
The next reply is private.

Ps:
The details you provided in the ticket does not work now.

Regards,

August 13, 2019 at 2:49 pm
August 13, 2019 at 3:06 pm #4389095

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Thank you for the details.

Can I duplicate your site for testing?

August 13, 2019 at 3:08 pm #4389129

renK

yes,you can

August 16, 2019 at 6:46 am #4404867

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

You have only one traditional chinese page and it needs updates.
It does not translated fully. : hidden link

Complete the translation.
Clear the browser cache and check.

Also, see if the browser redirection works if you create a new very simple page and translate it fully.

Let me know how it goes.

Regards,

The topic ‘[Closed] Not redirecting’ is closed to new replies.