This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by gregorK-3 5 months, 2 weeks ago.

Assigned support staff: Riffaz.

Author Posts
December 2, 2018 at 7:41 pm #2960463

gregorK-3

I read all topics, watched video how to implement Contact form 7 for various languages (did this on other pages before) but this one is giving me headache - no matter what i do, i cannot save Contact Form7 element in VC .. not saving .. I also tried with shortcode .. no luck.

Thank you for your help

December 4, 2018 at 6:21 am #2965054

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

May I ask what do you mean by "it is not saving" ?
DOes this revert back to original language or you are unable to select and save the form in VC?

It seems like a compatibility/server issues. So to make sure if possible, please do the following steps.

Plugin conflict
Could you please disable all the plugins and check this?

Minimal Setup
If you disable all non-related WPML plugins, switch to one of the default themes like twenty seventeen, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Console Errors
In your chrome browser Press Ctrl + Shift + J (Windows / Linux) or Cmd + Opt + J (Mac) before you go to this step.
Check if you see any red errors here: hidden link and let me know.

Debugging
1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/ .
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see

Let me know.

Regards,
Riffaz.

December 4, 2018 at 7:06 am #2965115

gregorK-3

Should I say that pages were translated by your Translate Editor and then i changed back to manual translation, since there was no field to change the contact form ID.
Now, when i check in manual translation I see that I cannot change anything ..
Debug and display error is empty ..

May I post credentials here?

December 4, 2018 at 7:10 am #2965120

gregorK-3

No other plugins installed

December 4, 2018 at 9:19 am #2965513

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Let me know your site login details to check this closely.

I am setting the next reply as private.
So only you and I can see the next reply.

Regards,

December 4, 2018 at 7:17 pm #2967846

gregorK-3

Hi Riffaz

Don't want to hurry you, but I'm already behind dead line with this site 🙁

Did you managed to take a look?

Also, please let me know how to remove anoying notice of Translate Feedback .. it's off and i cannot get rid of it 🙁

December 5, 2018 at 6:03 am #2968866

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I've fixed it. Please check and confirm.

You had to select "Not Translatable" in WPML > Settings > Post Types Translation > Contact Forms (wpcf7_contact_form)

I created a test form and translated it: hidden link

You can create the form and translate them now.
For steps, you can refer : https://wpml.org/documentation/plugins-compatibility/using-contact-form-7-with-wpml/

Let me know the results, please.

Regards,
Riffaz.

December 5, 2018 at 7:04 am #2968999

gregorK-3

Sorry this is science fiction for me .. what I did:
Deleted all forms
created new one, added it with Visual Composer as element and choose TEST SLO to add it to slovenian langauge (default language)
duplicated TEST SLO and renamed it TEST DE and changed the Contact Form element on german page to TEST DE - saved and nothing is saved ..
What am I doing wrong?

December 5, 2018 at 7:05 am #2969001

gregorK-3

Looks like something, some setting is preventing from saving pages ...

December 5, 2018 at 7:23 am #2969010

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I am not sure which element you are using.

I tested with VC element as well and it works fine: hidden link
The page I've created right after your last reply: hidden link and it's English translation is : hidden link
The forms I've used in these pages were created by you.
Please follow the same structure or element that you can find when you edit these pages.

Let me know the results, please.

Regards,

December 5, 2018 at 7:30 am #2969034

gregorK-3

huh .. i think we have a winner . i was using the other element .. might be obsolate ..

Will try with the one you did - thank you

December 5, 2018 at 7:32 am #2969037

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for informing and glad you've found the correct element now.

A rating with a comment is appreciated. 🙂

Regards,
Riffaz.

December 5, 2018 at 8:20 am #2969160

gregorK-3

Riffaz, one final help please

Try to open Gemran version of Domov (Home - front page) and change Contact Form TEST SLO to Test DE and save it.

Did you managed to do that?

I believe I'm having some permission issues from the very beginning .. it is not happening on new created pages 🙁

December 5, 2018 at 10:33 am #2969566

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I also see the same issue in your site.
I am not sure why is that since it is not showing any error messages.

Anyhow, I created a copy of your German homepage:hidden link where I could be able to select your German form
Connect it to the other language you want using this option : hidden link and delete your old German homepage.

Hope, this trick will solve the issue.

Let me know the results, please.

Regards,

December 5, 2018 at 1:18 pm #2970192

gregorK-3

A soon as i assigned/connect it to original page it gets locked .. no more editing.

This begins to frustrate me ...