This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Radu 2 months, 4 weeks ago.

Assigned support staff: Radu.

Author Posts
July 10, 2019 at 12:29 pm #4180215

petritK

I am trying to:automatically show the correct language after someone opens a page in chrome

Link to a page where the issue can be seen: hidden link

I expected to see: this page in dutch because the page is setup in 15 languages. I enter the default URL which is english and I want it automatically to show me the page in the language of the user. I checked with iphone and in safari this works but on chrome something is not working right

Instead, I got: the english page

July 10, 2019 at 2:29 pm #4181441

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Petrit,

Thank you for reaching out the WPML support!

Can you check this article and tell me if this is what you are looking for, please?
https://wpml.org/documentation/getting-started-guide/language-setup/automatic-redirect-based-on-browser-language/
Basically, you can use the WPML option to make the link be redirected to the browser language, if that's set and if the language is available on your website. You can give it a try and tell me how it works.

Thanks,
Radu

July 13, 2019 at 3:30 pm #4203687

petritK

Hey Radu,

Thank you for your reply. I did check the box for automatic URL, I also checked if it worked by using Incognito window and have asked around the world to open the link and they all get the english page and not a different page. What could be the reason, PLease check the following page, this one is created in 15 languages. The blue button should containt text in your language. hidden link

July 15, 2019 at 11:19 am #4210337

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Petrit,

I just tested this out on two browsers:

1. I used this link hidden link on Chrome browser (which is set to be in English) and I get redirected to hidden link - based on the browser language (hidden link);
2. I used this link hidden link on Firefox (which is set to use the French language) and this time I get redirected to the French version of the page hidden link (hidden link).

Can you tell me if this is the behavior that you are looking for, please? Or, if there's anything else you expected, just let me know and I'll tell you if that can be done or not.

Thanks,
Radu

July 22, 2019 at 6:20 am #4254165

petritK

Hi Radu,

PLease use this URL hidden link not the urls you are using. We are purely working with page_id. This url is the english version which is entered in third party systems and then must redirect to the correct language. PLease check again but only use the url I provided not the ones you used. thanks
Kind regards,
Petrit

July 22, 2019 at 9:23 am #4255419

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Petrit,

I used the link you send to me (hidden link). When I access it using a browser that has the English language set on it, I get redirected to this page hidden link. When I'm using a French browser, this page is the one I'm redirected to hidden link.
Can you tell me what links are you redirected to when using a English and French browser, please?

Thanks,
Radu

The topic ‘[Closed] not showing page in users language’ is closed to new replies.