This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 3 voices.

Last updated by Andrés 12 months ago.

Assigned support staff: Andrés.

Author Posts
October 9, 2018 at 7:20 pm #2801757

wayneC-3

I have a site that's built primarily using ACF fields for content—one column, two column, etc.—and does not utilize the standard editor in any way. I set all of the appropriate ACF fields to translate, and exported the pages to send to a translation service. They sent back a ZIP file that I imported, which created the new pages in Chinese as it should, but there were no ACF fields on the new pages, so there was no place for the content to populate.

I guess my question is that since I'm completely new to this process, how exactly is content exported/imported and how can I ensure the appropriate fields are exported, and the content is imported correctly moving forward?

Thanks.

October 10, 2018 at 1:37 pm #2804475

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @waynec-3, welcome to the WPML support Forum!

You need to set these custom fields as "translatable". Please try the following:
- Go to the edit screen of the page (default language)
- Scroll down to "Multilingual Content Setup"
- Set the custom fields as "Translatable"
- Click on "Apply"
- Do a small modification on the page content (and on some of the custom fields)
- Click on "Update"

After that the custom fields should be displayed on the tranlation editor.

Please let me know if it worked for you.

All the best,
Diego

October 10, 2018 at 4:39 pm #2805216

wayneC-3

Yes, they were all set up that way before—see attached. When the content is imported back in, the pages do not have those fields added. So "content_block" was set to translate, exported, and when the new Chinese page was created, it did not have a "content_block" on the new page.

October 11, 2018 at 1:48 pm #2808522

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Please send us access to your WordPress dashboard (website URL, login and password) I'll check and do some tests. - Please use the private field to send the sensitive data - do not post if you do not see it.

It would be better if you give me a test site rather than the live site.

IMPORTANT Please backup a working copy of site files and database before.

Regards,
Diego

October 11, 2018 at 6:41 pm #2809508

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there, Thanks for the credentials.

What page does the issue exactly occur on? I checked the "About" page (there is a custom field) and created a new translation. The fields are displayed correctly in Translation Editor (see screenshot).

The problem was already solved? If not, please describe the steps necessary to reproduce the issue.

Maybe we'll need to replicate your site locally. For this please temporarily install a plugin called “Duplicator” and "Cloudways WordPress Migration" on your site. This will allow us to create a copy of your site and your content. Once the problem is resolved we will delete the copy site. Please let me know if this is ok for you.

Regards,
Diego

October 11, 2018 at 9:04 pm #2809745

wayneC-3

The problem is occurring when content is exported, translated by a third party, and then imported back in. When I import the translated file back in, I get a blank page.

October 12, 2018 at 11:23 am #2811735

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello there,

As Diego is not available I would like to take care of your case.

According to your description, the issue is coming from the imported file.

1. Try the following:
- Export your XLIFF file.
- Do a minor modifcation.
- Import it.

Does it work? If so, you may need to contact your translation service to check what could be creating this situation.

2. Blank screen means a PHP error. It would be good if you can provide me the WordPress debug.log (not WPML debug informations).

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way, because sometimes the logs are long and create a complete mess in discussion).

October 12, 2018 at 1:41 pm #2812200

wayneC-3

It imports with no errors, but as I've said before, there are no *fields* once I import. Try logging in and looking now. hidden link has several ACF fields that are populated. I have imported the content from the translation service into the Chinese language. When I go to THAT page hidden link there are NO ACF fields even created, let alone populated.

October 12, 2018 at 2:42 pm #2812346

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Thanks for the new inputs, I understand now that your situation is different from what you previously describe here:
https://wpml.org/forums/topic/not-sure-how-this-process-works/#post-2809745

If I understand correctly:
- You create a page with ACF.
- You export the XLIFF.
- It is translated by Translation party.
- You import it.
- The page is blank: it means that content s are not imported, not that you have a blank screen.

Is this your situation? If so:

1. Please update your "Advanced Custom Fields PRO".

2. It is possible that the problem is not because exporting/importing content is not working but just that your ACF fields are not correctly configure. For this:
- Create a new test page.
- Try to translate it directly, no third party involved: click on the (+) icon.
- Do you see thee ACF fields?

October 16, 2018 at 1:55 pm #2821168

wayneC-3

Correct.

I created a test page with an ACF field as suggested. When I press the + for Chinese, a new page is created with no title and no ACF fields.

October 16, 2018 at 2:40 pm #2821428

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

I have visited your ACF settings and there is not any custom field created. Could you please indicate in a detailed way how you add them and which page you have created as a test?

October 16, 2018 at 5:48 pm #2822026

wayneC-3

All of the fields are created within a PHP file that is imported into the theme. You can see the test page here hidden link

October 16, 2018 at 5:54 pm #2822030

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

WPML uses a different approach for translating Custom fields which may be not compatible with the one your using:
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

Could you try to create another file for your other languages? Otherwise, we may need to review your method and see if there is a way to make it compatible with WPML or even send you to one of our contractors if you are using custom code.

October 16, 2018 at 7:03 pm #2822198

wayneC-3

All of the fields are showing up as translatable options though, and I've had them set since the beginning. See attached.

October 17, 2018 at 6:22 am #2823210

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

As our previous documentation explained, WPML works in a different way with ACF:
- You create some Custom fields.
- You translate them.
- Then you set them as translatable. This step does not create your translatable fields from the previous step.

As I showed you here, you have not created any field in this way. On the contrary, you are using a different method which may not be compatible in how WPML works.
https://wpml.org/forums/topic/not-sure-how-this-process-works/#post-2821428

Have you created the translatable custom fields in the same way you have created the originals?

You may need our hooks documentation in order to do this:
https://wpml.org/documentation/support/wpml-coding-api/wpml-hooks-reference/