This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Lauren 1 year ago.

Assigned support staff: Lauren.

Author Posts
September 14, 2018 at 10:42 pm

michaelG-85

I am trying to: Show not translated images in the translated pages. But instead of showing the original image, there is no image shown at all. I tried to play with the settings but even if i set
Beitragstypen-Übersetzung -> Medien (attachment) -> Übersetzbar - Übersetzung nutzen, sofern verfügbar, oder auf Standardsprache zurückgreifen ( if translateable, fall back to default language if not set.)

Link to a page where the issue can be seen:
Working:hidden link
Not working: hidden link

I expected to see: The default Header image because there is no need to translate it.

Instead, I got: No image shown.

September 17, 2018 at 3:41 pm #2741720

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

In order to show the same image in multiple languages, you need to duplicate the images. Please go to WPML -> Settings -> Media Translation. Here you can check the boxes to duplicate images and then click "Start" to sync the images to your secondary language(s).

Please let me know if you need any further assistance and I will be happy to help.

September 18, 2018 at 4:39 pm #2745955

michaelG-85

Like i said i aleready did this. I need further help.
I tried this approach 3 times but without result.
It is very urgent because this site is live...We relied on WPML to work smoothly with Enfold.

September 18, 2018 at 8:19 pm #2746473

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Can you please tell me where you go to set this header image? If it is somewhere within the theme options, you will need to use the theme language switcher to change to your secondary languages and set this header image. Please walk me through how you added the image so that I can help get this resolved for you. Thanks!

September 23, 2018 at 6:14 pm #2758915

michaelG-85

The image was already added, when we installed WMPL. And for a time it also showed up. Would it be helpfull if i send you credentials as personal note so you can have a deeper look? please tell me where to send them too. Thanx in advance

September 24, 2018 at 2:38 pm #2760803

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

September 25, 2018 at 5:34 pm
September 25, 2018 at 5:55 pm #2764960

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Can you please double check the password in your previous reply? I don't think it is correct. You can edit your previous reply to update it as needed. Thanks!

September 25, 2018 at 10:33 pm #2765333

michaelG-85

Done 🙂

September 26, 2018 at 1:05 pm #2767345

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for updating the credentials. I was able to log on. Your media files should be set to Translatable. When I did that, you can now see the space where the image should be in English and French. However, I haven't figured out how to get the image to display yet. So I'd like you to try a few things. First, be sure to make a full backup of your site.

I see that your WP Memory does not meet our requirements. Please try increasing the WP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it above the line /* That's all, stop editing! Happy blogging. */

Then, go to WPML -> SEttings and in the Media Translation section, please click Start to begin duplicating the images. I realize you already did this, but changing the media to translatable might just make a difference.

If that does not resolve the issue, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentySeventeen. With these settings, is the issue resolved?

If you don't have a testing environment available and cannot test this on your live site, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to set up your site locally and run these tests for you.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply. I will also need the username and password of a user that was created before the duplicator package was created. It looks like you may have attached just a Duplicator archive file in your original post, but I will need both the archive and the installer file.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will enable the next reply to be private so only you and I have access to it. Thanks!

September 26, 2018 at 6:24 pm #2768412

michaelG-85

I think this post might be visible, could you enable private again please?

September 26, 2018 at 7:22 pm #2768473

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

The next reply is marked as private. You may need to refresh your screen once you are logged in.

September 26, 2018 at 10:24 pm
September 27, 2018 at 12:43 am #2768922

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending credentials. I found that it was one of your menu items causing an error that broke the slider. Please reference https://wpml.org/forums/topic/avia-page-builder-theme-enfold-i-didn-found-a-solution-for-that/#post-1986288.

I edited the English and French menu to remove the #ide?lang=en/fr and now you can see the slider working in all languages.

Please let me know if you need any further assistance and I will be happy to help.