Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Dennis 6 months, 2 weeks ago.

Assigned support staff: Dennis.

Author Posts
April 30, 2019 at 6:13 am


I was able to apply "nm_woostore_aftercartcontents" to string translation via "Translate texts in admin screens".
Now it is shown in String Translation.
But after translating (from English to Dutch), it keeps showing the English string in Dutch-page.

April 30, 2019 at 8:33 am #3709475



Welcome to WPML Support forum.

Have you tried running routines from WPML troubleshooting page? If not, could you please try these steps and see if it resolves the issue?

Note: Please make sure to make a complete backup of your site before proceeding.

-delete the strings from String Translation page. Select the strings and then click 'Delete Selected Strings' button

-Go to WPML>>Support page
-Click on Troubleshooting link (link in the middle of the page)
-In Troubleshooting page, please click on the following options of 'Clean up' section. Wait for confirmation of processing after each one.
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
-Recreate ST DB cache tables

-go to WPML > Theme and plugins localization. Be sure that 'Translate themes and plugins using WPML's String Translation only (don't load .mo files)' is selected.
-under Strings in the plugins section, select your plugin.
-click 'Scan selected plugins for strings'
-go to WPML > String Translation
-translate the string again. check 'translation is complete' . click 'save'

Does it help? If not, I would like to request your permission to install Duplicator plugin, build a package and download a copy so I can continue debugging locally and without affecting your site.

Kind regards,

April 30, 2019 at 9:59 am #3710219


Hello Dennis,

It did this, but nothing changed 🙁
You have my permission to install Duplicator.

May 1, 2019 at 8:17 am #3716827



Thank you for your reply.

This seems like a compatibility issue with your plugin. To confirm this, we have to reproduce the issue on a clean install so I have created a test site for you. You can now access it using the link below.

hidden link

Could you please upload just your Personalized WooCommerce Store plugin, if possible try to replicate the issue. You do not have to recreate your site, just install the minimum necessary to reproduce the problem.

Please let me know once done so I can go and check. If you have any questions please let us know.

Thank you.

Kind regards,

May 5, 2019 at 7:13 am #3741919


Sorry for the late response.
Still haven't got time to do this.
I will be soon, I hope.

May 6, 2019 at 1:01 am #3744141



No worries. Please just take your time and please let me know when your done.

Thank you.

Kind regards,

The topic ‘[Closed] Not translating after adding via Translate texts in admin screens’ is closed to new replies.