Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 23 replies, has 3 voices.

Last updated by Diego Pereira 1 week, 3 days ago.

Assigned support staff: Diego Pereira.

Author Posts
October 25, 2019 at 9:22 am #4825425

xavierf-6

I am trying to: translate and localise the completed order emails. Somehow, I can translate the topic and header, but not the body of the email to other languages.

As you can see on the attached image, the whole email is in English, but the body copy is in Spanish.

How could I proceed?

Thanks.
Xavi

October 26, 2019 at 1:00 pm #4831847

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Please update to our latest versions of WPML plugins, as well as WooCommerce if needed. Then, you should be able to translate the email content via WPML ->String Translation. You can search for the strings there, and make sure to check the box as complete and click Save.

If you have tried this with the latest version and it is still not working, please let me know and I will be happy to further troubleshoot.

October 27, 2019 at 8:03 am #4833687

xavierf-6

HI Lauren,

Thanks a lot for assisting me.

I did update the plugin to the latest version and still, when I go to string translation and search the copy I want to translate, the search gives zero results, and no options appear.

Could you please let me know how could I proceed?

Thanks a lot for your help

October 27, 2019 at 11:36 pm #4835697

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Are you using the standard WooCommerce emails? If so, please go to WPML -> Theme and Plugin localization and scan the WooCommerce plugin for strings. After this, are you able to find the strings in the table?

If not, I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

October 28, 2019 at 3:52 pm #4841357

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Unfortunately the credentials provided are not allowing me to log in. Please double check them and you can edit your previous reply if needed to update the credentials. Thanks!

October 28, 2019 at 9:41 pm #4843027

xavierf-6

Hey Lauren, Apologies, not sure what happened. I double check, and the credentials should work right now.

October 29, 2019 at 7:28 pm #4851327

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thanks for updating credentials. I was able to login and it looks like the text that was not translating was the "Additional Content". I added this to string translation by adding the following code to WPML -> Settings ->Custom XML Configuration.

<wpml-config>
    <admin-texts>
        <key name="woocommerce_customer_completed_order_settings">
            <key name="additional_content" /></key>
    </admin-texts>
</wpml-config>

Now, you can see the string in WPML -> String Translation. Please try adding the translation there and then let me know if the email displays the translation correctly.

November 1, 2019 at 8:25 am #4868709

xavierf-6

Hi Lauren,

Thanks a lot for your help. I definitely see that now the copy of the additional content appears in the string translation when I look for it. So that is definitely an improvement.

However, I did translate the copy to English and French, check the translation finished and saved it, and when I test it, the additional content in the email still comes in Spanish.

How can we proceed?

November 1, 2019 at 7:48 pm #4872939

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Let's try this. Since the site default language is Spanish, please try going to WooCommerce -> Settings -> Emails and in the Completed email, enter the additional content in Spanish. Then, go to WPML -> String Translation. if the string has not automatically updated, you can delete it and rescan the plugin at WPML -> Theme and plugin localization. Then, translate the Spanish string to English. If the string is registered as English when you go to the String Transaltion Table, you can switch it to Spanish.

Please let me know if these steps resolve the issue.

November 6, 2019 at 9:16 am #4896005

xavierf-6

HI Lauren,

Unfortunately, that is the case. See the picture attached. THe main copy is in Spanish, and then I translate it into French and English.

Unfortunately, also see the attached images for emails, the additional content does not translate, and now also the header of the emails is also in Spanish all the time and will not translate. (please see I did attache pictures of the emails in French and English, and you can see a bit of mix in Spanish and French and or English depending on the email language)

Please let me know how can I proceed.

Thanks a lot.
Xavi

November 6, 2019 at 3:06 pm #4899741

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Please see my previous private reply and let me know once the migration is completed.

November 6, 2019 at 8:02 pm #4901413

xavierf-6

Hey Lauren,

Sorry, these details are not working for me.

See the message they show me:

November 7, 2019 at 1:56 pm #4906479

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

I just checked again and the details are all correct, so I'm not sure why that message is showing. Could you perhaps try one more time? If it still does not work please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

November 7, 2019 at 2:26 pm #4906755

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

It turns out our test server was overloaded at the time of migration. Could you please try again and let me know if it is successful this time? It should work without the error now.

November 7, 2019 at 6:47 pm #4909463

xavierf-6

HI Lauren,

I did try again and the migration is completed.

Please let me know how to proceed.

Thanks.
Xavi