This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Bigul 4 months, 1 week ago.

Assigned support staff: Bigul.

Author Posts
June 4, 2019 at 5:56 am

Syndicate

I am trying to: Set a different domain per language

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link loads the chinese language and hidden link loads the english version

Instead, I got: hidden link and hidden link loads english.

June 4, 2019 at 2:07 pm #3952283

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please untick *Validate on save* checkbox and then save the Language URL format. Then check you are getting the expected result or not.

Please check the following documentation(especially the *Setting up your DNS server* section) and make sure you have correct settings.

https://wpml.org/2016/04/use-wpml-different-domains-per-language/

--
Thanks!

Bigul

June 4, 2019 at 2:38 pm #3952827

Syndicate

I tried to untick and save and it does not work.
hidden link

We are using Cloudways.com as our hosting provider. They do not use CPANEL.
Please let us know what else we can do.

Our DNS is setup correctly, the A record for both hidden link and hidden link are both pointing to the same server IP address.

The server has two domains assigned to it.

June 5, 2019 at 9:16 am #3958407

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please share the correct login URL. The one you have shared is showing *404/PAGE NOT FOUND* error. Please check.

--
Thanks!

Bigul

June 5, 2019 at 2:10 pm
June 5, 2019 at 2:40 pm #3961639

Syndicate

Hello i've sent the update login info
hidden link

June 6, 2019 at 8:54 am #3967215

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. I was able to save the *A different domain per language* settings after unchecking the *Validate on save* option. Now it is showing the expected result for me except on the home page.

Please check the following links for more details and let me know your feedback.

hidden link

hidden link

--
Thanks!

Bigul

The topic ‘[Closed] not valid A different domain per language’ is closed to new replies.