This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

No supporters are available to work today on this forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

This topic contains 14 replies, has 2 voices.

Last updated by guntherK-2 3 weeks, 2 days ago.

Assigned support staff: Raja Mohammed.

Author Posts
September 13, 2019 at 11:38 am

guntherK-2

I am trying to: Activate this feature

Link to a page where the issue can be seen: Backend of caravita.de

I expected to see: Being able to edit all languages in the backend.

Instead, I got: Not able to edit language other than language connected with domain of backend.

September 16, 2019 at 5:10 am #4576325

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello there,

I checked your site, I am unable to reproduce the issue.
I am able to open the translation of pages without any issues.

Could you please explain to me the steps to reproduce the issue, please let me know the URL of the page where the issue can be seen.

I would await your results.

Kind regards
Raja

September 17, 2019 at 2:53 pm #4589463

guntherK-2

Please log back into the backend and go to "Sonnenschirme" (custom post type). Then please open "Big Ben". The German version is loading the divi builder with no problems. Now switch to the English version. No Divi Builder loading. (we have the same problem with normal pages)
This worked with no problems when we were still running with /en instead of an own domain for the English version of the site.

September 18, 2019 at 5:55 am #4592617

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

The issue seems to be related to a plugin conflict, Loading your consumes browser resources and slows down the process.

Please perform basic troubleshooting to isolate the issue.
- Disable all non-WPML plugins check if the Divi builder can be loaded in English translation
- If the issue disappears try loading activating the plugin one by one to identify the conflicting plugin

Please let me know the results.

P.S Based on our test Query monitor plugin used with WPML slows down site performance we would advise not to use it in the live site except for debugging purpose.

September 19, 2019 at 10:16 am #4603519

guntherK-2

Deactivated Query Monitor and removed it: no change.
Deactivated everything except WPML-Plugins: not even the main language is now editable. So it's worse than before. Even worse: after reactivating the required plugins that customs post types don't work anymore. Every single one yields a 404.

Again: Site worked perfectly in test environment with /language.

September 20, 2019 at 4:33 am #4609755

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I am not sure about what causing the issue.

1) It would be good if you can provide me with the WordPress debug.log (not WPML debug information).

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

In this case, the errors will be saved to a debug.log log file inside the /wp-content/ directory.

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in the discussion).

2) It would be better if you can send a snapshot (copy) of your site so that I can debug the issue in my local environment.

You can use the Duplicator plugin to create a snapshot of the site and share the package link with me http://wordpress.org/plugins/duplicator/. I have enabled private fields for you to securely share the details.

September 20, 2019 at 8:23 am
September 20, 2019 at 7:39 pm #4614283

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I think the issue seems to be related to DIVI latest builder, Please change the DIVI editor to the classic experience and disable the latest editor, From Divi > Theme Options > Editor > Advanced. This resolves the issue for the time being.

I'm not sure if this is a issue with DIVI or with WPML as I can reproduce the same when I disable WPML. The best would be to isolate the issue in a clean installation. Please install DIVI and Your child site to the sandbox site

One Click Login:hidden link

Let me know once done.

September 23, 2019 at 7:13 am #4620953

guntherK-2

I will try this today and come back to you.

September 23, 2019 at 7:21 am #4621083

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Sure, I will await your results.

September 23, 2019 at 8:01 am #4621455

guntherK-2

I installed Divi and the child theme in the sandbox.
Plus: I can confirm that switching to the classic editor seems to resolve the problem.

Really looking forward to finding out who's the "culprid" 🙂

September 23, 2019 at 2:03 pm #4624843

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks, Seems like a compatibility issue. let me test this and update you soon.

September 25, 2019 at 1:34 pm #4639309

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I am unable to reproduce the issue on a clean installation. Probably this is something specific with your site.

However, I can reproduce the same when I disabled WPML in your site duplicator. I would suggest checking this with the DIVI support if they have any solution for you to use the latest Divi editor.

Kind regards
Raja

September 25, 2019 at 1:40 pm #4639341

guntherK-2

Thank you!
Site works perfect with the old "classic" editor. I will just leave it at that. Thanks a lot.

Sidenote: I don't really like Divi anyway, we don't use it on our new sites. But we still use WPML - among other things because of the great support we get there. 🙂

September 26, 2019 at 5:37 am #4643575

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thank you very much for your kind words.
As always feel free to reach us any time of your convenience.

Kindly mark this ticket as resolved. In case there is no further assistance is needed in this case.

Kind regards
Raja