This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
Admin Text strings in a third party plugin called "User Verification (Pick Plugins)" were not showing up in String Translation. The user was unable to mark the strings for tracking by WPML, probably due to a server configuration issue.

Solution:
The strings can be marked for tracking by uploading a wpml-config.xml file, or adding Config XML to the WPML -> Settings -> Custom XML Config

<wpml-config>
    <admin-texts>
        <key name="uv_email_templates_data">
            <key name="*" />
        </key>
    </admin-texts>
</wpml-config>

The code above can be used for other plugins by replacing "uv_email_templates_data" with another key.

Relevant Documentation:
https://wpml.org/documentation/support/language-configuration-files/

This topic contains 7 replies, has 2 voices.

Last updated by holgerF 2 weeks, 4 days ago.

Assigned support staff: Izzi Hassan.

Author Posts
September 24, 2019 at 9:50 am #4629975

holgerF

Hello,
I am trying to translate the email templates of this plugin hidden link

I tried this instruction https://wpml.org/documentation/getting-started-guide/translating-theme-options/ but, when I click at Apply it seems it will be fine but then nothing happens. When I go back to string translation site I don't see the checked items.

What can I do to translate the email templates of this plugin.

Thank you for your help in advance.

Holger

September 24, 2019 at 3:37 pm #4632881

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for reaching out to us.

I was unable to recreate the issue you are seeing. After checking the options under uv_email_templates_data, I saw the email templates show up in the String Translation page without issue.

This leads me to believe that the problem is that your server’s PHP setting for “max_input_vars” is not high enough. You can see how the same issue was resolved for another client by modifying their php.ini file:
https://wpml.org/forums/topic/cant-add-string-for-translation-from-admin-strings/

If you are unable to modify your server config (or don’t want to), you can also mark the template texts for translation using a WPML Language Configuration File (https://wpml.org/documentation/support/language-configuration-files/).

For a quick fix:
Go to WPML -> Settings
Click the “Custom XML Configuration” tab
Add the following and click Save

<wpml-config>
    <admin-texts>
        <key name="uv_email_templates_data">
            <key name="*" />
        </key>
    </admin-texts>
</wpml-config>

Now when you go to String Translation, the strings should show up as expected.

Please let us know if this worked for you and don’t hesitate to reach out if you have further issues!

September 24, 2019 at 4:59 pm #4633141

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

There was a slight typo in the code I sent. I have corrected it in the original response but here is the correct version in case you are trying it already:

<wpml-config>
    <admin-texts>
        <key name="uv_email_templates_data">
            <key name="*" />
        </key>
    </admin-texts>
</wpml-config>
September 25, 2019 at 4:36 pm #4641251

holgerF

Hello, Thank you for your help. I followed the instructions and have set max_input_vars to 10000 and also inserted you code. But nothing happens. I am still able to see 149 strings with domain user-verification but the most interested ones for me
(- uv_email_templates_data
+ user_registered
+ email_confirmed
+ email_resend_key)
are still not shown and I am not able to active them (will not work).
I really thank you when you can try to help me again.
THX
Holger

September 25, 2019 at 5:37 pm #4641515

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures
I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy
We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

IMPORTANT
Please make a backup of site files and database before providing us access.

If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC.

DO NOT post your website details unless you see the required wp-admin/FTP fields.

If you do not, please ask me to enable the private box. The private box looks like this: hidden link

September 25, 2019 at 7:06 pm #4641811

holgerF

Hello Izzi, thank you for your answer. Is it possible that I can share screen with you (e.g. Skype, Teamviewer, Anydesk etc.) so you can login through my screen to my wp-account and my FTP. Hopefully this works for you...
Thanks in advance.
Holger

September 26, 2019 at 8:17 am #4644345

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Unfortunately, we are not going to be able to go through your site over a screen-share.

I would like for you to follow these steps one more time and confirm that you are not seeing what I am:

  • Go to WPML -> Settings
  • Add the code provided above to the box and click “Save”
  • Confirm that you see the message saying “The XML has been saved” as shown in the first screenshot

--

  • Go to WPML -> String Translation
  • Click on the “Translate texts in admin screens” link
  • Scroll down to “uv_email_templates_data” and expand it
  • Confirm that all the fields are now checked automatically as shown in the second screenshot

--

  • Go to WPML -> Theme and plugins localization
  • Scroll down to the “Strings in the plugins” section
  • Select “User Verification” by checking the box next to it
  • Click “Scan Plugin”
  • Confirm that WPML finds 163 strings now instead of 149 as shown in the third screenshot

--

  • Go to WPML -> String Translation
  • Confirm that the email template strings are now showing up as shown in the fourth screenshot

--

Let us know if there’s anything you see that doesn’t match up to the screenshots provided so that we can see where the issue is happening in the process.

You can access a temporary “sandbox” site I tested this solution in by clicking on the link below:
hidden link

If you are unable to resolve the issue by following the instructions as provided, then you will either need to provide us with temporary access, or you can provide us with a copy of the site so that we can set up a test site and see what’s happening.

Please rest assured that we would only be accessing your site to get some additional technical information about the issue, and would only be attempting the same steps as outlined above.

September 26, 2019 at 9:19 am #4645041

holgerF

Hello Izzi, wow wow wow! Thank you for your really great support. Your detailed instruction helped me to solve this task. You made my day ... no ... my week! I am really happy and thank you very much for your help! Real 5 star support!
I wish you all the best
Holger