This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Shekhar Bhandari 2 months, 2 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
July 5, 2019 at 5:15 am

han-suC

We have 4 languages (English, Chinese, Japanese, Korean). English is the main default language.

I am trying to:
Make all translated pages, posts, woocommerce products etc use the original English slug/url. So for example:

hidden link (English)
hidden link (Chinese)
hidden link (Japanese)
hidden link (Korean)

I expected to happen:

When creating a translation of an original document, I expect the slug to automatically use the original English slug (Copy / synchronise).

Instead, what happens is:

The slug of the translation document is automatically generated from the title. Also it appears in the translation editor if using the advanced translation editor, which I DON'T want otherwise translators will translate it.

The issue appears to be the same as the issue described here, although I have already marked the translation document URLs as encoded:

https://wpml.org/forums/topic/translated-documents-options-page-url-issues/

Please see screen shots of my WPML settings and permalink settings attached

July 5, 2019 at 7:00 am
July 5, 2019 at 7:33 am
July 5, 2019 at 8:28 am #4149027

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I have removed the images and marked the previous reply as private.

I will respond to you as soon as possible.

Thanks

July 8, 2019 at 3:55 am #4158955

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I have escalated this issue to our 2nd tier supporter to perform further debugging after discussing the issue with them.

I will update you as soon as I will have more feedback.

Thanks

July 8, 2019 at 3:59 am #4158957

han-suC

Thanks for the update Shekhar. I will wait to hear back from you and 2nd tier support.

July 8, 2019 at 12:12 pm #4162235

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Sure, will update you as soon as I will receive further feedback here.

Thanks

July 11, 2019 at 7:30 am #4186659

han-suC

@shekhar

Any update on this? I will remove the staging environment soon. Can you confirm that this is a bug and not the intended behaviour of WPML?

July 11, 2019 at 12:18 pm #4189637

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

This is still on our 2nd tier supporter queue, so I don't have any update of it yet, I have reproduced the issue on a fresh install so you can remove the staging site.

I will respond to you as soon as I will have a further update.

Thanks

July 16, 2019 at 2:24 am #4215185

han-suC

Hi @shekhar

Any update on this yet? I keep getting emails saying that because I am not replying this topic will be closed? Can you acknowledge this is a bug and will be fixed in next version?

August 9, 2019 at 5:54 am #4367451

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Our 2nd tier is debugging this issue right now, I will update you as soon as I will have the further update.

Regarding the ticket closed, since the ticket is marked as "Escalated to 2nd tier" the ticket will not be closed before we provide any feedback on the issue, so you can leave it as it is.

Thanks

August 9, 2019 at 6:40 am #4367709

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I just received feedback and our 2nd tiers confirm that it's only possible to use this feature when using translation editors for pages/posts and it's normal.

Regarding the WooCommerce Product slug, the slug translation is always included in the editor so this setting will not be applied to it.

Being so, if you are using manual editors or using the WooCommerce Products you will need to manually translate those URLs.

If you wish you can create a new feature request from here for both issues. https://wpml.org/suggest-a-new-feature-for-wpml/

Thanks