This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The notification "WPML Media Translation is almost complete" won't go away

Solution: backup the database and check for the "wpml_notices" entry in the table wp_option. It contains all WPML notices, you can delete the Media Translation notice from there.

This topic contains 10 replies, has 2 voices.

Last updated by paulM-40 11 months, 3 weeks ago.

Assigned support staff: Laura.

Author Posts
October 5, 2018 at 9:03 am #2789966

paulM-40

I am trying to: hide notification

Link to a page where the issue can be seen: all backend sites

I expected to see: not the notification

Instead, I got: the notifcation for months now!

Same problem as https://wpml.org/forums/topic/media-translation-admin-notification-wont-go-away/ - tried the suggested solutions, but I still have this anoying message!

October 8, 2018 at 8:06 am #2795036

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

in some cases, it worked going to WPML -> Media Translation and run the Media Translation process from the beginning.

Also try to clear WPML cache in WPML -> Support -> "troubleshooting" link

Let me know if this helps you or if we need to debug the issue further.

October 8, 2018 at 12:53 pm #2796040

paulM-40

Hello and thanks for your support Laura

I've tried both solutions, but none of them worked 🙁

October 9, 2018 at 7:15 am #2798520

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

at this point, I'd ask you for a copy of the site. We usually suggest the Duplicator plugin to do it.
I'll need the database, plugins, and theme at least.

I'll enable a private reply so you can safely share the link with me.

October 15, 2018 at 8:28 am #2816556

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

the file is okay, but you sent me only the database, not the entire site.

If you are not sure on how to proceed, there are several tutorials for Duplicator like this one: hidden link
and also our documentation: https://wpml.org/faq/provide-supporters-copy-site/

I'll enable a private reply.

October 15, 2018 at 2:34 pm #2817971

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I tried to run Duplicator Pro on your site but it seems there is a server configuration problem.
If you give me your FTP credentials I could download the files I need directly.
I'll enable a private reply.

October 16, 2018 at 2:52 pm #2821463

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I manage to download the files I needed and I'm testing the copy.
I'll let you know as soon as possible.

October 17, 2018 at 8:42 am #2823815

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

after some testing, I'm going to escalate the ticket so maybe we can find a solution.
Just to be sure, you deleted both 'wpml_notices' and 'icl_admin_messages', right? I can't find them in wp_options.

October 19, 2018 at 10:41 am #2831604

paulM-40

Unfortunately, I can not say 100% sure, because I have tried some solutions and I can not remember exactly if they included the deletion of this tables.

October 22, 2018 at 12:29 pm #2838016

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

in the table wp_option, I searched for 'wpml_notices' and erased the content (probably, if you find it you can just delete the Media notice).
Now the message doesn't show anymore.

Could you try this way? Please be sure to have a working backup before touching the database.
I used the plugin Ari Adminer but you can try with PHPMyAdmin if you prefer.

Let me know if this helps you or if you need further assistance.

October 22, 2018 at 3:15 pm #2838621

paulM-40

That did the trick - my issue is resolved now. Thank you!