This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:Number of translated "Published" events do not add up

Solution:Deactivating and Reactivating the WPML plugin resolved the issue

Relevant Documentation:

This topic contains 9 replies, has 2 voices.

Last updated by minis 1 year, 1 month ago.

Assigned support staff: Bobby.

Author Posts
September 13, 2018 at 7:28 pm #2732794

minis

Hello WPML Support,

I have translated events form NL -> EN successfully. Using TEC for the events.

See the screenshot I provided.

On the screen Dashboard -> Events:
All = 79 and Published = 79 (see screenshot)

Were does this Published number come from?
I am aware of having 36 NL events and 36 EN events for a total of 72 events, and this is CORRECT.

But what are the 79-72 = 7 other events? Do not know about these.
And when I click on the "Published (79)", I still only see 72 events in the list.

Could you please explain?

cheers

September 13, 2018 at 7:37 pm #2732807

minis

Hi,

Just wanted to add that for translated Pages everything adds up!

See the screenshot.

There number of published is the same as "all languages" pages = 42. Is Correct!

So for Pages the numbers add up, but for events they do not.

cheers

September 15, 2018 at 12:46 pm #2737659

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

did you by any chance ever add events under another language that might be deactivated now ?

Please go to WPML => Support , and click on "Troubleshooting" while in the Troubleshooting page please perform the actions. (specifically "set language information" but i recommend performing all of them"

let me know your results

September 15, 2018 at 4:23 pm #2737927

minis

Hi,

Your question: "did you by any chance ever add events under another language that might be deactivated now ?" No, have not defined another language that NL and EN.

(Note: But did change the names of the languages to get NL and EN on the switcher. (Originally they were Dutch and English respectively, now they are NL and EN. I recall that at the time we already had several events defined before changing the names.)

First of all: The numbers of published events NOT adding up is NOT correct right? That is NOT expected, right? (see question on original ticket)

Before the troubleshooting the number of events was as follows (different since my original ticket since things have mobe:
All (73) | Mine (38) | Published (73)
NL (33) | EN (33) | All languages (66)

Have performed the Troubleshooting as you requested. See the screenshot.
- I performed all the cleanup action that have an arrow next to them.
- I did not perform "Synchonize post taxonomies" since did not know what to do here.
- All performed actions ended with the "Done" popup
- For "Fix post type assignment for translations" got 1 fix (see screenshot).

Now as to the result of the number of events do still not add up.
After troubleshooting result is exactly the same as it was before troubleshooting:
All (73) | Mine (38) | Published (73)
NL (33) | EN (33) | All languages (66)

Please advise as to next steps.

September 17, 2018 at 8:16 am #2740156

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

yes that is not an expected behavior , if possible i would like to take a closer look

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

September 17, 2018 at 7:24 pm #2742370

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

The issue should be resolved now.

40 NL and 33 EN = 70 all

i deactivated and reactivated WPML.

September 17, 2018 at 9:03 pm #2742612

minis

Hello Bobby,

Nice! The numbers for the events now add up.

Just so that I know what to do next time:
- Did you deactivate all of the installed WPML plugins or only the main plugin "WPML Multilingual CMS"?
- Does this happen often?

And any idea as to what happened to cause this? (So I can take care not causing this again?)

Thanks.

September 17, 2018 at 9:23 pm #2742649

minis

Hello again,

Just thought of the following:
Due to me noticing that the number of published events were NOT adding up, I spotted a problem. After you deactivated and reactivated WPML, it turns out that there were "unknown ghost" events in the database that were previously not shown.

I noticed this anomaly of published event numbers by chance.

To have a more proactive approach, is there any tooling that I can use to see the events in the database?

Thanks.

September 18, 2018 at 6:46 am #2743700

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

this is not something that happens often and truly something that usually gets resolved with the troubleshooting actions i had mentioned before.

its possible it happened due an upgrade or even a caching issue, but it should be resolved, i personally do not see this type of issues to be reoccurring

i simply deactivated the WPML plugin just the main one, and re activated it.

September 18, 2018 at 8:39 am #2744049

minis

Thanks for your help Bobby.