This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 16 replies, has 2 voices.

Last updated by Bigul 9 months, 1 week ago.

Assigned support staff: Bigul.

Author Posts
December 28, 2018 at 9:11 am #3039475

nicoB-10

I am trying to: duplicate an english page to 3 languages without translation.

Link to a page where the issue can be seen: hidden link

I expected to see: canonical and og:url to the original language I duplicated or at least to itself.

Instead, I got: canonical and og:url to spanish language (no the language I duplicated).

hidden link

Thanks.

December 28, 2018 at 2:16 pm #3040430

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

This may be happening because of the older version of WPML and Yoast SEO plugins. Please upgrade to the latest version of the plugins after a full site backup. Then update the post having the issue in the default language and check the issue is existing or not.

--
Thanks!

Bigul

December 31, 2018 at 10:05 am #3044766

nicoB-10

Updated (both, Yoast and all WPML plugins) and still happening.

December 31, 2018 at 3:15 pm #3045633

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. You have duplicated the Post from English to other languages except for the Spanish, and translate the English post to Spanish. OG:URL is showing the Spanish post URL instead of the English URL in the Duplicated post, am I right?

Does it happen with the all type of posts or only with the Project posts?

Please update one of the posts having the issue in the default language and check the issue is existing or not.

--
Thanks!

Bigul

January 2, 2019 at 9:50 am #3048449

nicoB-10

Hello,

Thank you for the updates. You have duplicated the Post from English to other languages except for the Spanish, and translate the English post to Spanish. OG:URL is showing the Spanish post URL instead of the English URL in the Duplicated post, am I right?

Yes, that is.
Updated both (main language and the duplicated one) and still happening.

January 2, 2019 at 1:23 pm #3049284

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page
2) Click on Troubleshooting link (blue link in the middle of the page)
3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

Also please create & duplicate a new test post, then check the issue is existing with the newly created post(to make sure).

--
Thanks!

Bigul

January 2, 2019 at 1:37 pm #3049328

nicoB-10

Tried and still existing.

This is the test hidden link

and I duplicated it to: hidden link

Even normal blog posts: hidden link

OG:URL and Canonical point to the ES version.

Also tried to update an existing activity and it broke the link between translations and generated 4 identical posts in the ENG language.

I really dont understand what's happening.

January 2, 2019 at 5:17 pm #3050010

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

January 3, 2019 at 5:41 pm #3054150

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. But I am not able to access the login page. It is showing following message. Please check the attached image for more details.

This page isn't working 

*** redirected you too many times.

Try clearing your cookies.

ERR_TOO_MANY_REDIRECTS

--
Thanks!

Bigul

January 4, 2019 at 4:41 pm #3057287

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. But we are still not able to access the login page. The result is the same after several tries from different connections.

Therefore please check you have enabled IP/Country based blocking.

--
Thanks!

Bigul

January 7, 2019 at 8:21 am #3061689

nicoB-10

Yes, please let me know your IP and Country to unlock.

Thanks,

January 7, 2019 at 3:13 pm #3063316

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I am accessing the site from India. My current IP is 112.133.236.0, but it is a dynamic IP and will change at any moment. Sorry, I don't have a static one.

--
Thanks!

Bigul

January 8, 2019 at 8:19 am #3065800

nicoB-10

Ok, please try again.

January 8, 2019 at 2:48 pm #3067493

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I can log in to the site now and tried to replicate the issue in a fresh installation with the same settings, but it works fine.

Therefore please upgrade to latest version of Yoast SEO plugin after site a backup and make sure the issue is existing or not.

If you are still having the issue, please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

January 9, 2019 at 10:48 am #3070838

nicoB-10

yeah, make a copy and try it. Go ahead

The topic ‘[Closed] OG:URL canonical (perma link) wrong language’ is closed to new replies.