Please make sure to update to WPML to the latest and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 4 voices.

Last updated by Beda 4 years, 11 months ago.

Assigned support staff: Beda.

Author Posts
March 19, 2015 at 3:11 pm #582251

malcomt

Hello!
When I start this website with woocommerce, my default language is italian. After installing WPML I change the default language in EN, but I found more word in italian, (see attachment).
How do I fix?

Thanx

March 19, 2015 at 3:54 pm #582298

Selena

Hi Malcom,

I will handle your request, but this is the English support, I will post the reply in two languages.

If I understood you correctly several strings are in Italian when they should be in English, is it correct?

Before to go ahead and make changes to the WooCommerce strings, I would suggest to create the PO file.
In order to create the WooCommerce PO file,please “Create PO file” that you can find in
WPML >> Theme and Plugins localization
scroll down to “Strings in the plugins” select “Create PO file” for “WooCommerce”.

Now, Can you please try to delete one of this string (the one in the screenshot should be fine) from the table in:
WPML >> String Translation
and go to:
WPML >> Theme and Plugins localization
scroll down to “Strings in the plugins” select “WooCommerce” and proceed with a scan?

Then hit the “View all the plugin’s texts” to see if the string is then present in the right language.

Se ho ben capito, solo alcune delle stringhe sono in italiano quando dovrebbero invece essere in inglese. sbaglio?

Prima di andare avanti, vorrei che tu creassi, per sicurezza, il file PO del plugin WooCommerce.
Per far ciò, potresti andare in:
WPML >> Theme and Plugins localization
nella sezione “Strings in the plugins” potresti selezionare “Create PO file” per il plugin “WooCommerce”?

Adesso, potresti cancellare una delle stringhe (anche quella che mi hai mostrato nello screenshot) dalla tabella in
WPML >> String Translation
poi, potresti andare in
WPML >> Theme and Plugin localization
nella sezione “Strings in the plugins” seleziona “WooCommerce” e procedi con una nuova scansione.

Clicca “View all the plugin’s texts” di "WooCommerce" e verifica se la stringa che avevi cancellato è presente nella lingua corretta.

il problema è risolto?

March 27, 2015 at 2:19 pm #589431

malcomt

Ciao Selena…my problem is here.
On the string "Grazie per il tuo ordine" not found, but when I complete an order in EN shop, the e-mail arrive with italian text…see image!
how do I?

Thanx

March 27, 2015 at 3:15 pm #589483

Maciej

Hello,

My name is Maciej and I will help you to solve your problem.

I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

I would also recommend to backup your database and website first before we proceed. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Thank you!

March 30, 2015 at 10:26 pm #590903

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch ) Italian (Italiano )

Hello Malcom

Since Maciej is away for a few Days, I will take care of this thread.
I hope this is OK for you.

I understand you have WOooCommerce Multilingual Email Notification Strings that appear in the Wrong Language in WPML > String Translation and are also wrong in the WooCommerce Emails.

To solve this, please head to Dashboard > WooCommerce > Settings > Emails and change all Strings that now are in Italian to English

Please before that make sure to have this line as exactly follows below in your wp-config.php file:

define ('WPLANG', '');

Please then head to WPML > String Translation and check if the strings are now in English, and if they re correctly translated to Italian.
In case they aren't, delete the problematic Strings.

In WPML > Theme and Plugin Localization you will then need to scan the Plugin WooCommerce for new strings

Then you can translate them form English to Italian in WPML String Translation again.

This should solve the issue.

Please let me know if the issue persist.

Thank you

The topic ‘[Closed] Old Italian language default’ is closed to new replies.