This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 12 replies, has 3 voices.

Last updated by Bigul 8 months, 1 week ago.

Assigned support staff: Bigul.

Author Posts
January 22, 2019 at 4:15 pm

carolinev-8

I am trying to: see my media files and comments

Link to a page where the issue can be seen: It's only on backend in WordPress

I expected to see: media files and comments

Instead, I got: they're not showing up in their folders/lists. But newly uploaded images are showing up.

We had another chat going about this (please check back through our history to see what I've done in the past to try and rectify this, before asking me to do a lot of the same actions again), but it unfortunately got closed because I was on vacation and my client didn't know how to handle the requests.

Since new images in the media folder show up, I feel like there's an issue with old stuff not being translated, and if they're not translated, they "disappear" (but only from backend). The images and comments show up on the frontend of the site itself, but we can't see them on backend. If I turn OFF WPML Multilingual CMS plugin, I can see the media files again. So that specific plugin is the issue.

Please advise as to next steps, thank you.

January 23, 2019 at 3:23 am #3118875

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

I can see that you have previously opened a ticket here: https://wpml.org/forums/topic/media-files-are-no-longer-showing-since-update/ I hope you are mentioning about the same ticket

I also hope that you have already tried all the suggestion made by our previous supporter and still the issue exists.

Most of the time, when the items don't show up properly in the backend but show in the front-end this happens due to the entries being not set properly, we have a great troubleshooting page where we can fix this types of issues, so, could you please follow the below steps and let me know if this helps:

1) Backup your Database

2) Go to WPML-> Support ->Troubleshooting and click the below buttons
+ Set Language information
+ Clear Cache in WPML
+ Fix element types collation
+ Assign translation status to duplicated content

Let me know if this helps.

Thanks

January 25, 2019 at 1:20 pm #3129070

carolinev-8

Hi Shekhar,

Yes that's the original ticket.

I couldn't find the "Troubleshooting" page. It isn't under the support, so I tried searching it (no luck) and searching the individual items you listed, which brought up some old solved tickets, but not exactly direct answers. I've tried a couple things from what I found:

1. In WPML - Settings - Post Types Translation, I selected Not Translatable for Media (attachment). That enabled me to see the media files in the media folder again, BUT the two images we uploaded since this issue started are showing 3x. I think this isn't the best solution, please advise on a better one.

2. In WPML - Theme and Plugin Localization - I selected "Themes und Plugins nur mit WPMLs String Translation übersetzen (Keine .mo-Dateien laden)" as something in your support recommended that adjustment for String Translation and speed of the website. It hasn't had any change on the Media folder contents, and I still can't see the comments that we have. It lists the comments as (1), but I can't see it unless I turn off WPML plugin.

Can you please direct me (with a link) to this Troubleshooting page or direct links to the directions I should try, or PLEASE just login and fix this for us. I provided my details to you already. All this fussing and searching around costs my client for my time by the hour and it would be much faster if you just do it. We are paying for a premium (yet very fussy) plugin and I'm getting frustrated with the level of service you're providing for that cost. This has gone on for over a month already, and I suspect it's a very easy solution that you could find much faster than I can.

Thank you for your time.

January 28, 2019 at 2:53 pm #3136112

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I am Bigul from WPML support team. Shekhar is on vacation now. So I am taking care of this ticket. Hope it will be okay for you.

Thank you for the details. Please visit WPML>>Support page and click on *Fehlerbehebungs* link on the middle of the page to visit Troubleshoot page. Check the attached image for more details.

If we choose *Translate* option the Media post type, the media files are not listing in Media>>Media Library?

Please share with me the WordPress debug.log (not WPML debug information) for more details. Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

January 30, 2019 at 2:22 pm #3144307

carolinev-8

Hi Bigul,

I've tried it again and no, technically the media files don't show up - but I noticed something new. If I choose "Translatable - show only translated elements" OR "Translatable - Use translation, if available, or use standard language", the media files don't show up when I'm in Dutch and German mode. They DO show up in English mode though (in dashboard obviously, none of this affects the front end look of the site). We have only those 3 language modes.

The comments section shows 1 comment, but it's not visible at all in any language mode unless I turn off the WPML plugin.

I'm keeping Media on Non-Translatable until this is fixed, so that everyone can access the files.

I had already changed the wp-config.php file back in December, please see attached code screenshot.

Here's the link to my debug.log file: https://pastebin.com/pNE0ZYrb

I hope this is enough to have you solve this issue. We're really losing patience with this. If you can't see the issue from the debug log, I would ask AGAIN that you please login to our site and fix this directly. This costs my client by the hour for me to fuss around with YOUR plugin.

Thank you.

January 31, 2019 at 9:18 am
February 1, 2019 at 1:07 pm #3151652

carolinev-8

Hi Bigul,

Ok I will set the site to transfer over on Monday and update you at that time.

Thank you for your help!

February 1, 2019 at 6:46 pm #3152974

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Take your time. We will wait for your feedback.

--
Thanks!

Bigul

February 4, 2019 at 5:35 pm #3158938

carolinev-8

Hi Bigul,

I've completed the migration of the site. Please let me know what you find when you take a look.

Thank you for your help.

February 5, 2019 at 1:44 pm #3162198

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates and migration process. I am trying to reproduce the issue on our Cloudways test space now.

I have activated WPML Media plugin and set *Translatable - only show translated items* or *Translatable - use translation if available or fallback to default language* option for the *Media* post type. Then only 12 media items are listing in Media>>Library.

When the *Not translatable* option is selected for the *Media* post type it is showing 119 items in Media>>Library. Please check the attached images for more details.

This is the main issue you are facing, am I right? Please let me know if I missed anything.

--
Thanks!

Bigul

February 5, 2019 at 5:13 pm #3163044

carolinev-8

Hi Bigul,

Yes that's the problem. Anything that we've uploaded since the update of all our WPML plugins seems to show up, but the old stuff doesn't - not being translated or something. The comments also don't show up unless you completely turn off the WPML Multilingual CMS plugin (there's only one comment there, but you can't see it). Also we don't usually have the WPML Media plugin on - is that important or helpful at all? The website wasn't using it and didn't even have it downloaded before the update. I downloaded it thinking it might solve this media folder problem, but it didn't.

Let me know if you need any other information, thank you!

February 6, 2019 at 6:12 am #3164274

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. I am not able to reproduce the following issue exactly. So please share more details or the steps to replicate about it.

The comments also don't show up unless you completely turn off the WPML Multilingual CMS plugin (there's only one comment there, but you can't see it)

WPML Media plugin is required if you are using media items in the secondary language or translate the media data(like caption). It will create an extra entry in the database to sync the media item in the secondary language. It will not make any file duplication. Please check the following documentation for more details.

https://wpml.org/documentation/getting-started-guide/media-translation/

Just to make sure, which version of WPML you were using before upgrading to the latest version.

--
Thanks!

Bigul

February 12, 2019 at 1:43 pm #3188839

carolinev-8

Hi there Bigul,

My client and I are discussing the continued use of your plugin. It's too fussy for the simple things we need it to accomplish.

Let's forget about the comments right now, they're not important.

I don't know what version was being used before we updated, as I was brought onto this project just before we updated and didn't make a record. My client had originally bought the plugin when it was a one-time set fee, but then it was changed to a yearly fee and they weren't aware of the change. So I had them purchase the plugin again, we updated everything and here we are, with the media file folder not working properly.

The Media plugin wasn't used in the past, so I didn't know it was required to translate the images. It wasn't being used before we updated everything, so I didn't think it was required. The media files were visible without it.

We have a new issue now - the WPML Media, String Translation and String Management plugins won't update. I've attached an image of the errors for your review. Are you able to help us with this AND the media file folder issue? Because I can't properly correspond with you about the media files if the plugins won't even update.

This is getting very frustrating and my client is considering dropping WPML and switching to another plugin if this can't be resolved quickly.

February 12, 2019 at 6:12 pm #3190295

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details. We will try our best to solve this issue as early as possible. Please try the following steps to upgrade to the latest version of WPML after a full site backup. Then check the issue is existing or not.

1) Visit Plugin commercial page
2) Click on *Check for updates* button
3) Visit plugins list and click on *update now* link
4) If you are still having the issue, Visit Plugin commercial page again
5) Unregister the subscription
6) Visit WPML.org>>My Account>>Sites
7) Delete the existing site subscription and create a new site key
8) Visit Plugin commercial page and register with new site key
9) Make sure you can upgrade to WPML 4.2.1 version or not

--
Thanks!

Bigul

The topic ‘[Closed] Old Media files and comments don't show up since the update’ is closed to new replies.