This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
There's an warning message on a page with a image carousel - Warning: Illegal offset type in isset or empty
Solution:
Just simply go to wp-content/plugins/acfml/classes folder through FTP, edit the file called class-wpml-acf-attachments.php and edit the line 13 from this:

if ( is_serialized($value) ) {

to this

if ( is_serialized($value) || is_array($value) ) {

Tagged: 

This topic contains 13 replies, has 3 voices.

Last updated by Radu 5 months, 3 weeks ago.

Assigned support staff: Radu.

Author Posts
April 11, 2019 at 5:32 pm

marnixv-2

I am trying to: have a page without errors

Link to a page where the issue can be seen: hidden link

I expected to see: no error

Instead, I got: This on a page with a image carousel - Warning: Illegal offset type in isset or empty in /var/www/vhosts/purestories.nl/httpdocs/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-element-translation.php on line 247 Warning: Illegal offset type in /var/www/vhosts/purestories.nl/httpdocs/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-element-translation.php on line 258 Warning: Illegal offset type in isset or empty in /var/www/vhosts/purestories.nl/httpdocs/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-element-translation.php on line 262

April 12, 2019 at 4:39 am #3594929

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Thank you for reaching out the WPML support!

Can you install the plugins mentioned at the top of this page hidden link and tell me if the warning message is still appearing, please?

Also, please deactivate all the plugins except for WPML, activate a default theme (like Twenty Nineteen), and tell me if the warning is still there. I just want to make sure that this issue is not cause by one of the plugin or even by the theme.

Thanks,
Radu

April 12, 2019 at 9:51 am #3597331

henrikK-7

Having the same issue on ACF gallery with fancybox. After updating: acfml, sitepress-multilingual-cms, wpml-media-translation, wpml-string-translation and wpml-translation-management. Worked before that.

Following the soulution.

April 12, 2019 at 10:00 am #3597395

henrikK-7

I found that it was acfml 1.2 that is causing this issue, I went back to acfml 1.1 and everything is working as expected.

April 14, 2019 at 6:31 pm #3608493

marnixv-2

Dear Radu,

1. The plugins mentioned on top of the page, are payed plugins. They are not in my package.
- WPML Translation Management (Installeren | Downloaden)
- WPML String Translation (Installeren | Downloaden)

2. I installed template Twenty Nineteen, the warning is not there, but also the slider is not there. Do you know if there is a slider in the wenty Nineteen theme?

Tomorrow I check the disabling of all the plugins.

Are there more people with the same issue, henrikK-7 had, but it's an other plugin problem I think.

Looking forward for your reply.

Marnix

April 15, 2019 at 5:00 am #3609765

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Marnix,

I think that this is happening only when you're having a custom image field created using ACF and display the image on the frontend. I tried to replicate this issue on my side but I had no luck with that. In this case, could you send me a duplicator package of your website so I can check this a bit closer and see what might cause this issue, please?

Thanks,
Radu

April 15, 2019 at 8:11 am #3610865

marnixv-2

Hello Radu,

Nice to fix this quick.

1. When I disabled 'WPML Multilingual CMS' there are no errors.
2. I tried to clone my website, but it's also without the large files 500+ MB. Is there another solution? I gave you the ftp inlog a website login, maybe you can look arround.

Looking forward,

Marnix

April 15, 2019 at 11:48 am #3613153

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Marnix,

As a temporary fix, you can downgrade the ACFML plugin to version 1.1 as Henrik suggested. You can easily download the previous version from here https://wpml.org/download/acfml/?section=changelog and install it manually on your website (by removing the existing version and installing the one that you just downloaded). Our developers team is already checking this out and we'll try to come out with a fix as soon as possible.

Thanks,
Radu

April 15, 2019 at 1:00 pm #3613581

marnixv-2

Dear Radu,

The Downgrade did the job for the moment. I wait for the fix.

Thank you for your help.

Marnix

April 15, 2019 at 1:36 pm #3613789

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Marnix,

I'll keep you posted about the progress we're making on this (and come back with an early fix, if possible).

Thanks,
Radu

April 19, 2019 at 1:29 pm #3646071

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Marnix,

I have some updates about this issue. You can update back the plugin to the latest version. Once you've done that, just simply go to wp-content/plugins/acfml/classes folder through FTP, edit the file called class-wpml-acf-attachments.php and edit the line 13 from this:

if ( is_serialized($value) ) {

to this

if ( is_serialized($value) || is_array($value) ) {

You can do this change and tell me if things are back to normal. This fix will definitely be included in the next update of the plugin but this is an early fix so you don't have to wait for the update.

Thanks,
Radu

April 29, 2019 at 5:53 pm #3705935

marnixv-2

...

Thanks for your help!

Marnix

April 29, 2019 at 6:31 pm #3706133

marnixv-2

Yes, this did the job. For now :o)

Thnx

April 30, 2019 at 6:27 am #3708181

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Marnix,

I'm glad to hear that everything is back to normal now.

Best regards,
Radu