This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: On the homepage I have a couple of links behind buttons. In the English version of this page the links directly forward the user to the German version. How can I change that?

Solution: I follow this steps to solve the issue: - I went to WPML -> Translation Management -> Custom XML Configuration -> Added the shortcode of the button with the attribute 'url' and 'text' -> Save the changes. - I edited the frontpage -> Made a minor change and save it.

Relevant Documentation: https://wpml.org/documentation/support/language-configuration-files/

This topic contains 10 replies, has 2 voices.

Last updated by Carlos Rojas 1 year, 5 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
April 24, 2018 at 7:35 am #1781127

christophB-19

Hi there,

On the homepage I have a couple of links behind buttons. In the English version of this page the links directly forward the user to the German version. How can I change that?
Unfortunately I cannot change it in the translation settings of the page

Link to a page where the issue can be seen: hidden link

Click on Public Transport | Cities or on any other read more Button and you will be forwarded to the German version

I expected to see: The English version e.g.: hidden link

Instead, I got: hidden link

Thanks for your help in advance.

How and where can I change that?

Best,

Christoph

April 25, 2018 at 12:58 pm #1810097

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello Christoph,
Thank you for contacting WPML support.

1.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

May 3, 2018 at 7:44 pm #1965648

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Christoph,

Giving me access is usually the fastes way to solve the issue, as I will be able to check the WPML settings in the backend and see the buttons elements in the edit screen of the frontpage.

However, I suspect this issue is the same that the one from the following link: https://wpml.org/forums/topic/option-to-translate-call-to-action-and-its-page-redirection-in-salient-theme/

I would like to ask you to follow the steps provided in the ticket above and let me know if the issue is solved.

Looking forward to your answer.
Best regards,
Carlos

May 4, 2018 at 1:44 pm #1976157

christophB-19

Hi Carlos,

Please check the private message again, you will now have access to wordpress. Looking forward to your thoughts. Please keep in mind, that I did not make a backup yet.

May 4, 2018 at 4:44 pm #1979135

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Christoph,

Thank you very much for giving me access to the site. Before I continues I kindly ask you to create a backup of the entire site for security reasons. I won't be making any important change, but is still a good practice to make the backup before hand.

Looking forward to your answer.
Best regards,
Carlos

May 17, 2018 at 8:51 am #2170506

christophB-19

Hi Carlos,

I am very sorry for the late response. I have been on holidays a couple of days. Backup is done now once every day. Feel free to check the page.

Best,

Christoph

May 17, 2018 at 5:37 pm #2180617

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Christoph,

I follow this steps to solve the issue:
- I went to WPML -> Translation Management -> Custom XML Configuration -> Added the shortcode of the button with the attribute 'url' -> Save the changes.
- I edited the frontpage -> Made a minor change and save it.

Now you can translate the url of the buttons of the frontpage in the Translation Editor.

To find more information about Language Configuration Files you can visit this link: https://wpml.org/documentation/support/language-configuration-files/

Best regards,
Carlos

May 18, 2018 at 10:01 am #2188692

christophB-19

Hi Carlos,

it works perfectly. But now I have the problem that the buttons on the mainpage (nextbike startseite) are gone (nectar_btn: text) in the WPML editor and are therefore not editable anymore. I can't find them nowhere.

Can you check that please?

Best,

Christoph

May 18, 2018 at 4:54 pm #2190747

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Christoph,

It seems this was an honest mistake. I didn't add the 'text' attribute in the Custom XML Configuration option for this shortcode.

I just did the necessary changes and to translate this text you just need to make a small change in the button in the original language and save it. Then translate the page to English and you will see the texts in the Translation Editor.

Regards,
Carlos

May 22, 2018 at 6:14 am #2205152

christophB-19

Hey Carlos,

super fast and good work.

Thank you so much!

Best,

Christoph

May 22, 2018 at 11:25 am #2207669

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Christoph,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos