This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Noman 5 months, 3 weeks ago.

Assigned support staff: Noman.

Author Posts
April 21, 2019 at 12:16 pm #3652373

hugog-7

Hi, we have deployed the site on daglianlaw.com and are experiencing the same issue where the logo doesn't change. I have made the changes you made above. Any idea?

April 21, 2019 at 12:35 pm #3652433

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

1. Please make sure your live site minimum requirements for WPML meet:
https://wpml.org/home/minimum-requirements/

2. In most cases a string is not fully enabled and this is due to too many options being saved at once on that page. To fix this issue, please increase MaxInputVars to 10000 or more. For this, please try to set these variables in your php.ini:

max_input_vars = 10000;
suhosin.post.max_vars = 10000;
suhosin.request.max_vars = 10000;

You may need to contact your hosting provider to set them.

- After increasing max_input_vars value you need to tick all the required strings from WPML >> String Translations >> (at the bottom of page) “Translate texts in admin screens” >> and click on “Apply” button.

- Then please go to WPML >> String Translation and you will see newly enabled values at the top of the page and ready for translation, add the translation for those strings and check Translation is complete checkbox and press the Save button.

3. If still issue persists, please add the debug report in the Debug Information box. I have also enabled debug info box for your next reply: https://wpml.org/faq/provide-debug-information-faster-support/

Thank you

April 22, 2019 at 4:59 pm #3657235

hugog-7

So I did further troubleshooting and what I discovered is that this issue is occurring when the "A different domain per language" setting is on (we're using 2 domains).

I turned it off and reverted to "different languages in directories", and the logo switches fine now. But when I add in the spanish domain (hidden link) is suddenly doesn't switch to Spanish at all, even though that domain is parked on daglianlaw.com - any insight?

April 23, 2019 at 9:01 am #3660993

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

1. Only logo translation does not show when using "A different domain per language" setting? OR other translations are also missing?

2. Were you also using same settings "A different domain per language" on the Test site where we fixed it earlier?

Thanks

April 23, 2019 at 4:04 pm #3665975

hugog-7

1. all translations stop displaying on the front end

2. Yes, same settings. It's an exact duplicate.

April 23, 2019 at 4:14 pm #3666055

hugog-7

Further troubleshooting shows that this domain issue only effects the homepage. daglianlaw.com

April 23, 2019 at 4:16 pm #3666059

hugog-7

I take that back - the domain switches fine on internal pages, but the translations don't load.

April 24, 2019 at 9:05 am #3670785

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To further debug logo translation issue, please provide temporary access (WP-Admin login info) to your site, so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

The topic ‘[Closed] On Live server – WPML String Translation Cannot Find Logo’ is closed to new replies.