This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
User cannot change language on mobile devices but in desktop can.

Solution:
try to add this css code to WPML > Languages > Language switcher options > Additional CSS

@media only screen and (max-width: 768px){
 .rigid-social ul { z-index: -10000; }
}

This topic contains 2 replies, has 2 voices.

Last updated by krasiD 1 month, 3 weeks ago.

Assigned support staff: Riffaz.

Author Posts
August 24, 2019 at 12:14 pm #4451579

krasiD

I am trying to: Switch language from mobile devices to English from language switcher.

Link to a page where the issue can be seen: hidden link

I expected to see: To switch language

Instead, I got: İ cannot change language on mobile devices but regular resolutions i can.

August 25, 2019 at 6:02 am #4453295

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

This is because your theme brings the other elements like social share layer to the front.
So the languauge switcher layer goes behind it. so we are unable to click it.
So this should be fixed by your theme support.

Anyhow, try to add this css code to WPML > Languages > Language switcher options > Additional CSS

@media only screen and (max-width: 768px){
 .rigid-social ul { z-index: -10000; }
}

This should fix the issue.
If not, please check this with your theme support.

Regards,
Riffaz.

August 25, 2019 at 9:05 am #4453715

krasiD

My issue is resolved now. Thank you!