This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Bruno 3 months ago.

Assigned support staff: Bruno.

Author Posts
July 16, 2019 at 5:38 pm #4222977

katjaN-2

I translated everything, but when I look on the website on most translated pages there are nog photos and no lines and colors.

Example:
> English, with the layout as it should be: hidden link
> Spanish, without photos and other layout elements: hidden link

I think I already did everything stated here: https://wpml.org/forums/topic/missing-photos-is-translated-page/

Only the homepage seems to be fine...

Hope you van help me out! Thank you in advance!

July 16, 2019 at 8:29 pm #4223815

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. As you have already followed the default steps of the other topic, I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please let me know exactly what steps should I follow to see the problem.

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

July 17, 2019 at 8:30 pm #4233363

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. I was able to replicate the problem you are reporting. To fix the problem, I followed the steps below:

* Note that I have already followed the steps below, but I am detailing for you to know what was done.

- Click on the WPML > Settings > Custom XML Configuration
- Insert these lines - between the tags "shortcodes":

        <shortcode>
            <tag>vc_column_inner</tag>
            <attributes>
                <attribute>css</attribute>
            </attributes>
        </shortcode>

- Open the desired page on the default language
- Click on the "Update" button
- Click to edit the translation
- On the "css" field, copy and check the "Translation is complete" (if the translation is not changed (for example, the css field is not displayed), make some small changes to the original content and update again. Then edit back to the expected content)
- Click on the Save & Close button

After following these steps, the images were displayed correctly. Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

July 17, 2019 at 10:30 pm #4233665

katjaN-2

Thank you so much! However, the problem still exists. I emptied my chache and let check another person on an another computer and she also still not sees the pictures and colors. I upload 2 images: 1 with and 1 without the pics and colors.

Hope you can help!

July 17, 2019 at 10:54 pm #4233751

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

As I explained above, you need to save the original content and then save the translation. If the problem persists, then you need to make some minor changes to the original content and then click on the "Update" button.

If you make any changes to your original content - such as adding a letter in the default language, then you can remove the change and save the content again by clicking on the "Update" button.

Finally, you will see the "css" field inside the Translation Editor and you just need to check the "Translate is complete" option and click the "Translate is complete" button.

In summary, you should follow the steps below for the translations that have this problem:

- Open the page on the original content
- Change the title, for example, insert "2" after the title - this is required for the css field to be displayed on the Translation Editor
- Click on the Update button
- Remove the "2" from the title and click on the Update button again
- Click to edit the translation
- Look at the "css" field and copy its content to translation
- Check the "Translation is complete" box
- Click on the Save & Close button

After following these steps, the page will display correctly. I'll add some pictures for you to see.

Thank you.

July 22, 2019 at 6:12 pm #4260737

katjaN-2

Thank you so much for your help, now it works perfect! Also sorry for my late response, I was away the weekend 🙂

July 22, 2019 at 6:14 pm #4260739

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Glad to hear that it now works. Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.