This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Bruno 5 months, 1 week ago.

Assigned support staff: Bruno.

Author Posts
May 1, 2019 at 4:20 pm #3718901

janv-51

Good Day

I am trying to sort out on-page SEO issues using WPML and All In One SEO Pro. For some reason, a couple of pages are showing up with duplicate page titles and meta descriptions, when I know for a fact I have set them differently. The multi-lingual on-page SEO works for some pages and for some it doesn't

Website: hidden link

As an example, the home page has duplicate page titles and meta description for all 3 languages, although in the background, each one has been set independently.

I can provide admin access if required

May 1, 2019 at 8:07 pm #3719729

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you for contacting us. Are you translating the content into any "All In One SEO Pro" option or within the Home Page itself?

I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

May 2, 2019 at 8:55 pm #3729221

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. To translate these strings, you must use String Translation. Even though it's inside the content page, All in One SEO uses the string that's set up in the plugin's options. I'll attach two pictures for you to see.

That is, even the possibility of configuring these strings within the page, All in One SEO uses the strings that are configured in the plugin options. That way you need to translate this content using String Translation.

Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

May 3, 2019 at 4:03 am #3730615

janv-51

Hi Bruno

Thank you for the response.

I will try the string translator out over the weekend and revert back to you.

What is interesting though is the fact that I did not use the string translator (as per your pics) to provide page titles and meta descriptions for other pages, yet they are working fine - i.e. they have the correct page titles and meta descriptions related to the applicable language.

How can I make this process easier in the future?

It would ultimately be easier to manage all on-page SEO from the actual page, as one would do with a single language website.

Kind Regards
Jan

May 3, 2019 at 4:15 am #3730697

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

This should only be necessary on the homepage. By default, there are two ways to use a homepage in WordPress: static page or standard, page with posts entries, such as "blog".

The author of All in One SEO probably kept for the homepage both changes in the same place, which would be the plugin's option page. So this problem should be happening only on the homepage and not on the other pages, which should work simply by translating the content as you are doing now.

For this reason, to translate this title content and description only from the homepage, you must use String Translation.

Thank you.

May 7, 2019 at 4:28 am #3753795

janv-51

Hi

This seems to have solved the home page issue, but I am still having some on-page SEO related problems on other pages.

For certain pages, page titles and meta descriptions are still showing up as duplicate, even though they are not. It would appear as though something is happening with WMPL, where there is no hreflang "flag" to indicate that the page is in a different langauge.

When editing the page, I have set each page's aio_seo attributes to the correct language, and ticked the box which says the translation is complete.

This should in theory work right?

Is there something I am missing w.r.t how to manage on-page SEO between AIO SEO Pro and WPML?

May 7, 2019 at 8:31 pm #3761815

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Glad to hear that homepage metadata now works.

About the problem, you are reporting, which pages are still experiencing this problem?

Also, where are you seeing these SEO issues? Are you looking at metadata directly on your site or just in Google Console?

Thank you.

May 9, 2019 at 4:00 am #3772905

janv-51

Hi Bruno

I make use of a tool called "Screaming Frog SEO Spider" which crawls through a website and pulls through all on-page SEO elements - making it easy to spot any potential issues.

Issue 1
In terms of implementing on-page SEO, the Page Titles and Meta Descriptions for the "main language" (I my case English) is added when viewing the page - please see screen shot 1. Once that is complete, I click on the "Translations" to the right of the screen shot 1, which takes me to the translation for Portuguese as example (screen shot 2).

As per Screen Shot 2, at the top of the page are the fields "aiosepp_title" and "aioseop_description". The translated page title and meta description is placed here. It is my understanding that when the "Translation is complete" box is ticked, the page title and meta description should be saved correctly, and then display correctly as well.

Am I missing something w.r.t how on-page SEO should be managed?

Issue 2
I did some further investigation into the home page, and it looks like the approach above did indeed not work correctly. All three pages/languages for the home page are reporting duplicate page titles and meta descriptions. This is persists after the same approach from "Issue 1" was taken, and after which the String translation approach was completed as suggested.

Can you please provide with some guidance?

May 10, 2019 at 2:00 am #3780085

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

According to issue 1, note that it is necessary to translate all of the content in the Translation Editor for the changes to take effect. I noticed that I had some still incomplete translations (images). After marking all the fields as "Translation is complete", the translations were displayed on the front end correctly. Please see the attached image (page-br.png).

On issue 2, when you make any changes to All in SEO options, you will need to re-access String Translation to mark the translation as complete (homepage-description.png and homepage-title.png). Also, make sure that the translations of the Home Page strings (title and description) should be done in WPML > String Translation.

In short:

- For the homepage, the settings should be changed within the options of the "All in One SEO" > "General Settings" > Home Page Settings. Here it is necessary to keep the string in the default language, in this case, English.

- All translations must be done within WPML > String Translation for Home Page strings. Do not translate to the All in One SEO options page, even switching to the secondary language. This should not work that way. In this case, translations are only expected in WPML > String Translation.

- Within the other pages or posts, make sure to completely translate the page (selecting all "Translation is complete" ticks) for the translation to be displayed on the front end.

Thank you.