This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Noman 7 months, 2 weeks ago.

Assigned support staff: Noman.

Author Posts
March 5, 2019 at 8:19 am #3272077

bhanuS

Tell us what you are trying to do?
We are putting language switcher dropdown button on top menu, but it's coming like open.

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?

March 5, 2019 at 10:51 am #3273013

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

1. You are using older version of WPML plugins. Please backup your site and update ALL WPML plugins to it's latest versions, also update WooCommerce Multilingual plugin. You can download it from your account: https://wpml.org/account/downloads/

2. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

3. If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Thank you

The topic ‘[Closed] On Top Bar menu Language Switcher dropdown button showing list type’ is closed to new replies.