This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by robertoG-6 5 months, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
May 7, 2019 at 7:03 pm #3761475

robertoG-6

I am trying to: Translate a website

Link to a page where the issue can be seen: hidden link

I expected to see: A full image like hidden link

Instead, I got: I thought I might have to change the image and save, but it is not updated, I even deleted my cloudflare cache, the bg wouldn't be an issue if the bg size was the same, maybe you have a suggestion. Thank you.

May 7, 2019 at 8:56 pm #3761985

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support.

Could you please go to the page editor for the "About us" page and check the right sidebar. Locate the language options and make sure to mark the two checkboxes for the media attachments.

Now please update the page and translate it again. Does the image now appear?

Kind regards,
Andreas

May 7, 2019 at 9:00 pm #3762017

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I see now that the image is added but there is a design issue. The site has a different scale.

I can see that the homepage does not expereince the same issue.

Please try to retranslate the page including the media attachment option and let me know if the issue persists.

If this will not solve the issue could you please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.
More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Kind regards
Andreas

May 8, 2019 at 6:55 pm #3770251

robertoG-6

Well, I did as suggested, but it simply does not work, as you say, the homepage works as supoosed and was translated the same way, I've tried disabling all the plugins, except for those needed by the theme, I deleted my translations and did over again, then tried with the media checkboxes enabled and it was the same.

I do not know why I cannot delete the title image, if I do so, and save, the image is forced once again, if I try to use another one and save, the first one shows again.

Maybe I misconfigured something? Is it possible to uninstall and reinstall, so I can see the setup wizard once again? I tried disabling and deleting the db tables, but it did not work.

Thanks

May 8, 2019 at 7:40 pm #3770577

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

May 9, 2019 at 5:28 pm #3778421

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for the provided credentials.

Please take note that it is recommended to install our Translation Management Plugin in order to activate one of our WPML Translation Editors when working with page builder like WPBakery.

https://wpml.org/documentation/support/maintaining-wpbakery-page-builder-compatibility-with-wpml/

Once plugin is installed and active please go to WPML -> Settings -> How to translate posts and pages and activate the Classic Translation Editor or the Advanced Translation Editor.

Now please translate the page "About" again. Does the style issue still appear?

If this will not solve the issue please proceed as followed:

I was revising the WPBakery backend editor and I was not able to locate the banner with the title "About Alfonso G" and its background. Also inside of the theme options I did not locate it. Could you give me some more detail about how this section was built?

Next try to run the site in minimal setup to see if the issue persists.

Please disable any additional plugin that is not related to the theme, like WPBakery, and WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.
More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Kind regards
Andreas

May 10, 2019 at 11:01 pm #3788061

robertoG-6

I reset the site and configured WPML once again, I enabled Translation Management, however, I do not understand the: WPML needs to set languages to existing media in your site. [Set Media Languages]

What if I will use different images? I wouldn't need to duplicate those, no? Do you have an article to understand this feature, I cannot find it.

Now... I tested the translation once again, I see this warning, and it makes me guess, that's why I cannot change my image as I want.

It says WPML will copy it from the English page. And it does not matter if I add my page code and save, the default image from the English version is still imported.

Is this normal? Can it be disabled in WPML?

Thanks

May 13, 2019 at 4:35 pm #3800631

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

It seems to me the issue is theme related. Could you try to change to a default theme like TwentySeventeen and verify if the page is apopearing as expected? Also please compare the default Bridge theme with your Child theme.

If so, please install the Bridge theme on the following test site in order to test it for compatibility.

One Click Login: hidden link

It would be very helpful if you could try to recreate the isse here and leave me a short notification after.
If the issue can be recreated on a fresh install I will be able to escalate the issue to our compatiblity team.

Kind regards
Andreas

May 14, 2019 at 4:58 pm #3809297

robertoG-6

Thank you, indeed, it seems to be a theme issue, I am working on another one now, hoping this resolves my issue.