This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 3 voices.

Last updated by Marcos Vinicios Barreto 1 month ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
September 8, 2019 at 8:26 am #4530801

magnusJ-3

My demosite is hidden link but I will use the duplicator plugin to move this demosite to the "real" .com adress for the english version. And I want the Swedish version of that site to be .com/se

Because of that I have tried to change my Swedish version on the site to /se (not /sv which is preset for Swedish in WPML). Did I do this right? Or will google or someone else think something is wrong? Please see my attached image.

Also, I get this message: You need to configure at least one more language in order to access "Theme and plugins localization" and "Media translation".

Have I done something wrong when I get this message?

All the best,

Magnus

September 9, 2019 at 9:13 am #4535089

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

When you go to WPML->Languages do you see English(Default) and Swedish as the secondary language? or is Swedish the default language ?

once you have migrated your site to your live site you can change your URL format or even your default language from English to Swedish and vice versa

September 11, 2019 at 10:17 am #4552457

magnusJ-3

Hi! English is the default language, Swedish is secondary. But since WPML ads Swedish as .com/sv by default, and not .com/se as I would like it, I had to create a new language (a new Swedish) to get the .com/se
Perhaps I did the settings wrong, with the se_SE and Sv_SV and everything else? Please see the attached image. And why do I get the "You need to configure.."?

September 11, 2019 at 11:09 am #4552879

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

If possible i would like to take a closer look at the backend to further test this issue

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

NOTE: if access to the live site is not possible and staging site does not exist please provide me with a duplicator package created with the duplicator plugin

Thank you,
Bobby

September 13, 2019 at 7:11 am #4565975

magnusJ-3

Hi! The server is working fine again. Could you please have a look at this?

September 13, 2019 at 2:42 pm #4569537

magnusJ-3

Hi again!
I duplicated the site to another server, could you please look at the site there?:
hidden link
The wp user I sent you before is the same, but ftp is new. Please let me know if you need the new ftp aswell.
(The old ftp I sent you still works but goes to the .se site that I just duplicated to .com, so it has the exact same setup.

September 13, 2019 at 5:31 pm #4570257

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates and sorry for the bit of waiting here. I took a detailed look in your website and didn't notice anything wrong.

1 - Your custom language with the code 'se' is properly setup.

2 - Your url structure is defined as languages in directories properly so you can have something like 'yourdomain/se' for your custom language.

3 - Your theme and plugins localization settings are working properly.

See: https://wpml.org/documentation/support/editing-wpmls-languages-table/

Do you need any speficic assistance and clarifications? Please, let me know, have a nice day.