This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Bigul 1 month, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
August 30, 2019 at 1:07 am #4483969

iharP

primary language of my site is Belarusian, Russian is secondary. almost all categories synchronised correctly, but one didn't. there are 1633 posts in that category in Belarusian but 0 in Russian. category page in Russian is empty.
posts in this category are translated and published. cross-linking in every post works correctly. if I add new post to this category and translate, it shows in Belarusian and Russian categories correctly. but older posts only in Belarusian.

what can I do to synchronise old posts in this category?

August 30, 2019 at 8:56 am #4485413

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please visit WPML>>Taxonomy Translation page, then choose *Categories* taxonomy and check you are getting Sync Taxonomy button on the bottom of the screen or not.

If the button is showing click on it and make sure the Category term is synchronized or not.

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

--
Thanks!

Bigul

September 2, 2019 at 7:30 am #4494969

iharP

The button isn't showing, all Category terms are shown as synchronised. But problem still appears.
If it could be useful:
hidden link — this category in Belarusian.
hidden link — this category in Russian.

September 2, 2019 at 2:49 pm #4497957

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page

2) Click on Troubleshooting link (blue link in the middle of the page)

3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment

--
Thanks!

Bigul

September 3, 2019 at 7:42 am #4501743

iharP

I've tried all this steps, but issue didn't resolved 🙁

September 3, 2019 at 6:21 pm #4506909

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

The topic ‘[Closed] One of categories didn't synchronised’ is closed to new replies.