This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 5 months, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
April 29, 2019 at 2:07 pm #3704165

reneV-19

I am trying to translate the following page: hidden link.

When I want to translate the page I don't see al seperate rows what I can translate, but the whole visual composer code is paste in 1 block (current.jpg). The other pages of my website don't have that and just show it nice seperate all. (correct-other-pages.jpg) I expected to see it like that.

I'm using the theme Uncode.

ps: I tried to translate the page still just to change the code in that one block but it also take the contentblock of the homepage in the translation.

April 30, 2019 at 2:04 am #3707251

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

April 30, 2019 at 7:06 pm #3714421

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took a detailed look in your website and it is really weird how everything works properly for other pages but not for this one, please, try the following troubleshooting:

1 - Install the plugin https://wordpress.org/plugins/duplicate-wp-page-post/ and create a clone of this problematic page.

2 - Now delete all the content of the problematic page and add one section at a time, save it and edit its translations.

The steps above will help us to understand which block is messing the shortcodes translations in the WPML Translation Editor.

Note, you still have the option to edit the problematic page translation using the default WordPress page/post editor, in case you don't want to step in the troubleshooting above. See: https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

Please, let me know if you need any additional assistance. Have a nice day.

May 3, 2019 at 12:36 pm #3734229

reneV-19

I tried but it looks WPML is broken or something?

When I add a new page (test) with 2 rows of text content and I would like to translate it: I don't see any blocks to translate?

May 3, 2019 at 10:14 pm #3738239

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above. Thanks!

May 6, 2019 at 9:46 am #3746599

reneV-19

Oke I will try do it now. So these steps I have to make:

1. Install and configure my theme
2. Active and configure WPML
3. Add some dummy content
4. Try to translate this?

I also wanted to translate now a new website (also Uncode), same problem!

May 6, 2019 at 9:58 am #3746729

reneV-19

I did the above steps and then it works fine on your testsite

I also deactived all my other plugins on the website: same problem.

May 8, 2019 at 12:58 am #3762851

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a further look in your website setup in your server and in our test server and noticed you had defined 96MB as the maximum value for WordPress, it is not enough to offer compatibility with some page builders. I increased this number and now you are able to translate your page contents properly. See: https://wpml.org/home/minimum-requirements/. Please, let me know if any additional assistance is required. Have a nice day.

May 8, 2019 at 7:06 am #3764261

reneV-19

Works, superbe!

At another website I have the same problem, despite I also increased the memory limit to 256. Do I have to add another ticket for that?

May 8, 2019 at 3:09 pm #3768247

reneV-19

To come back to my earlier reply. The page HOME also still has the same trouble at mydrivesmyhabits?

May 9, 2019 at 12:40 am #3771719

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Regarding your questions:

1 - "At another website I have the same problem, despite I also increased the memory limit to 256"

You can experiment the same steps outlined in this ticket, if it doesn't solve your issue then you can proceed with a new ticket for the specific issue.

2 - "The page HOME also still has the same trouble at mydrivesmyhabits?"

Please, make a backup copy of your website so you can revert it back in case of troubles, then delete your current home translation and add a new one. Please, confirm if you still see the issue.

Hope it helps, have a nice day.

May 9, 2019 at 6:21 pm #3778731

reneV-19

Hi,

I prefer not to do q2 at mydrivesmyhabits.com because that takes really a lot of time what I can not ask back of my client. I did this at my other website (q1) and the problem remains. I deleted the plug-in and completely configured the plugin again.

Really looks like a conflict with Visual Composer?

Cheers,
René

May 10, 2019 at 1:07 am #3780023

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I wouldn't say it is a plugin conflict as we don't see it happening in the sandbox test environment we created before, instead it seems to be related with server resources as all other pages are back to work when the memory limit was increased. Here I recommend you to increase your current memory limit maximum value for WordPress to 512MB and confirm if it works (see https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP). Thank you for your collaboration, have a nice day.