This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by cooldeep 2 months, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 29, 2019 at 9:41 pm

cooldeep

Hi,

Earlier too I'd created a ticket for a similar issue: https://wpml.org/forums/topic/one-particular-nepali-word-automatically-being-replaced-by-an-english-word/#post-4303541. But since that thread seems to be closed now, had to open this new one.

In spite of repeatedly DELETING the translation, it works for a while, and then crops up again after sometime!!!

Please help me resolve this issue once and for all, as its getting too problematic/frustrating now!

July 31, 2019 at 6:30 am #4311783

cooldeep

Hi Marcos,

Any Update? It's more than one & half day now, that I've got any response regarding this issue?

July 31, 2019 at 12:35 pm #4314375

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support and sorry for the bit of waiting here. I tried to access your website with the provided WordPress Dashboard access details, but it seems I don't have permission to access your website, when trying it I get the message "You are not allowed to log in" from your login page. Could you review it please? I will enable a private reply for you, so you can safely resend these access details. Thank you for your collaboration and continued patience, have a nice day.

July 31, 2019 at 12:56 pm
August 1, 2019 at 3:24 pm #4323439

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took a detailed look in your website and noticed the weird string comes from your 'Broken Link Checker' and as these strings was set as 'auto register' in the strings translation settings your issue was persisting even after string deletation. Here are the steps I performed in your website in order to fix your issue:

1 - In your WordPress Dashboard > WPML > String Translation I unchecked the 'auto register' options for the 'Broken Link Checker' text domains, in these case the 'default' and 'broken-link-checker' domains.

2 - Then, I deleted the strings which was causing these issues, as the auto register is turned off it won't keep reappearing in your website string settings.

See: https://wpml.org/documentation/getting-started-guide/string-translation/

As a left step you will need to recreate your footer menu in order make a reset for the stored footer menu values in your database tables. Here is what you should try:

1 - Keep your WPML Multilingual CMS plugin deactivated (I forced a deactivation renaming the plugin folder as sitepress-multilingual-cms_OLD) in order to avoid a fatal php error due corrupted database menu values.

2 - Now in your WordPress Dashboard > Appearance > Menus delete all the existing footer menus. As WPML is deactivated you will notice both footer menus are listed under the menu selection dropdown.

3 - Now rename the WPML Multilingual CMS plugin folder back to its original name (sitepress-multilingual-cms) from your wp-content/plugins folder and activate it in your WordPress Dashboard > Plugins settings.

4 - Recreate your footer menu in the default language and add a translation for it according our instructions at: https://wpml.org/documentation/getting-started-guide/translating-menus/

Note: You would need to clear your browser cache or even server side cache in order to see the changes. I found the 'define( 'WP_CACHE', true );' constant in your wp-config.php file and I had to comment this line in order to see the changes.

Please, let me know if you need any additional assistance and clarifications. Have a nice day.

August 3, 2019 at 1:04 am #4332867

cooldeep

Hi,

Marcos I applied all your instructions. Not sure whether my issues have been resolved or not. I can only confirm this after sometime.

But now instead I've ended up with some more issues. I deleted the footer text from the string translation, and now they aren't repainting in the String Translation page. Earlier even if I deleted, and rescanned the theme in >> WPML >> Theme and plugins localization, it would resurface in the String Translation page but now it's not happening. And because of this I am unable to translate the footer strings.

Please view attached screenshots.

August 5, 2019 at 3:03 pm #4341497

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates and sorry for the waiting here due the weekend. I took a detailed look in your website and noticed the strings for the footer text of your theme options are appearing properly for translation as you can see in the attached screenshot.

Please, don't forget in some cases you would need to register the strings entered for theme options in your WordPress Dashboard > WPML > Strings Translation > Translate texts in admin screens just as our instructions indicate at: https://wpml.org/documentation/getting-started-guide/translating-theme-options/. Please, let me know if it helps, have a nice day.

August 5, 2019 at 3:35 pm #4341665

cooldeep

Hi Marcos,

Thanks for your support. Yes the issue seems to be resolved now, but it's due to the help of another Team Member of yours. I manually had to make those entries via Custom XML entries. Please check this link: https://wpml.org/forums/topic/all-footer-entries-of-tagdiv-newspaper-not-getting-displayed-not-translating/