Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Mihai Apetrei 1 year, 6 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
July 25, 2019 at 8:06 am


I am referring to the ITALIAN version of the following page: hidden link

If I open this page on mobile devices the section with the 4 Icons is displayed in English. If I open it on desktop it is displayed correctly as Italian. As far as I can see this error only occures in this section in this language on this particular page on mobile devices.

Any idea how we can solve that issue?


July 25, 2019 at 2:18 pm #4284123

Mihai Apetrei

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

The reason why you are seeing this happening is that there are 2 content blocks in the translated page (hidden link) that contain the same information in 2 separate languages and the first one is set to show only on the desktop while the English one is set to display only on mobile.

I think there are 2 options you can select from in this case:

1. You can set the correct one (translated) to display on all the devices and completely hide the second one

2. You can leave both of the content blocks to use the same settings and you can edit the second block that's in English and translate it accordingly.

From what I can see, the English one is set to have the icon boxes one under the other so that it looks nice on mobile so probably it would be better to just click edit on the English text and translate it.

Here is a gif that explains what I've said:
hidden link

I hope that you will find it helpful.

Please let me know if you still have questions or need help.

Kind regards,
Mihai Apetrei