This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by robinW-7 1 month, 3 weeks ago.

Assigned support staff: Dennis.

Author Posts
March 27, 2019 at 1:40 am #3467223

robinW-7

The google console reported me a redirect error on this url:
hidden link

This is a translated post of hidden link.
So I changed the slug of the translated post expecting to fix this error, here's the new url:
hidden link

But when I click the switcher on this page, it doesn't switch into the English post page as I imaged.
Could you please check this post for me?

Best regards.

March 27, 2019 at 8:15 am #3468489

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

Could you please try these steps and see if it resolves the issue?

Note: Please make sure to make a complete backup of your site before proceeding.

-Go to WPML>>Support page
-Click on Troubleshooting link (link in the middle of the page)
-In Troubleshooting page, please click on the following options of 'Clean up' section. Wait for confirmation of processing after each one.
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment

Re-save your permalink settings at Settings > Permalinks. Click 'Save Changes'

Does it help? Please let me know.

Kind regards,
Dennis

March 27, 2019 at 8:24 am #3468549

robinW-7

Hi Dennis, thank you for your help. I checked this post again before I try your steps, it's amazing the switcher works now, seems like a cache issue.
Thank you anyway.