This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: When using Jupiter Edge Slider add-on, the secondary language home page is not loading.

Solution: -Go to Edge Slider and translate the slides -Go to Pages and edited the English home page -In the Edge slider block of the English home page, delete the slides that were already assigned and select the new ones (the ones translated in the first step)

This topic contains 9 replies, has 2 voices.

Last updated by geraldC-2 2 years, 1 month ago.

Assigned support staff: Otto.

Author Posts
August 5, 2017 at 12:20 pm #1335794

geraldC-2

I switch from French to English from the homepage

hidden link

But the English version does not end up loading and never displays.
Yet all other English pages work fine ...

I do not understand why. I have no redirection plugin and there is no redirection running on the server ...
Please could you help me

August 6, 2017 at 12:04 pm #1335952

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you for contacting the WPML support!

The WP memory limit needs to be increased. PHP memory is fine but WordPress uses 40Mb as default. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Can you please increase the memory limit to 256MB:
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

Add this code to your wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

If the issue persists, can you please try the following test:
-Back up your site first
-Deactivate all the plugins that are not related to WPML
-Switch for a moment to a WordPress default theme like Twenty Fourteen.
-If the issue is gone, activate one by one to see with which one there is an interaction issue

Let me know your results, please.

Kind Regards,

Otto

August 11, 2017 at 11:39 am #1340159

geraldC-2

I tried everything you said. The problem doesn't come from an external plugin or of the theme himelf.
I use Jupiter theme and it use a component that is call 'Edge Slider'. It seems to be because of that. On my EN homepage if i disable the edge slider the english version page display.

What can you do about that ?

August 11, 2017 at 2:12 pm #1340316

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you for contacting the WPML support!

Thanks, we narrowed down the issue 🙂

Can you please update the Jupiter theme to the latest version (5.9.7) and check if the issue persists? Please backup your site before doing it.

If the issue persists, it would be good if you can provide me the WordPress debug.log.

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

In this case, the errors will be saved to a debug.log log file inside the /wp-content/directory.

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way, because sometimes the logs are long and create a complete mess in discussion).

Let me know your results, please.

Kind Regards,

Otto

August 12, 2017 at 11:01 pm #1340832

geraldC-2
[12-Aug-2017 20:08:51 UTC] PHP Warning:  require_once(/var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/classes/core/interfaces.php): failed to open stream: No such file or directory in /var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/js_composer.php on line 178
[12-Aug-2017 20:08:51 UTC] PHP Fatal error:  require_once(): Failed opening required '/var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/classes/core/interfaces.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/js_composer.php on line 178
[12-Aug-2017 20:08:53 UTC] PHP Warning:  require_once(/var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/classes/core/interfaces.php): failed to open stream: No such file or directory in /var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/js_composer.php on line 178
[12-Aug-2017 20:08:53 UTC] PHP Fatal error:  require_once(): Failed opening required '/var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/classes/core/interfaces.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/js_composer.php on line 178
[12-Aug-2017 20:09:53 UTC] PHP Warning:  require_once(/var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/classes/core/interfaces.php): failed to open stream: No such file or directory in /var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/js_composer.php on line 178
[12-Aug-2017 20:09:53 UTC] PHP Fatal error:  require_once(): Failed opening required '/var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/classes/core/interfaces.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/js_composer.php on line 178
[12-Aug-2017 20:10:30 UTC] PHP Warning:  require_once(/var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/params/hidden/hidden.php): failed to open stream: No such file or directory in /var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/autoload/params/hidden.php on line 10
[12-Aug-2017 20:10:30 UTC] PHP Fatal error:  require_once(): Failed opening required '/var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/params/hidden/hidden.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/autoload/params/hidden.php on line 10
[12-Aug-2017 20:10:37 UTC] PHP Warning:  require_once(/var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/params/hidden/hidden.php): failed to open stream: No such file or directory in /var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/autoload/params/hidden.php on line 10
[12-Aug-2017 20:10:37 UTC] PHP Fatal error:  require_once(): Failed opening required '/var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/params/hidden/hidden.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/autoload/params/hidden.php on line 10
[12-Aug-2017 20:10:51 UTC] PHP Warning:  require_once(/var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/params/hidden/hidden.php): failed to open stream: No such file or directory in /var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/autoload/params/hidden.php on line 10
[12-Aug-2017 20:10:51 UTC] PHP Fatal error:  require_once(): Failed opening required '/var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/params/hidden/hidden.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/autoload/params/hidden.php on line 10
[12-Aug-2017 20:10:52 UTC] PHP Warning:  require_once(/var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/params/hidden/hidden.php): failed to open stream: No such file or directory in /var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/autoload/params/hidden.php on line 10
[12-Aug-2017 20:10:52 UTC] PHP Fatal error:  require_once(): Failed opening required '/var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/params/hidden/hidden.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/autoload/params/hidden.php on line 10
[12-Aug-2017 20:11:07 UTC] PHP Warning:  require_once(/var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/classes/vendors/plugins/class-vc-vendor-wpml.php): failed to open stream: No such file or directory in /var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/autoload/vendors/wpml.php on line 9
[12-Aug-2017 20:11:07 UTC] PHP Fatal error:  require_once(): Failed opening required '/var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/classes/vendors/plugins/class-vc-vendor-wpml.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/autoload/vendors/wpml.php on line 9
[12-Aug-2017 20:12:51 UTC] PHP Warning:  require_once(/var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/classes/vendors/plugins/class-vc-vendor-wpml.php): failed to open stream: No such file or directory in /var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/autoload/vendors/wpml.php on line 9
[12-Aug-2017 20:12:51 UTC] PHP Fatal error:  require_once(): Failed opening required '/var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/classes/vendors/plugins/class-vc-vendor-wpml.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/autoload/vendors/wpml.php on line 9
[12-Aug-2017 20:13:07 UTC] PHP Warning:  require_once(/var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/classes/core/shared-templates/importer/wordpress-importer.php): failed to open stream: No such file or directory in /var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/classes/core/shared-templates/class-vc-shared-templates.php on line 6
[12-Aug-2017 20:13:07 UTC] PHP Fatal error:  require_once(): Failed opening required '/var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/classes/core/shared-templates/importer/wordpress-importer.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/classes/core/shared-templates/class-vc-shared-templates.php on line 6
[12-Aug-2017 20:15:07 UTC] PHP Warning:  require_once(/var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/classes/core/shared-templates/importer/wordpress-importer.php): failed to open stream: No such file or directory in /var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/classes/core/shared-templates/class-vc-shared-templates.php on line 6
[12-Aug-2017 20:15:07 UTC] PHP Fatal error:  require_once(): Failed opening required '/var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/classes/core/shared-templates/importer/wordpress-importer.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/vhosts/charles-frey.fr/httpdocs/wp-content/plugins/js_composer_theme/include/classes/core/shared-templates/class-vc-shared-templates.php on line 6
[12-Aug-2017 22:31:40 UTC] PHP Notice:  Undefined index: full in /var/www/vhosts/charles-frey.fr/httpdocs/wp-includes/media.php on line 3224
[12-Aug-2017 22:35:10 UTC] PHP Notice:  Undefined index: full in /var/www/vhosts/charles-frey.fr/httpdocs/wp-includes/media.php on line 3224
August 12, 2017 at 11:05 pm #1340833

geraldC-2

https://pastebin.com/hwaked37

August 13, 2017 at 2:34 pm #1340949

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thanks!

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

** IMPORTANT **

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:

hidden link

Kind Regards,

Otto

August 14, 2017 at 12:53 pm #1341689

geraldC-2

Please let me know if you need something else and where are your investigations, because my project is becoming urgent

August 14, 2017 at 1:22 pm #1341708

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thanks!

Please apologize for the delay, it was due to the weekend. You can check my working hours here: https://wpml.org/forums/users/otto-f/, so you can have an actual expectation about when I am going to reply.

I managed to solve the issue on your test site following these steps:
-I went to Edge Slider and translated one of the slides
-Then I went to Pages and edited the English home page
-In the Edge slider block of the English home page, I deleted the slides that were already assigned and select the new one (the one I translated in the first step)

Now it is working fine, as far as I can see. Can you please take a look and let me know if it is solved?

Kind Regards,

Otto

August 14, 2017 at 3:40 pm #1341863

geraldC-2

Hi Otto,
Thank you! It seems to be OK ! It was an so easy issue that I just did not think about going there.
Your plugin is really well done, and having support brings great quality. Thanks for all