This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 3 replies, has 2 voices.

Last updated by Bruno 1 year ago.

Assigned support staff: Bruno.

Author Posts
September 19, 2018 at 1:02 am

Shawn

I have WPML installed and activated, the language switcher is active and works.

When you are not logged into the website and choose the second language you get an error screen.

When you are logged in you can then see the second language.

I think it is a conflict with wpgeodirectory.

September 19, 2018 at 8:05 pm #2749914

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

I downloaded the Duplicator package you provided, but I could not replicate the problem in my testing environment.

Also, when I try to access the files on your FTP, the credentials appear to be correct, but the file list is not displayed.

Please, could you enable debug to see if any error message is displayed? To do it, please check the steps in our documentation: http://wpml.org/documentation/support/debugging-wpml/

Then try again to check the problem. If any error message appears, please paste here in the post for me to see.

Thank you.

October 1, 2018 at 3:59 am #2777096

Shawn

These are the errors I get when debug is enabled:

Notice: wpdb::prepare was called incorrectly. The query does not contain the correct number of placeholders (1) for the number of arguments passed (2). Please see Debugging in WordPress for more information. (This message was added in version 4.8.3.) in /home/rebuildcanada/public_html/wp-includes/functions.php on line 4161

Notice: wpdb::prepare was called incorrectly. The query does not contain the correct number of placeholders (1) for the number of arguments passed (2). Please see Debugging in WordPress for more information. (This message was added in version 4.8.3.) in /home/rebuildcanada/public_html/wp-includes/functions.php on line 4161

Notice: wpdb::prepare was called incorrectly. The query does not contain the correct number of placeholders (1) for the number of arguments passed (2). Please see Debugging in WordPress for more information. (This message was added in version 4.8.3.) in /home/rebuildcanada/public_html/wp-includes/functions.php on line 4161

Notice: wpdb::prepare was called incorrectly. The query does not contain the correct number of placeholders (1) for the number of arguments passed (2). Please see Debugging in WordPress for more information. (This message was added in version 4.8.3.) in /home/rebuildcanada/public_html/wp-includes/functions.php on line 4161

Notice: wpdb::prepare was called incorrectly. The query does not contain the correct number of placeholders (1) for the number of arguments passed (2). Please see Debugging in WordPress for more information. (This message was added in version 4.8.3.) in /home/rebuildcanada/public_html/wp-includes/functions.php on line 4161

When I try to switch to French I get the error 500. Right now I only have the french enabled for me as a user.

October 2, 2018 at 9:34 pm #2782881

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. When I access your website and click to switch to the secondary language using the language selector in the footer, even without being logged in the page loads correctly. I'll attach an image for you to see.

Is the problem happening on a specific page? I tried on a few pages, like on homepage and page "Qui somme-nous?", for example. Both pages are worked as expected.

Thank you.

The topic ‘[Closed] Only works when logged in’ is closed to new replies.