This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Alejandro 3 months ago.

Assigned support staff: Alejandro.

Author Posts
July 16, 2019 at 9:43 am #4218259

ronanM-4

Open default lag base on currentl location

July 16, 2019 at 11:04 am #4219477

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ok yo can give this video to your client: hidden link

and the explanation is in the browser header settings, which always seems to add en_US as the second language accepted after the one the user has added.

So if your browser is in French, for example the hierarchy will be:

fr_FR > fr > en_US > en > All the other french regions

so your bowser will first look for french from france, then french in general, then go to english us, then go to generic english and last but not least all other french regions. and show the page it finds first.

So what youre experiencing is not a bug, it's the behaviour of the browser.
you can have more information on this documentation: https://www.w3.org/International/questions/qa-lang-priorities

because the preferences can be changed but that is a personal matter, something the user has to do to the browser, so you shouldn't really count on it that much.

Regards.