Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Lauren 1 month, 3 weeks ago.

Assigned support staff: Lauren.

Author Posts
February 19, 2018 at 10:46 am

Kris

I am trying to: edit translations with the Avada theme using the "translation editor".

Link to a page where the issue can be seen: hidden link when clicking on "Edit the [language] translation".

I expected to see: the "translation editor", but it takes very long time before the page is loaded (like 5 minutes?) and sometimes the page doesn't respond at all. And my PC CPU is peaking like mad.
Also, when I try to save new translations, it just keeps saving (the saving never stops and is never fully finished).

Instead, I got: a page crash/loading error page. Or unfinished translations. This is very frustrating.

Capture.JPG
February 20, 2018 at 4:01 pm #1523871

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this. The link in your previous reply takes me to a 404 page, so I was unable to login and try to reproduce the error. Could you please update credentials so I can test this?

In the meantime, please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

2. Browse to the page with the issue and/or reproduce the issue.

3. Locate the debug log in: /wp-content/debug.log

4. Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

Also, are you seeing any errors in your browser console? Here is some information about how to view your browser console: hidden link

February 21, 2018 at 9:29 am #1524601

Kris

Sorry, I accidentally gave you the wrong FTP credentials. I don't know how to send/update them as a private message. But you should be able to login to WordPress admin now.

I edited the wp-config.php and I looked at the debug.log, but there were no (new) lines added to the log.

Can you please look again at the issue? To reproduce the error, edit the English (US) "Partners" page and then try to translate and save it into Spanish with the translator editor...

Thanks.

February 21, 2018 at 8:43 pm #1525437

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I was able to login to the WordPress dashboard but everything I try to access returns a 404 link. Please double check the credentials and make sure I have administrative access.

I have marked the next reply as private so you can update credentials if needed.

February 22, 2018 at 11:23 am
February 22, 2018 at 5:43 pm #1526589

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I tried to login again and also asked one of the supporters in another country to test. He confirms he is seeing the same thing I am - anything you try to click leads to a 404 page. Please see attached screencast here: hidden link

Could you try creating a new user for WPML support, with admin privileges? If not, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

February 23, 2018 at 12:05 pm #1527455

Kris

Wow, this is very weird WP behaviour. Sorry about that. Maybe it has something to do with security protection. I disabled the Wordfence Security plugin to exclude more problems.
I created a new 'wpmlsupport' admin and also build a Duplicator package.
<strike>Unfortunately, I don't think this message is labelled as 'private' so I can't give you the requested information. Can you please change this? Thanks.</strike>

#Edit: okay, I updated the previous private message with the requested info.

February 23, 2018 at 2:18 pm #1527606

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Unfortunately the same thing is happening with this login. I think it will be best to send me a snapshot of your site so that I can try to set it up locally.

Please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

March 5, 2018 at 8:59 am
March 6, 2018 at 12:46 am #1537014

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending files. I think there is some strange stuff going on with your database. Here's what I found.

When I installed the Duplicator files, I still was unable to access any part of the site. So I am wondering if somewhere in your files is a place to block or allow IP addresses? I am assuming my IP is blocked. I couldn't find any place where this could be, so I continued testing.

I created a fresh install of WordPress and connected it to your database. I created a new admin user via the functions.php file. I was able to access the site with a stripped down WordPress and your existing database. So I installed Avada and WPML plugins and when I tried to edit a page (the Partners page) using the translation editor was slow, but it loaded and saved.

I then created a new page named "Test" with some elements using the Fusion builder. This page saved and translated very quickly. So now I have some additinal questions.

1. Is this happening on all pages, or just on this one page?

2. If you were to copy and paste the shortcode from this page to a new page, are you able to translate it then?

3. If you change from using the Fusion Builder to the default editor, does that make any difference?

4. And lastly, if you go to WPML -> Translation Management -> Multilingual Content Setup, and switch to Manual Translation instead of using the Translation editor, are you able to save translations?

Hopefully these answers will help point me in the direction of what could be causing the slow performance.

March 6, 2018 at 10:58 am #1537468

Kris

Thanks for trying to find the problem.

1. It happens mostly on large pages, not so much on news posts for example.

2. I copied the shortcodes to a new draft page and had the same (long) loading errors.

3. I don't think this makes a difference.

4. If I use old style translating, then it workes as expected. But this not very convenient when I'm editing layouts of pages.

I looked at the debug.log and found some new lines, maybe this may help us find the (memory?) problem:

[06-Mar-2018 10:08:06 UTC] PHP Notice:  Trying to get property of non-object in /home/squaregrzmjb02/public_html/wp/wordpress/wp-includes/class-wp-query.php on line 3740
[06-Mar-2018 10:11:15 UTC] WordPress database error Duplicate entry '664-eur' for key 'trid_lang' for query UPDATE `wp_icl_translations` SET `language_code` = 'eur' WHERE `translation_id` = '8898' made by require_once('wp-admin/admin.php'), require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), WP_Hook->do_action, WP_Hook->apply_filters, SitePress->rebuild_language_information, TranslationManagement->add_missing_language_information, TranslationManagement->add_missing_language_to_posts, TranslationManagement->add_missing_language_to_post
[06-Mar-2018 10:12:53 UTC] PHP Notice:  Trying to get property of non-object in /home/squaregrzmjb02/public_html/wp/wordpress/wp-includes/class-wp-query.php on line 3871
[06-Mar-2018 10:12:53 UTC] PHP Notice:  Trying to get property of non-object in /home/squaregrzmjb02/public_html/wp/wordpress/wp-includes/link-template.php on line 643
[06-Mar-2018 10:17:13 UTC] PHP Fatal error:  Allowed memory size of 134217728 bytes exhausted (tried to allocate 225280 bytes) in /home/squaregrzmjb02/public_html/wp/wordpress/wp-content/plugins/fusion-builder/fusion-builder.php on line 979
[06-Mar-2018 10:17:13 UTC] PHP Fatal error:  Allowed memory size of 134217728 bytes exhausted (tried to allocate 20480 bytes) in /home/squaregrzmjb02/public_html/wp/wordpress/wp-includes/wp-db.php on line 1889
wpml_info.JPG
March 6, 2018 at 9:50 pm #1538320

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for the help with testing. I also found this error in the debuglog:

WordPress database error Deadlock found when trying to get lock; try restarting transaction for query DELETE FROM `wp_options` WHERE `option_name` = '_site_transient_timeout_avada_autoloader_paths_a6a80782666226116e2ec07c3dd067ba' made by require('wp-blog-header.php'), require_once('wp-load.php'), require_once('wp-config.php'),

Please make a full backup of your site. Then access the database wp_options table and delete the _site_transient_timeout_avada_autoloader_paths entries.

After this, are you able to edit and save a translation?

March 7, 2018 at 10:49 am #1538857

Kris

I didn't find the line you mentioned in our debug.log, but I deleted the one "_site_transient_timeout_avada_autoloader_paths..." I could find from the wp_options table.

Then I tried to translate the Partners page again: loading still takes a long time (including ignoring the "page not responding" message). When I click "Save & Close" the page doesn't stop "Saving..." (waited for more than 5 minutes). But when I go to the translated page, it actually saved the new translations.

In the WPML language widget, it still shows the "translation in progress" icon (see screenshots).

wpml_unfinished.JPG
wpml_saving.JPG
March 7, 2018 at 4:33 pm #1539471

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for testing that for me. In my test copy of your site, I am able to save the page when using manual translation. Please use that as a workaround and I will discuss with our developers what could be causing the issue with the translation editor. I will report back here as soon as I have more information.

March 8, 2018 at 3:03 pm #1540723

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I have escalated this ticket to our 2nd Tier support so that they can investigate further. I will reply back here as soon as I have more information.