Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: What can I do to optimize WPML performance?

Solution: WPML 4.3 version solved the performance issues that some sites experienced. Updating to the latest version of WPML and its add-ons should resolve the problem.

If you are still running into performance problems, first follow our FAQ entry about preventing performance issues with WPML. This FAQ includes a number of simple steps to follow.

In case you want to profile your site's performance and get to the bottom of performance problems, follow the guide for debugging performance problems.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by healthC 2 years, 11 months ago.

Assigned support staff: Ricardo Alday.

Author Posts
November 28, 2018 at 10:09 am #2947366

healthC

We would like to optimize ttfb, we check that active / inactive WPML components :
active WPML components : TTFB 6~8 seconds
inactive WPML components : TTFB 3~4 seconds

Therefore, we try to optimize wpml performance,
We have try the following :

1.
wp-config.php add code :
define( 'WP_MEMORY_LIMIT', '512M' );
define( 'WP_MAX_MEMORY_LIMIT', '768M' );

2.
Disable the following settings:
- Adjust IDs for multilingual functionality (WPML > Languages)
- Track where strings appear (WPML > String translation)
- Auto register strings(WPML > String translation)

However, the performance just a little bit improve.
Then we go deep to check with plugin "Query Monitor" (20181128_wpml.png)
active WPML components : 1063 DB queries
inactive WPML components : 193 DB queries

Please advise what could we do to optimize wpml performance?

20181128_wpml.png
November 29, 2018 at 6:55 pm #2953715

Ricardo Alday

Hi,

Welcome to WPML support.

1. Check auto-registered domains in WPML > String Translation and make sure that all are included.

It is expected for WPML to increase the number of queries. Can you tell me which page are you checking that shows that many queries?

December 3, 2018 at 7:27 am #2961118

healthC

Hi support,

1.
For some researching, disable Auto register strings(WPML > String translation) may increase loading speed (https://wpml.org/forums/topic/how-to-optimize-wpml-performance/), anyway we have all included.

2. testing link : hidden link
As we have done some caching, then now :
active WPML components : 428 DB queries, TTFB 5~6 seconds
inactive WPML components : 201 DB queries, TTFB 3~4 seconds

There is 2 seconds different on TTFB. Please advise.

December 3, 2018 at 9:55 pm #2964276

Ricardo Alday

I say those are pretty decent numbers and I'm not sure there's much you can do besides deactivating non-essential plugins. I'll consult with our 2nd tier support to see if they have any other suggestions.

December 4, 2018 at 3:57 pm #2967295

Ricardo Alday

Our 2nd tier support does not have any other suggestions other than what you have already tried.
"It is impossible to have 0 seconds difference when WPML is active. Any plugin/theme takes resources to execute the code thus will add some load time."

- Deactivate plugins that are not needed
- Deactivate Query Monitor
- Use caching plugins

Best regards,
Ricardo

December 13, 2018 at 8:17 am #2996597

healthC

My issue is resolved now. Thank you!