Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 47 replies, has 3 voices.

Last updated by Carlos Rojas 1 week, 3 days ago.

Assigned support staff: Carlos Rojas.

Author Posts
October 22, 2019 at 1:33 pm #4802891

alexanderW-19

Hi Support Team,

Tell us what you are trying to do?
1. I need your help to set up properly the language approach for a different addon domain
2. I need your help to improve page loading speed as they differ on different language approach

Is there any documentation that you are following?
I am using the instruction from your website https://wpml.org/documentation/getting-started-guide/language-setup/#language-url-format

This is our current WPML setup approach without language directory
worldcheckin.com > hidden link
worldcheckin.de > hidden link
> Screenshot > hidden link
Different languages in directories ((hidden link - English, hidden link - German))
BUT I am unable to setup "use directory for default language" as I have installed the main domain in a subfolder "public_html/wci"

My problem is that I need the best set up for page loading speed improvements as I am getting different time speed loadings by using Cloudflare cache. They pointed out that I need to contact you to establish the best solution for my approach. Coudflare Support Query > hidden link

Either we need to manage the "Use directory for default language" to get it to run being able to save that content separately to reduce loading time,
OR depending on your suggetion, we need to switch the Language URL format "A different domain per language" I need also then your help to create a corresponding htaccess 301 redirect rule to point from old approach mydomain.com/de to mydomain.de - not losing all backlinks created on external sites.

What is the link to your site?
hidden link

I hope I could explained my problem well to enable a faster page loading for each language

Best, Alex

October 23, 2019 at 12:14 pm #4811199

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

Please update all outdated plugins and themes, specially WPML plugins, to their latest version. Could you tell me if the performance issue persists?

Kind regards,
Carlos

October 24, 2019 at 6:56 am #4816369

alexanderW-19

Dear Carlos,

thanks for the response. Well all plugins are updated but only 2 are left and the theme itself because the developers are not supporting this any more or they have switched to a new version which will completely not support my current setup.

As well those are not the problem makers as the same problem persists if I deactivate those.

Find here a result screenshot of the different time consuming problem.
Pingdom tools speed test Screenshot > hidden link

Please help to find out the best and fastest solution for EN and DE approach and help to solve this issue.

Best, Alex

October 24, 2019 at 9:58 am #4818411

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Alex,
Thank you very much for your feedback.

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

October 24, 2019 at 1:00 pm #4820077

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Alex,
Thank you very much for the information provided.

Could you provide the credentials for the popup that appears rights before seeing the site? You can edit your previous message and add the credentials there.

Regards,
Carlos

October 24, 2019 at 1:04 pm #4820121

alexanderW-19

Hi again,

I've dropped that htaccess within public_html/.../wp-admin/ in _off folder so it should be good to go.

Best, Alex

October 24, 2019 at 1:11 pm #4820217

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Alex,

I still see the popup. Could you flush all cache memory in the site?

Regards,
Carlos

October 24, 2019 at 4:50 pm #4822331

alexanderW-19

Hi Carlos,

please go ahead, I should work now.
It was in cpnginx cache and I had to de-/re activate that on server to get it back to run.

Best, Alex

October 25, 2019 at 9:50 am #4825687

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Alex,

I'm sorry but I still see the popup, even on incognito mode. Could you contact your hosting providers and ask them to help you solve this?

Regards,
Carlos

October 25, 2019 at 9:55 am #4825707

alexanderW-19

Please Send me a Secure Form to Input the Details

Best Alex

October 25, 2019 at 10:00 am #4825741

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Alex,

Your next answer will be private.

Regards,
Carlos

October 25, 2019 at 10:13 am #4825861

alexanderW-19

Not Secure so i deleted

October 25, 2019 at 10:18 am #4825921

alexanderW-19

Please send form again

October 25, 2019 at 10:28 am #4826059

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Form sent again.

Regards,
Carlos

October 25, 2019 at 11:04 am #4826241

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Alex,

The credentials are missing from your previous (private) message. Could you edit your previous message and enter the credentials again?

Regards,
Carlos