Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 47 replies, has 3 voices.

Last updated by Carlos Rojas 1 week, 5 days ago.

Assigned support staff: Carlos Rojas.

Author Posts
October 25, 2019 at 1:06 pm #4827061

alexanderW-19

Dear Carlos,

sorry for that circumstances.
not sure why even by put that htaccess file into off folder still is requested.
Now I've added those popup details in to the private message from October 24, 2019 at 11:52 am.

Please go ahead.

Best, Alex

October 25, 2019 at 1:36 pm #4827257

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi Alex,
This time I was able to log into the site 🙂

I took a look at the site and I would like to ask you to follow this steps:
- Create a full backup of the site.
- Update all outdated plugins and themes, specially WPML plugins, to their latest version. Outdated functionalities can cause conflicts in the code, plus the latest version of WPML includes a solution for some performance issues.
- Flush all cache memory.

Could you tell me the results of the steps above?

Regards,
Carlos

October 28, 2019 at 7:54 am #4836583

alexanderW-19

Dear Carlos,
after upgrade, the WPML plugins my site crashed totally. The server started to freeze and I had to find out which plugin is causing this issue by downgrading.

After several hours I found out that my older newsletter plugin mailpoet 2 seems not to be compatible with the latest WPML plugins.

Now I need to setup mailpoet 3 which will take me several days (because of auto newsletter setup) to be able to proceed with the upgrade.

After I finish that, I will report being able to proceed with your further help to solve the different page loading speed problem while using the DE approach.

Best, Alex

October 28, 2019 at 2:54 pm #4840973

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi, Alex.

FYI, Carlos is on vacation today, but tomorrow he'll be back to work.
Please let him know once you are finished with your testings.

Regards,
Itamar.

October 29, 2019 at 8:42 am #4844777

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi Alex,

I'm back. Please let me know when you finish the setup of the plugin.

Regards,
Carlos

October 31, 2019 at 12:16 pm #4863439

alexanderW-19

Dear Carlos,

as the server expecting a down out of service after upgrade all WPML plugins while using the older mailpoet version 2 together with v3 and also I am in need first to setup mailpoet v3 autoresponder emails and this also is taking so long (I guess one or two weeks). Let us go further with this workaround.

I copied and renamed the plugins folder "plugins_OLD" and using now the upgraded version in folder "plugins" that you will be able to investigate further. Then after your investigation and solving I will do again the downgrade by renaming the plugins folder to "plugins_NEW", renaming the plugins_OLD and using then the older version to proceed with mailpoet v3 upgrade setup.

Now you are able to investigate further with the latest version and please let me know after your solving to be able to proceed with my mailpoet 3 upgrade setup.

Best regards, Alex

October 31, 2019 at 1:06 pm #4864261

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi Alex,
Thank you very much for your message.

Before I started to run the tests I need your confirmation that there is a backup of the site in case we need to restore it.

Regards,
Carlos

November 1, 2019 at 1:03 pm #4871113

alexanderW-19

Hi Carlos,

yes, backup has been made to be found in .../zip-files and database is also exported as a dump file > mysqldump worldche_wcigd_mbkp_2019-11-01.sql

You can go ahead now.

Best regards, Alex

November 4, 2019 at 7:39 am #4878299

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi Alex,
Thank you very much for your confirmation.

I tried to access the site but I got this error (see attached image). Could you verify that the site is working correctly?

Also, please pause Cloudflare service while we are running the tests in the site.

Regards,
Carlos

November 4, 2019 at 8:46 am #4878677

alexanderW-19

Dear Carlos,

thanks for getting back to me. Unfortunately there is no image attached found, but I was able to get the site back to run.

These were the causes:
1. Server was running out of disk space
2. You've done plugin updates which caused a site damage
I could have restored by downgrading those plugins

IMPORTANT:
For your further investigation. Please make sure not to upgarde the following plugins + themes found in this screenshot > hidden link
Plugins
- GeoDirectory You have version 1.6.38 installed
- WP Support Plus You have version 8.0.7 installed
Themes
- Directory Starter you have version 1.1.10 installed
- Supreme Directory You have version 1.2.1 installed

If you upgrade those then the site will go down.
These older versions do not cause the issue of the different language page loading speed as those have been running formerly without any problems.

• about cache in use
1. I have now changed the cloudflare DNS settings to point now directly to our server and purged the cache
2. I have deactivated autoptimize and flushed cache as well
Screenshot > hidden link
3. I have deactivated wp supercache and flushed cache as well
Screenshot > hidden link
4. I've also deactivated the server related CPNGINX application which enable also a cache and fast http2 approach.

Please now go ahead with your investigation AND DO NOT UPDATE THE LEFT UPGRADE PLUGINS + THEMES

Best regards, Alex

November 4, 2019 at 9:21 am #4879089

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi Alex,
Thank you very much for your clarification regarding the plugins/themes updates.

I updated those elements just to be sure we weren't facing any conflict in the code between those functionalities and the latest version of WPML. In any case, I won't updated them any more 🙂

I will start running some tests and I will try to find a solution for this issue.

Regards,
Carlos

November 4, 2019 at 9:36 am #4879223

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi Alex,

I'm sorry but I still can't access the site, now I'm getting an "ERR_TOO_MANY_REDIRECTS" error.

Are you able to log in the backend of the site?

Regards,
Carlos

November 4, 2019 at 11:45 am #4880483

alexanderW-19

Hi Carlos,

As I remember from other tasks this may occur in case of cpnginx is not activated as the server is optimized for this setup. I've now activate only the cpnginx application on server.

Please check again and state if you are able to proceed.

Best regards, Alex

P.S. Please also make sure that you deleted the cookies in your browser as well.

November 4, 2019 at 1:01 pm #4881281

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi Alex,
Thank you for your message.

I applied several tests in the site but the performance issue keeps being intermittent. I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Regards,
Carlos

November 4, 2019 at 4:21 pm #4883131

alexanderW-19

Hi Carlos,

I've started my investigation by dropping all not necessary plugins into the /wp-content/plugins/_plugins_off=== folder

Screenshot > hidden link

Then I started the comparison by using pingdom tools

hidden link for EN approach > hidden link
hidden link for DE appoach > hidden link

The stunning result is, that if almost all plugins are dopped in sub-folder then the german approach is faster than the main engl. approach.

Results
9 active plugins (core files) Screenshot > hidden link
EN 3,19 sec DE 2,09 sec

25 active plugins )core files + all with letter "a" Screenshot > hidden link
EN 3,56 sec DE 1,97 sec

54 active plugins )core files + all with letter "a-g" Screenshot > hidden link
EN 4,41 sec DE 3,55 sec

60 active plugins )core files + all with letter "a-j" Screenshot > hidden link
EN 4,53 sec DE 4,49 sec

75 active plugins )core files + all with letter "a-s" Screenshot > hidden link
EN 7,46 sec DE 6,89 sec

93 active plugins )core files + all with letter "a-w" Screenshot > hidden link
EN 8,72 sec DE 6,51 sec

Stunning result:
If I use for german either hidden link or hidden link
then we also have different results then it works almost without delay if I only have core plugins activated.
Screenshot > hidden link
approx EN 2,9 DE 1,98 - 2,02 sec

If I use all plugins then the results are also almost similar.
Screenshot > hidden link
approx EN 7,7 DE 6,9 - 6,7sec

Then I reactivated cache with all 93 plugins activated
autoptimize and wp supercache with these results
Screenshot > hidden link
approx EN 3,74 DE 6,90 + 7,25 sec

Then deactivated autoptimize plugin
Screenshot hidden link
apporx EN 7,76 DE 7,76 + 7,31

>>>THAT MEANS THAT THE "AUTOPTIMIZE PLUGIN" CACHE FOR WPML DE APPROACH IS NOT APPLICABLE IF THIS PLUGIN GOT ACTIVATED
in other words autoptimize does the job for the EN content but for the DE content it's not working for whatever reason.

Conclusion: these plugins have a high impact of page speed loading time
- ewww-image-optimizer (currently deactivated)
- autoptimize is not applicable for DE content which make the difference in site speed loadings

I hope this helps to find out why and how to solve.

Best regards, Alex