Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 47 replies, has 3 voices.

Last updated by Carlos Rojas 1 week, 3 days ago.

Assigned support staff: Carlos Rojas.

Author Posts
November 5, 2019 at 11:30 am #4888249

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Alex,
Thank you for your feedback.

The test you made are excellent, however there is one key test missing: how is the performance of the site with WPML plugins deactivated? I ran this test already and the site's performance looked the same for me, which means that WPML is not causing this issue, but I would like to confirm with you this results.

In the other hand the two plugin you mentioned, Autoptimize and EWWW Image Optimizer hasn't been validated yet by our compatibility team and you can double check it in our Multilingual-Ready Plugins list: https://wpml.org/documentation/plugins-compatibility/

Also, please take in account that with this number of active plugins the performance of a WordPress site will be hard to keep good in a hosting with 'regular' characteristics.

Regards,
Carlos

November 6, 2019 at 5:33 pm #4900685

alexanderW-19

Hi Carlos,

thanks again for your helping information. Well I do not know the handling - how to test the different language approach while WPLM is not activated. Thanks for doing that for me.

To proceed further maybe in help with the autoptimize support, I've made a ticket to get help in that way also from them.

Here is the support ticket URL > https://wordpress.org/support/topic/autoptimize-not-working-with-wpml-in-multiligual-approach/

I am looking forward to your thought and leave you with my

best regards, Alex

November 7, 2019 at 8:04 am #4903339

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Alex,

I see that you had an answer form the Autoptimize support service. Let's see what are their results in their investigation and let's keep working together.

Regards,
Carlos

November 7, 2019 at 3:16 pm #4907427

alexanderW-19

Dear Carlos,

I've already answered to the autoptimize support ticket
> https://wordpress.org/support/topic/autoptimize-not-working-with-wpml-in-multiligual-approach/#post-12107430
and now let's wait what they will state.

Best regards, Alex

November 8, 2019 at 7:50 am #4911159

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Alex,

Thank you for keeping me updated.

Regards,
Carlos

November 8, 2019 at 6:53 pm #4916207

alexanderW-19

Hi Carlos,

we've got a feedback from autoptimize support > https://wordpress.org/support/topic/autoptimize-not-working-with-wpml-in-multiligual-approach/#post-12110747

They state that they do not find any segnificat difference. For their investigation they used hidden link as they state there is a better checking result deliverd.

Please let me know what you also find out to may proceed in faster site loadings.

Best regards, Alex

November 16, 2019 at 5:19 pm #4959135

alexanderW-19

Hi Carlos,
I've been away. Please re-open the ticket to go furhter with the investigation.

Best, Alex

November 18, 2019 at 9:24 am #4963363

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Alex,

Ticket re-opened again.

Regards,
Carlos

November 18, 2019 at 1:06 pm #4965373

alexanderW-19

Hi Carlos,

thanks again. I've aleardy started the migration process and need to wait until it's done.

Best, Alex

November 18, 2019 at 1:59 pm #4965707

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Alex,

Thank you for keeping me updated. I will be waiting for your message.

Regards,
Carlos

November 19, 2019 at 7:40 am #4968969

alexanderW-19

Hi Carlos,

the migration has been successfully done. Screenshot > hidden link

I am now exited in your results
1. to solve the problem of different page loading speed while switching the languages from EN to DE
2. to get speed improvement advice to reduce the loading time in general site loading too.

Best regards, Alex

November 19, 2019 at 2:59 pm #4973559

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Alex,

The migrated site is not loading correctly, so I'm applying several steps to recover the site. I will get back to you as soon as I finish setting up everything and run the tests.

Thank you very much for your patience and understanding.
Regards,
Carlos

November 19, 2019 at 3:28 pm #4973925

alexanderW-19

Hi Carlos,
thanks for letting me know.
I guess you Need to delete the plugin Cache of autoptize and wp super Cache

Also you May Start first Renaming the Plugins folder and then dropping the Plugins back ohne by ohne.

Best Regards, Alex

November 20, 2019 at 10:08 am #4978501

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Alex,

I updated all outdated plugins, themes and core. Applied several troubleshooting steps and deactivated all plugins except WPML ones. Could you tell me if in this minimal setup the issue persists?

If the issue persists, please activate a default WordPress theme and double check again.

Could you tell me the results?
Regards,
Carlos

November 22, 2019 at 1:54 pm #4998497

alexanderW-19

Dear Carlos,

thanks for getting back to me.
Currently, I have the server http2 (cpnginx) approach deactivated to ensure not this harm our testings.
Find here my results:

I've
1. updated the plugins except
- geodirectory core
- wp-support-plus-responsive-ticket-system

2. dropped the most plugins except
- geodirectory (must use) + related addons
- invoicing (must use referring to geodirectory)
- newsmaker (already a support case in use)
- and WPML related once
screenshot > hidden link
into plugins_off folder and opened the plugin.php page to let all dopped plugins deactivate at once.

RESULTS:
1. with minimum plugins
The different language approach has small issues at different time loading while using my top-level domain in .de or .com
in EN site loads in 9.189s and first byte will be delivered in 0.236 s marked as "A"
> hidden link
and
in DE site loads in 8.980s and first byte will be delivered in 1.472s marked as "F"
> hidden link

2. with minimum plugins and theme twenty seventeen activated and I've used theme-test-drive plugin to enable the theme switch.
The different language approach has 2 sec as different time loading while using my top-level domain in .de or .com
in EN site loads in 10.368s and first byte will be delivered in 0.227s marked as "A"
> hidden link
and
in DE site loads in 12.136s and first byte will be delivered in 4.391s marked as "F"
> hidden link

3. then reactivated theme and all plugins back.
The different language approach has small issues at different time loading while using my top-level domain in .de or .com
in EN site loads in 19.350s and first byte will be delivered in 0.239s marked as "A" and
> hidden link
in DE site loads in 19.326s and first byte will be delivered in 8.661s marked as "F"
> hidden link

In other words.
The most important difference is related in first byte delivery and we need to search for that also.
Please advise in - how to proceed further.

Best regards, Alex