Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 66 replies, has 3 voices.

Last updated by Carlos Rojas 8 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
December 17, 2019 at 2:00 pm #5147513

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alex,

Please check the images attached where you will find the latest tests made by our specialists. There you can see that the .de domain is loading faster that the .com domain, however our specialists can't see WPML as the cause of this behavior.

Best regards,
Carlos

December 18, 2019 at 11:09 am #5154543

alexanderW-19

Hi Carlos,

thanks for the feedback.

The issue that the German site loads faster than the English site is that the german sites has not so many listings within. We have to focus on the first byte loading time.

In your results by using different domains for each approach the loading of EN site is slower then the DE site and also the first byte loading is also faster on DE site.

But if we change back to
1. "Different languages in directories" Screenshot > Different languages in directories
2. Redirect cPanel settings "worldcheckin.de > hidden link" screenshot > hidden link
then still we have the issue of different first byte loading time.

Currently, the latest setup of redirection domain.de points to .com/de is still left to see the results and still directs to ....com instead of .de after setting up the redirection. That is why I use the .com/de for page load testings.

worldcheckin.com first byte loading time 6.949s
hidden link

worldcheckin.de first byte loading time 9.499s
hidden link

Which means the same content is used from worldcheckin.com (reason of time delay as the redirection is still left in the results) the wordcheckin.de appraoch takes much more time für 1st byte loading 9.499s instead of 6.949s as it is on EN .com approach. Usually it should at least take the same amount of time as the content is still the same.

Please let me know your thoughts.
Best regards, Alex

December 18, 2019 at 1:54 pm #5155545

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alex,

Our specialists where able to reproduce the issue and get the same metrics as yours. At this moment they are requesting a Duplicator copy of the site so they can continue testing on another testing environment.

I have set your next answer private so you can provide a download link with a Duplicator copy of the site.

Looking forward to your message.
Regards,
Carlos

December 19, 2019 at 11:00 am #5162555

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alex,
Thank you for sharing this information.

I updated our specialists in the 2nd tier and I'm waiting for their answer. I will keep you updated.

Regards,
Carlos

December 30, 2019 at 1:34 pm #5211413

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alex,

Our 2nd tier specialists tried several times to restore a copy of the site but deploying this results in number of fatal errors caused by outdated plugins - mainly GeoDirectory ones.

I have set your next answer private so you can provide a download link with the lastest version of Geodir plugins, this way our specialists will be able to continue on this issue.

Looking forward to your message.
Regards,
Carlos

January 2, 2020 at 1:55 pm #5224007

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alex,
Happy New Year to you too!

I just updated our 2nd tier specialists with this new links. I will keep you updated.

Regards,
Carlos

January 7, 2020 at 12:36 pm #5246655

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alex,

After downloading the copy of the site, our 2nd tier specialists is getting fatal errors with GeoDir plugins:

[07-Jan-2020 12:16:20 UTC] PHP Fatal error:  Uncaught Error: Call to undefined function geodir_map_name() in E:\laragon\www\perf\wp-content\plugins\geodir_marker_cluster\geodir_marker_cluster.php:170
Stack trace:
#0 E:\laragon\www\perf\wp-includes\class-wp-hook.php(288): gdcluster_templates_scripts('')
#1 E:\laragon\www\perf\wp-includes\class-wp-hook.php(312): WP_Hook->apply_filters(NULL, Array)
#2 E:\laragon\www\perf\wp-includes\plugin.php(478): WP_Hook->do_action(Array)
#3 E:\laragon\www\perf\wp-includes\script-loader.php(2670): do_action('wp_enqueue_scri...')
#4 E:\laragon\www\perf\wp-includes\class-wp-hook.php(288): wp_enqueue_scripts('')
#5 E:\laragon\www\perf\wp-includes\class-wp-hook.php(312): WP_Hook->apply_filters(NULL, Array)
#6 E:\laragon\www\perf\wp-includes\plugin.php(478): WP_Hook->do_action(Array)
#7 E:\laragon\www\perf\wp-includes\general-template.php(2879): do_action('wp_head')
#8 E:\laragon\www\perf\wp-content\themes\twentytwenty\header.php(23): wp_head()
#9 E:\laragon\www\perf\wp-includes\template.php(722): require_once('E:\\laragon\\ in E:\laragon\www\perf\wp-content\plugins\geodir_marker_cluster\geodir_marker_cluster.php on line 170

Do you have a workaround to solve this?

Regards,
Carlos

The topic ‘[Closed] Optimized setup for speed improvement by different addon domain approaches’ is closed to new replies.