This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Yvette 4 months, 2 weeks ago.

Assigned support staff: Yvette.

Author Posts
June 4, 2019 at 1:05 pm #3951897

mirandaF-2

I'm coding a custom theme for my site, and I've been struggling with troubleshooting the styling of the language switcher I coded. When revisiting article https://wpml.org/documentation/getting-started-guide/language-setup/designing-custom-language-switchers-using-template-files, I was trying to make sure I'd completed all the steps when I noticed there's no longer any option to choose the language switcher style I coded using the instructions in the article (I'd noticed it was available previously). How can I choose my styling over the default styling? Thank you!

June 4, 2019 at 3:15 pm #3953191

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Please refer to this section of the article:
https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/#customizing-menu-language-switchers

With the class "wpml-ls-menu-item" you can add additional styling to the Additional CSS section under the Language switcher options.

Does this answer your question?

June 4, 2019 at 6:09 pm #3954347

mirandaF-2

Hi Yvette,

Thanks for replying! Unfortunately, I'm trying to style a slightly more complex switcher, but I don't know any PHP. The custom switcher I designed is a dropdown in my menu, but I'd like to have it labeled "Languages" (in the current language), and when hovered over it displays the languages. This is why I was hoping I could still use the template method. Can you give me some guidance?

Thanks,
Mira

June 4, 2019 at 6:33 pm #3954517

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Oh - unfortunately I don´t have the Symfony/Twig skills to help you to that extent and our support policy is limited in how many resources we can dedicate to custom developments.

Can you give me a link to your site so that i can see what you are trying to do?
https://wpml.org/faq/provide-debug-information-faster-support/

I´ll ask around if there is someone that is better suited to help you out - otherwise, I will have to direct you to a wpml contractor that might have these skills
https://wpml.org/contractors/

June 4, 2019 at 6:38 pm #3954667

mirandaF-2

Thanks for taking a look Yvette! I'm pretty sure my Twig template was correct, but unfortunately with the new update it appears I can't apply it. Anyway, here's the link to my dev site: hidden link. As you can see I'm still styling even the existing menu dropdowns but as long as I can get things looking similarly, that'd be great. Thanks for all your help!

June 4, 2019 at 6:41 pm #3954675

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Just for completeness - could you also please provide system access (wp-admin and ftp) so I can provide details of your code to a resource (assuming I find one)

I´m opening the private are for this
Thanks

June 5, 2019 at 7:58 am #3957823

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi there

Right now, the only language switcher I can see is the standard one that is integrated into the navigation menu.

I don´t see the vertical listing one that you designed with Twig.

Is this expected? Is the problem that your custom switcher is now not appearing at all?
THanks for the clarification

June 5, 2019 at 11:47 am #3960105

mirandaF-2

Yes, that's correct. (^_^)

June 6, 2019 at 12:19 pm #3969217

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi

The SFTP login credentials are not working for me. Could you please check them?
I´m opening the private area again-

June 7, 2019 at 11:38 am #3975949

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I´m sorry for going so slow with this.
Where exactly is the root directory for your installation?

I am having no luck navigating the root file system to find the wp-content/themes/ directory.
Thanks for yoru help

The topic ‘[Closed] Option to choose a language switcher style gone’ is closed to new replies.