This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 3 voices.

Last updated by marcH-8 3 years ago.

Assigned support staff: George Botsev.

Author Posts
September 26, 2016 at 2:59 pm #1100532

marcH-8

Hi, I have a strange problem and I guess it's related to WPML. When I make an order on the english page, the order-received page displays properly. This is the order-received page: hidden link
The URL of the page is for example: hidden link

However, when I make an order in German or Italian, the order-received page is missing!! That means, it's blank! The URL shows the translated "order-received" as set up in the settings.

As far as I can remember, this has been working well until some time ago... don't know when it stopped working.

What can the reason be?

thanks, marc

p.s.: I have latest versions of Woocommerce, WPML, WP and all other plugins are updated!

September 26, 2016 at 10:43 pm #1101396

paolinoV

Hi. I'll follow your request, because I've the same problem.
My default language is Italian and the order-received page works fine.
When using English, the page is blank.
I've understand it's related to the woocommerce endpoints strings in wpml.
So I tried to translated the various strings like (order-receiver, order-cancelled, etc.) in italian.
The result was that now the page url is:
hidden link

instead of:

hidden link

Now it's blank in Italian and in English.

Then I tried to change the endpoint under the settings in woocommerce with the trsnslated ones, but nothing changed.

So... i need help too 🙁

This is the situation right now, and only Italian is working.

hidden link

Thanks

September 27, 2016 at 6:39 am #1101716

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Please check this errata page and please do try our latest beta: https://wpml.org/errata/errors-order-confirmation-page-using-woocommerce-multilingual/
A lot of our customers report that the beta fixes similar issues.

Please remember to backup your database first before you proceed! You can use a plugin for this if you like (example: http://wordpress.org/plugins/duplicator/)

September 27, 2016 at 8:16 am #1101913

marcH-8

Thanks George. If the beta fixes similar issues for a lot of your customers, I would rush to make this beta a stable version. 😉

September 27, 2016 at 8:51 am #1101973

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Thank you for your recommendation.
In order for a beta version to become a stable one, there is a lot of testing that our testing team needs to do first. For now the beta seems to be stable enough, however, the test just began.

September 27, 2016 at 8:57 am #1102005

marcH-8

I had to rename the old folder in order to install the beta. NOW after installing the beta there are many translations NOT translated anymore!!!! How come??

September 27, 2016 at 9:00 am #1102008

marcH-8

the beta works. But as I told you, many translations are missing now!!! I thought translations are in the database and not in the folder of string-translations!!

September 27, 2016 at 9:20 am #1102024

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

@march-8 would you care to elaborate on which translations exactly are missing for you?
Can you please elaborate a little more so I can better understand? Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit so if you like make use of "upload an image" below the comment area.

September 27, 2016 at 9:33 am #1102053

marcH-8

sure, of course.
First screenshot shows that there is now "items" on the german page for the cart instead the German translation I had for this (Artikel).
hidden link

next one is a product category. I had translated "sweets" in German and Italian, but now it shows only the english. See the result: hidden link
and the settings: hidden link
it WAS translated before!!

next one: address, phone and working days was translated before!
hidden link

I cannot check everything now, but this is really strange.

My site is: quattromori.store

I renamed the wpml-string-translation folder back (took the old one and renamed the new beta), but NO change!!! These translations are still wrong!! And weired, too!! On the Italian page "Address" is written in Italian, but "phone" in English. And "items" is translated totally wrong! So, what can this be???

September 27, 2016 at 11:49 am #1102455

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

I am suspecting that you might have had some strings that were cached, with their cached translations. Perhaps these translations came from a .mo file for your theme or for WooCommerce itself.
I would recommend you to check the availability of such strings in WPML > String Translation and if they are translated there. If they are - maybe a simple theme and plugin re-scan for strings would correct the situation for you.
Another possibility is that the .mo files may not be present anymore, so I would definitely check that too.
If neither of these options help, then I would suggest that you open a new ticket here in the forums, so that we can investigate more in-depth the issue and not interfere with all the subscribers for this thread here.

September 27, 2016 at 12:35 pm #1102542

marcH-8

There is no one who could have deleted the .mo files. No other than me is accessing my server. I have also wiped out the cloudflare and wp-rocket cache.
I also re-translated some things, but the do NOT show up!!
Do you mean the wp .mo files under /languages or the woocommerce .mo files?

I saw that "Translate the theme and plugins using WPML's String Translation" is NOT clicked!! But it was before!! When clicking it and saving, it doesn't save!! It always returns to the "Don't use String Translation to translate the theme and plugins".

I guess that's the problem!!

How come it doesn't save??

September 27, 2016 at 9:12 pm #1103193

marcH-8

There have been several updates of wpml in the last days, as I remember. I think that some of the settings have NOT been saved!!! How can this be?? As I told you, the "Translate the theme using WPML string translation" was not clicked, but it was before!! And many translations are mixed up. Also the browser detection is disabled, but it WAS enabled before!!

September 28, 2016 at 6:33 am #1103333

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

The .mo files may be in /wp-content/languages/ or in your plugin or theme folder.
It is a mystery to me why the translations are missing.
Did you re-scan the plugins and theme that are affected?

Sometimes the option: "Translate the theme and plugins using WPML's String Translation" can un-check itself after upgrade of WPML String Translation.
Also, that option may not have worked before to save because of insufficient time or memory to your server, or too many strings - this option when set, used to automatically re-scan your theme. However, this should be improved now and in the future releases as well and that problem will be gone.

Because this issue that you are reporting has nothing to do with the current ticket, I want to ask you to please open a new one - so that we can investigate the issue properly - if this is your wish.

September 28, 2016 at 6:54 am #1103344

marcH-8

ok, George, I will open up a new ticket, because I still have problems and I cannot translate some things. I'll explain in the new ticket. Thanks for your support!