Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: The client has added some custom orders to the Woocommerce products at "product edit page -> Advanced -> Menu Order", and all of his languages follow this order when displaying the products list, only the French language didn't follow this order. Solution: The French language hasn't copied the menu order for most of the products, they were having "0" as their order, so when clicking the update button at the original product the issue has been resolved. Relevant Documentation: https://wpml.org/documentation/related-projects/woocommerce-multilingual/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
March 9, 2017 at 12:40 pm #1226357

rolandd-5

Hi,

I'm having a shop with it's default language Dutch. I also have the German, French and English translation.
The Dutch and German languages are online, the French and English are hidden at the moment.

I've set the order for the product manually. So product-1 has ordernr 10, product-2 has ordernr: 20 etc. This way, product-1 is listed first, then product-2.

This is all working fine for the Dutch and German language. For French however, the order of the products in the shop (Boutique), is different.

I checked if the ordernr is copied to the translation and the creation date is the same. It is, so that's not the problem.

Synchronizing the product-order doesn't help (enabled by default). So I turned it of and turned it on again. No avail.

In Woocommerce -> settings -> products -> display, I have the exact same options set as for my order languages.

How can i get the order for the French products exactly the same as for my products in the language German and French?

Regards,

Roland

March 9, 2017 at 9:55 pm #1226878

Bruno

Hi,

Thank you for contacting us.

Please, could you upgrade to the latest version of WooCommerce Multilingual, 4.1.0, which we release today?

Note: it is recommended that you fully backup your site before updating your plugins.

After upgrading WooCommerce Multilingual, please let me know if the problem persists.

Thank you.

March 13, 2017 at 7:49 am #1228399

rolandd-5

Hi,

Problem still exists after upgrading WooCommerce Multilingual tot Version 4.1.0.

regards,

Roland

March 13, 2017 at 9:08 pm #1229331

Bruno

Hi,

I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

*** Please let me know exactly what steps should I follow to see the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

March 14, 2017 at 4:12 pm #1230164

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hello, Bruno is off for today so I am stepping in to help out.

WooCommerce -> WooCommerce Multilingual -> Settings and changed the settings to use the native WooCommerce editor. I noticed that when I used this setting and re-saved the original product, then the product orders are synced to all secondary languages.

You can go to Products and select them all and click Edit to bulk edit and update the products in the default language. This should sync all of the translations orders.

Please let me know if you need any further assistance and I will be happy to help.

March 14, 2017 at 5:43 pm #1230266

rolandd-5

Hi Lauren,

Sorry, but I can't replicate it.
Tried you're suggestion, but nothing seems to change.
Products are still not in the correct order.

March 15, 2017 at 5:28 pm #1231314

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I noticed that if I go to WooCommerce -> WooCommerce Multilingual -> Status, there is a message that the store pages are missing for secondary languages. If you click "Create missing translations", do the products show in the correct order on these new translations?

March 16, 2017 at 8:12 am #1231705

rolandd-5

Hi Lauren,

Still no luck.

for test, I enabled the English translation. All products in English are in the correct order.
It affects only the French translation. Why?

The French site have to go online soon, so I need an urgent solution.

regards,

March 16, 2017 at 8:31 am #1231718

rolandd-5

Hi Lauren,

I changed the Theme back to Twenty-sixteen and I still see the same order only for France which is wrong.

I also deleted the translated French product and recreate it different ways. Still no luck.

Regards,

March 16, 2017 at 8:59 am #1231753

rolandd-5

Another little update:

WooCommerce -> settings> Products> display -> default sorting

When I change this drop-down to any other value then "default sorting" on the main (or other) language, it is applied to all other language. All products have the same sorting in the shop. Changing it back to "default sorting", the order is the same for all languages, except for the French products.

So the order is not applied for the French language. I have:
Product A -> order set manually 10
Product B -> order set manually 20
etc.

I can't change this setting on the translated products, but the number for the French product is the same as for the other translated products as for the main language where this setting is set.

Regards,

March 16, 2017 at 9:58 pm #1232665

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I'd like to set up a copy of your site locally so that I can run further tests without interupption to your live site. Please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will enable the next reply to be private so only you and I have access to it!

March 17, 2017 at 6:49 am #1232794

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

If you go to WPML -> Languages, in the hidden languages do you have French marked as hidden? If so, if you change temporarily so French is. It hidden, does the order sync correctly?

March 17, 2017 at 2:21 pm #1233233

rolandd-5

Hi Lauren,

Please see my private message on MARCH 14, 2017 AT 7:55 AM in this threat for the login credentials.

Regards,

March 20, 2017 at 11:24 pm #1235211

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks Rolan, I have the credentials. This one is really baffling me. I'm discussing with our developers and will report back here as soon as I have more information. Thanks for your patience.

March 21, 2017 at 1:48 pm #1235812

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I have escalated this to our 2nd Tier Support team. I will be working with the developers to find the cause and resolution and will keep you updated here. Thanks for your patience while we continue to troubleshoot.