This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 30 replies, has 3 voices.

Last updated by Alejandro 4 months ago.

Assigned support staff: Alejandro.

Author Posts
April 30, 2019 at 1:40 pm #3711775

edmondG

I have a website (www.financialmatch.nl) where the basic settings are in English but half of the pages are written in Dutch.
- If I changes a Dutch page (settings language Dutch, both translate or not translate) with Dutch sentences and I save this page then my Dutch sentences are changed (it looks like its automatically translating in English and back in Dutch what I don’t want because it is not translated correctly). How can I realise that my (Dutch) sentences are not (automatically) changed or translated . (I’m now not using MO or PO-files).

- See attachment: sometimes the website translate (most words) correctly but often half is in Dutch half is in English (with stringtransaction I have translated all the words like membership and Hire freelancer but WPML doesn't see them or I do something terribly wrong

Help

April 30, 2019 at 7:05 pm #3714419

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support.

From your provided information it is difficult for me to tell what might be the issue on your site.
To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us:
http://wpml.org/faq/provide-debug-information-faster-support/

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

May 1, 2019 at 10:06 am #3717505

edmondG

Dear Andreas,

Thanks for your reply,

I hope i can response in a couple of days. Now the developer is still working on the site and i don't want that there might be a (technical) conflict if you both look/work in my site. I hope he will finish his work in a copple of days and then i will give you access to everything that is necessary for you to help me. I will let you know.

Kind regards

May 13, 2019 at 6:35 pm #3801199

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am writing as I wanted to know if you still need further assistance about the issue with translating your site content?

If the issue is solved please feel free tomark this ticket as resolved.

Kind regards
Andreas

May 14, 2019 at 9:07 am #3805009

edmondG

Dear Andreas,

I absolutely still need assistance but I'm waiting till my developer has finished the website before I reply to You. I hope this will be this week. I'll let You know ASAP.

Kind regards,

Edmond

May 21, 2019 at 8:21 am #3853151

edmondG

Dear Andreas. The developer is ready and I would like to give you all the (login) information you need but I'm not sure if this reply is private or public so I wan't give it here. Can you inform me how i can give you all needed information (a reply on this conversation?) Furthermore I'm an amateur so I don't know how to make a backup. Off course it is no problem for me if you make a local backup or perhaps it is possible that you look on my computer by teamviewer? Please let me know. Kind regards, Edmond

May 21, 2019 at 2:23 pm #3856143

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access. Here a good article about plugins that offer to make backups of your site and database.
hidden link

If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

May 21, 2019 at 6:43 pm #3858327

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

It appears to me that we are handling with a configuration issue here.

I suppose that the URL:

hidden link should be set for Dutch

and

hidden link

for English, correct?

Your current WPML Default Language is English. You will need to change it to Dutch in order to use the above mentioned URL site structur.

Alternatively, you could use English as Default language and enable a directoy as well:

Example: hidden link with option setting "use directory for default language" at WPML -> Languages -> Site URL Structure.

But then the second language Dutch would appear as:

hidden link

Now for the content issue, I can see Dutch pages on the English section of the site. This is why you find Dutch language on your English URL.
The actual Dutch Homepage is a translation of the English Homepage which by mistake was create in Dutch on the English Site Language.

This is why the Dutch content exists twice. An English version of the homepage is not existing on your install. I would advise you to switch the WPML default language to dutch and then translate the pages into English.

Please let me know if this solved the issue.

Kind regards
Andreas

May 22, 2019 at 12:07 pm #3865189

edmondG

Dear Andreas,
Thanks for your reply. Unfortenatly my problem is not solved.
Now you see for the (home)page this:

You said: Your current WPML Default Language is English. You will need to change it to Dutch in order to use the above mentioned URL site structur.
If I do so:
- WPML plugin
- Languages
- Site languages
- Change English default in Dutch default
I see the pictures below (so no picture and no buttons in the footer)

So the whole body and the buttons in the footer disappeared. My developer says:
“To solve your issue you need to create all the content like pages, posts and all in dutch language too with the same content in dutch. So you will have pages in dutch too and then if you change default language then it will show the dutch page. So you can see your dutch content”
Andreas is this true and if so How?

Andreas: Alternatively, you could use English as Default language and enable a directoy as well:

Example: hidden link with option setting "use directory for default language" at WPML -> Languages -> Site URL Structure.

But then the second language Dutch would appear as:

hidden link
Edmond: If I click (only) on Use directory for default language (and nothing in the buttons below) and I go to the homepage it gives an error (something like can’t entry because it’s to much redirected)

So do I do something wrong/have I forgot something or is there another solution?

I hope you can help me.
Kind regards,

Edmond

May 22, 2019 at 6:40 pm #3868717

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

It seems you did not clarify with the developer which is the default language of the site. I see you created a homepage in Dutch which also appears on the English content in Dutch. Further, the URL hidden link should logically refer to Dutch content, right?

I would like to clarify the issue once more as there is some kind of weird issue on the site which also might be related to custom coding inside the child theme:

Currently your WPML default language is set to English at WPML -> Languages.

With the current URL site structure the language is actually should displayed this way:

Different languages in directories ((hidden link - English, hidden link - Dutch))

Anyhow, for some reason your site displays in the logical "correct way", but the language settings for WPML seems to cause here the problem.

hidden link for Dutch
hidden link for English

To make myself clear, as your page is displaying Dutch on hidden link therefor the WPML default language should usually be set to Dutch, which it is not.
Could you please make a backup of your site and database.

Now, for testing purpose could you please change to a default theme like Twenty Seventeen for example and see if you get the same issue, as explained above? If so the issue is theme related.

Now, change the WPML default language to Dutch at WPML -> Languages -> Site languages. This usually should solve the issue. I can assist you further with translating Footers and other sections if necessary.

First translate your homepage again from Dutch to English, as this page currently is not translated correctly. Also verify that you do not find any pages with Dutch titles on your English Pages section (As mentioned in my last message).

Further, the menu is not translated yet. Please go to Appearance -> Menus and and click the plus icon on the right side to translate the menu. You will need to create a individual menu for each language here. Afterwards you can syncroniye the menus at WPML -> WP Menus Sync.

Let me know if this solved the issue.

Kind regards
Andreas

May 24, 2019 at 2:43 pm #3885767

edmondG

Hello,

It seems you did not clarify with the developer which is the default language of the site. I see you created a homepage in Dutch which also appears on the English content in Dutch. Further, the URL hidden link should logically refer to Dutch content, right? Edmond: Right

I would like to clarify the issue once more as there is some kind of weird issue on the site which also might be related to custom coding inside the child theme:

Currently your WPML default language is set to English at WPML -> Languages.

With the current URL site structure the language is actually should displayed this way:

Different languages in directories ((hidden link - English, hidden link - Dutch))

Anyhow, for some reason your site displays in the logical "correct way", but the language settings for WPML seems to cause here the problem.

hidden link for Dutch
hidden link for English

Andreas: To make myself clear, as your page is displaying Dutch on hidden link therefor the WPML default language should usually be set to Dutch, which it is not.
Could you please make a backup of your site and database.
Edmond: I think I made a backup but will you please check this in my site/

Andreas: Now, for testing purpose could you please change to a default theme like Twenty Seventeen for example and see if you get the same issue, as explained above? If so the issue is theme related.
Edmond I’m so sorry but I’m to much an amateur to dare this. I think you made a backup of the site on your server. Is it possible for you to test it? And if here is the problem how can I (or my developer) solve the problem (so that I still have the same look and feel of the website (or of the childtheme?)

Andreas: Now, change the WPML default language to Dutch at WPML -> Languages -> Site languages. This usually should solve the issue. I can assist you further with translating Footers and other sections if necessary.Edmond (Can I afterword’s bring back the same homepage/childtheme/look & feel of the site?

First translate your homepage again from Dutch to English, as this page currently is not translated correctly. Also verify that you do not find any pages with Dutch titles on your English Pages section (As mentioned in my last message).Edmond: I think last time I tried this the website crashed (could not see the body and the icons in the footer)

Andreas: Further, the menu is not translated yet. Please go to Appearance -> Menus and and click the plus icon on the right side to translate the menu. You will need to create a individual menu for each language here. Afterwards you can syncroniye the menus at WPML -> WP Menus Sync.
Edmond: I don’t see a plus icon, I see only a pencil icon (edit)

Do I have to click that icon or do I have to create here a new menu (and can I udo these steps if the website crashes)

Last general questions:
- Wp-settings
o Browser language redirect. Now I got Disable browser language, Will it be OK to change this to Redirect visitors based…. (is there a change then that the visitors will see the dutch texts/)
- And other options
o Now I got Assume that the original language is English. Is it wise to change this in: change to use the theme or plugin Text?
- Translations queue
o A lot of words (translation status) says in progress. Can I (without harm) click on translate and will this help?
- Do you think that if I use PO or MO files my translation problems can be solved?

Andreas I hope you are able and still wants to help me with these problems.

Kind reagrds,

Edmond

May 25, 2019 at 9:36 pm #3890141

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have realized that your website was running two multlingual plugins at the same time which seems to have caused issues with the content.

Besides WPML Multilingual CMS the plugin Weglot Translate was installed and activated. Such setup is not advisable as it cuases issues with content and URLs.

I have disabled Weblot and checked your homepage which seems to have no content but only a title and one line of text. Could you please give me some more detail about how this page was build? I would advise you to rebuild the page again in Dutch and then translate it to English.

The menu had to be created at Appearance Menus. There is somehow an issue with the current menu when it comes to display the WPML language switcher.

It seesm that this issue is related to the FreelanceEngine Theme and I would kindly like to ask you install a version of the theme on the following test site for more testing:

One Click Login: hidden link

Please leave me short message once the theme is installed.

Also could you please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 256M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means, with a default theme and not other plugins installed.

Kind regards
Andreas

May 27, 2019 at 9:25 am #3895243

edmondG

Dear Andreas,

Thanks for your response.

I will do the following actions:
- Ask my developer to add the code to increase WP memory ( according to my hostingprovider my memory-limit is 256 MB)
- Ask my developer to create/rebuild an extra homepage in Dutch
- Install a version of the freelanceengine Theme for testing
But first will you please roll back your changes to the website concerning Weglot so that I have the original website again (I have activated Weglot but cannot get my original site back)
(Somehow I do need Weglot because with an earlier deactivation it was suddenly no longer possible to sign in (it was still possible to log in).

After you have restored the website I will request my designs to arrange the above points.

Hope to hear from you soon.

Kind regards,

Edmond

May 27, 2019 at 4:56 pm #3899771

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to point out again that it is not possible to use Weglot and WPML at the same time.

I have now deactivated WPML and your old content apperead again. In fact I would like to invite you to check the page editor for your current homepage, which actually onlz has a title and a one line paragraph

How was the content created that appears once the site runs with Weglot?

Kind regards
Andreas

May 28, 2019 at 1:51 pm #3907665

edmondG

Dear Andreas,
- I don’t know if this has to do with deactivating WPML but now the items (in the Header) under About Us are disappeared and if you (in the Header) click on memberships all the products/subscriptions are shown twice (twice basic, twice standard etc). Can you undo this please
- I asked my developer if he can create an extra homepage (default language in Dutch) and if he can explain how the content was created for the Homepage. If he respons I’ll let you know
- (for me) a strange thing is that on (only) my tablet (so not on the desktop or smartphone) if I change (in the Header) the language from Dutch (NED) to English at the bottom of the page there is a line to translate (see attachments). If I click on that the page is translated. Is this a WPML thing or Weglot or something else and can we maybe use this (also for the desktop and smartphone (and also for the other pages) to solve the translation problems?
Hope to hear from you.

Kind regards,

The topic ‘[Closed] Original text changes’ is closed to new replies.