This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 9 replies, has 2 voices.

Last updated by fredrikS-7 1 month ago.

Assigned support staff: Raja Mohammed.

Author Posts
September 9, 2019 at 4:36 am

fredrikS-7

I am trying to: Open a product category page in the language Swedish.

Link to a page where the issue can be seen:
hidden link

I expected to see:
The filter on the left side should only show the Brand OOO - not Manduka, Jade etc
If you switch to English - you see correct.

Instead, I got:

To much in the filter 🙂

September 9, 2019 at 6:44 am
September 9, 2019 at 6:46 am #4533873

fredrikS-7

Hi - I´ve been working in the Sandbox area - but I does not work at all.

Can you check if WPML is correct setup?

Thanks!

September 9, 2019 at 7:08 am #4533987

fredrikS-7

I can´t get the things going in the Sanbox mode.

Could you check for compatibility issues?

Thanks!

September 9, 2019 at 7:27 am #4534047

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I will check and let you know in some time.

September 10, 2019 at 10:38 am #4544287

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Unable to reproduce the issue in the sandbox. checking the site again. I will update you in a while.

September 10, 2019 at 12:48 pm #4545423

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

This seems like some of your installed plugins is conflicting with WPML, Please try some basic troubleshooting.

- Disable all non WPML plugins except WooCommerce and Product filter for woocommerce Check if the issue still persists. The filter should only show the category when the category page is accessed

- With all the plugins disabled, Try changing to any of WordPress default theme to identify the issue with the thee

- If the issue disappears then this is possibly a conflict issue with any of the installed plugins, Try activating the plugin one by one to identify the conflicting partner.

Let me know the results.

September 11, 2019 at 3:47 am #4550381

fredrikS-7

Hi,

I have now:

Disable all non WPML plugins except WooCommerce and Product filter for woocommerce Check if the issue still persists.

Changed to Theme 2019 of WordPress default theme to identify the issue with the theme.

But the problem persist.

So left is WPML.

Any ideas?

Only strange thing I could see - was that it was double filters while changing theme.

Looking forward to some ideas! 🙂

Thanks!

Fredrik

September 11, 2019 at 10:58 am #4552807

fredrikS-7

Hi again!

I´ve been thinking and testing.

If I click on a button that has this link:
hidden link
(where ?v=f003c44deab6 is a unique user - just to explain)

Then the filter acts correct in english.

If I just switch to swedish:
hidden link

Then the filter does not give correct result - just showing the filter without filtering/reflecting the content on the page.

But if I check (in this case the Brand Liforme) then the outcome is correct in swedish.

The link changes to:
hidden link

So somehow it seems that WHEN arriving on a category page in a SECOND language - The filtering never happens.

Do you know what could cause this?

Best Regards
Fredrik

September 11, 2019 at 12:15 pm #4553301

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Please provide a snapshot copy of your site. You can use the Duplicator plugin to create a snapshot of the site and share the package link with me http://wordpress.org/plugins/duplicator/

I have enabled private fields for you to securely share the details.

September 11, 2019 at 3:50 pm #4555085

fredrikS-7

Hi Raja!
Finally the plugin creator found that you made some changes in your latest version of the plugin that affected his plugin.
NOW IT WORKS!
Thanks for supporting - It meant a lot!

/F

My issue is resolved now. Thank you!