Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 23 replies, has 3 voices.

Last updated by Jamal 1 month ago.

Assigned support staff: Jamal.

Author Posts
October 20, 2019 at 2:32 pm #4789829

orenF-2

Hi Jamal,

Thank you for sending this. The site has been migrated.
Please let me know if I can answer any questions or provide any additional information.

Best regards,

October 22, 2019 at 12:30 pm #4802231

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for your collaboration. I had to create another admin user on the migrated site to be able to log in.

As this is translated through a translation service, I don't want to pull translations or send them again to not cause inconsistencies with the translation service and your live site.

From what I could gather so far, some ACF fields were not saved in the translations, check the attached image. I still believe that the settings for ACF fields are wrong, but you have a point, why did it work for other languages.

Please note, that I have upgraded the WPML plugins in the migrated site to the latest release and also applied a patch that causes a Fatal Error.

What I would suggest doing for one product is:
Complete any ongoing translation even with just a copy of the original field.
1. Configure all ACF system fields (prefixed with _) to be "copy" or "copy once". You need to click on "show system fields" to see them, check these two videos.
- hidden link
- hidden link
2. Keep the ACF fields (not prefixed with _).
3. Click on apply on the bottom of the page.
4. Save the product, to force WPML to pick all fields.
5. Send jobs to translation again.

Best regards,
Jamal

October 24, 2019 at 11:06 pm #4823523

orenF-2

Hi Jamal,

Please allow me a little time to try this out and get back to you.

Thanks!

October 25, 2019 at 9:20 am #4825415

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Sure! I marked this ticket as needing user feedback, it will remain open for 3 weeks. Without an answer from you, it will be closed by our cleanup bot.

I remain at your disposal.

Best regards,
Jamal

October 27, 2019 at 11:04 am #4834149

orenF-2

Hi Jamal,

I understand what you're saying about the ACF, but when I go to settings in WPML and to the section for "Custom Field Translations", I can't find any field that begins with an underscore ( _ ). I looked for the field you shared in your screenshot and see that it exists without underscore and that it's set to translate (see screenshot).

If there is somewhere else that we need to adjust these settings, please let me know. More importantly, though, please let me know where and how we can edit these settings in bulk. I do not plan to go page by page and adjust these settings, especially when many of them are locked.

Please advise.

Best regards,
Liad

October 28, 2019 at 7:02 pm #4842709

orenF-2

Btw, I do want to add that for each individual page I can make these changes, but it would be crazy to go through each page. There must be some central location, like the settings section that would allow me to do this from a single location.

October 29, 2019 at 10:47 am #4846207

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello Liad,

To check the fields prefixed with _ you need to show system fields, check around 0:51 in the first video.

When the settings for system fields(prefixed with _) is set it became central for all the website. As of now, we can not change them from a central location.

The settings for system fields(prefixed with _) cannot be changed right now from a central location. But once we set them in a page/post they became central for the whole website.
You won't need to configure a field(identified by name) on each page. But you will have to update each page individually so the page can take the new settings.

I hope this answers your question. Let me know if you have any other question. I remain at your disposal.

Best regards,
Jamal

November 5, 2019 at 1:01 am #4885411

orenF-2

Hi Jamal,

I've watched the videos you've provided and made some settings changes inside individual posts. I'm still seeing that some fields are locked/"grayed out". Where would I change these? (see screenshot)

Best regards,

November 5, 2019 at 5:23 pm #4892043

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

These locked/grayed fields are being configured with a configuration file. Check this article for more about it https://wpml.org/documentation/support/language-configuration-files/

I believe that these fields should be kept as translate. You will need to check the system fields, by clicking on "Show system fields" right before that table.

If you still need to reconfigure any of these fields, go to WPML->Settings->Custom fields Translations and unlock them, you can use the search box on the table to look for each field.

Best regards,
Jamal

The topic ‘[Closed] Our translation service has pushed new translations but they do not appear’ is closed to new replies.