This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 24 replies, has 3 voices.

Last updated by sebastianM-7 4 years, 3 months ago.

Assigned support staff: Ahmed Ibrahim.

Author Posts
December 7, 2015 at 3:25 am #762326

sebastianM-7

Hi there,

We use a domain per country. Unfortunately when entering the UK domain with www (hidden link - see screenshot), it redirects to the NZ version (hidden link) only without (hidden link) works fine and shows the expected UK content.

I had a look at the help section and found some reference to the htaccess file but as this a godaddy managed wp site, we don't have access to that as far as I know.

I would greatly appreciate your help. Please let me know what logins you require...
See the basic once below:

Many thanks for all your help and time. Have a great day!

Kind Regards,
Sebastian

P.S.
Just out of interest, why do you think our admin backend it so slow?

December 8, 2015 at 9:55 am #763310

Eduard

Hi,

Can you please do the following:
1. Backup your database and files
2. Update WPML and it's addons to latest version
3. Go to WPML->Languages and change the domain for UK to hidden link and check if issue exist.

If this won't help can you please deactivate "Sidekick" and test without it?

Thanks.

December 10, 2015 at 9:17 am #765575

sebastianM-7

Hi Eduard,

Thanks for your replay and advise.

I followed your steps, however the 3rd step causes me trouble. I am not able to safe hidden link for the UK. After saving and refreshing the page it would go back to hidden link

Unfortunately deactivating sidekick and ant other plugins that are not necessary has not made a difference. Do you have another idea?

Have a great day!

Many thanks,
Sebastian

December 10, 2015 at 2:48 pm #766003

Eduard

Hi,

Can you please do the following:
1. Backup your database and files
2. Switch to default theme
3. Deactivate all non-WPML plugins
4. Go to WPML->Languages and change the domain for UK to hidden link and check if issue exist.
5. Activate your theme and plugins.

Please let me know if you have any issue

Thanks

December 11, 2015 at 4:12 am #766537

sebastianM-7

Hi Eduard,

Thanks for the steps. This all seem to not help. it seem comes up with the same issues, which is that it won't save the new domain and always jumps back to the version without www. I know that Bruno looked at this once before for a different domain and fixed it. Would you know what he might have done in the backend?

Looking forward to hear from you.

Regards,
Sebastian

December 11, 2015 at 6:28 am #766554

sebastianM-7

Hi Eduard,

I hope you re having a fantastic day!

We just tried to also include hidden link into WPML and we are having the same issue, it is not saved. Would you mind to have a look at this at the same time please?

Many thanks,
Sebastian

December 11, 2015 at 10:52 am #766800

Eduard

Hi,

Just to clarify you have deactivated all non-WPML plugins, switched to default theme, tried to save options and got same error message?

Thanks

December 12, 2015 at 2:15 pm #767654

sebastianM-7

Hi,

YES, all 10 plugins where deactivated excluding WPLM, and theme was changed to fifteen.
Still no way to save the change for the domains.
I would appreciate fi you could have a look and do what ever Bruno did when we had this issue with some other domains.

Many thanks and have a great day,
Sebastian

December 14, 2015 at 8:09 am #768012

Eduard

Hi,

I've escalated your ticket for further debugging.

Thanks

December 15, 2015 at 6:49 am #769041

sebastianM-7

Hi Eduard,
Thank you, that is much appreciated. It would be great to learn how to fix this issues ourself as well, as we will continue to add languages and domains in the near future and the issues seem to come up every time we do that.

Kind regards,
Sebastian

December 17, 2015 at 6:35 pm #771892

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi this is Ahmed Ibrahim from second tier support.

Could you please provide me with temporary access (wp-admin and FTP) to your site in order to provide a better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

+ Please make sure that you have a full backup of your website and database. (Please don't ignore this)!
+ It'd be great if you give me an access for a test site where the problem is replicated.

Best Regards.

December 18, 2015 at 4:46 pm #772650

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi, and thanks for your data.

I think it could be an issue with wpml, but I would like to make a test before escalating to the developers, I want to change the UK domain to start with "www", and I can see from the previous message that you couldn't change it, so I will provide you a script for doing, so please add this script to your functions.php at the root file of your active theme, and refresh your WPML -> languages page once, then delete the script, and clear all your cache on the server(if you have) and if you have any cache plugin please disable it and check your issue again.

*** Please backup your site before doing this.

function update_icl_settings() {
	$wpml_plugin_settings = get_option( 'icl_sitepress_settings');

	if($wpml_plugin_settings['language_domains']){
		$wpml_plugin_settings['language_domains']['uk'] = "<em><u>hidden link</u></em>;
		update_option( 'icl_sitepress_settings', $wpml_plugin_settings );
	}
}
add_action( 'admin_notices','update_icl_settings' );

Please let me know if that helps you.
Best Regards.

December 20, 2015 at 8:31 am #773100

sebastianM-7

HI Ahmend,

Thank you so much for your help. Are you sure that this syntax is correct? I am asking as it broke the function.php and we had to restore a backup...

Could you sit double check and I can try again..

Have a great start into the next week!
Many thanks,
Sebastian

December 21, 2015 at 8:54 am #773409

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi, and thanks for your response.

Sorry there was a typo error in the syntax, there was a missing coma at the end of the domain name, it is weird because I don't know why it is missing, so please try this one, and you can add your code using ftp or CPanel, and if something goes wrong, you can delete the code safely without restoring the whole site.

function update_icl_settings() {
    $wpml_plugin_settings = get_option( 'icl_sitepress_settings');

    if($wpml_plugin_settings['language_domains']){
        $wpml_plugin_settings['language_domains']['uk'] = "<em><u>hidden link</u></em>";
        update_option( 'icl_sitepress_settings', $wpml_plugin_settings );
    }
}
add_action( 'admin_notices','update_icl_settings' );

Please let me know if it works for you this time, and if not I will need to take a copy from your site locally to test it.
Best Regards.

January 7, 2016 at 2:21 am #782287

sebastianM-7

Hi Ahmed,

The hidden link still points to the NZ version and the DK version is still not accepted in the setting page. What will be the next step to resolve thees issues?

Thank you for your time.

Regards,
Sebastian