This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 24 replies, has 3 voices.

Last updated by sebastianM-7 4 years, 3 months ago.

Assigned support staff: Ahmed Ibrahim.

Author Posts
January 7, 2016 at 8:51 am #782410

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi, and thanks for your reply.

I can see that you haven't tried the code from my last reply, the uk domain still not having the www in your languages settings(see the attached screenshot), you can add it to your functions.php file through FTP, and if any thing wrong just remove it but It should work without any problems, refresh your back-end once then remove the code. I will past it again here :

function update_icl_settings() {
    $wpml_plugin_settings = get_option( 'icl_sitepress_settings');
 
    if($wpml_plugin_settings['language_domains']){
        $wpml_plugin_settings['language_domains']['uk'] = "<em><u>hidden link</u></em>";
        update_option( 'icl_sitepress_settings', $wpml_plugin_settings );
    }
}
add_action( 'admin_notices','update_icl_settings' );

Also Please take a backup from your site and update all your WPML plugins because you are running an old version.

Then please if you can deactivate all the non wpml plugins, specially the "404 redirects" switch to the default theme if possible and try again

Please let me know if that helps you.
Best Regards.

January 12, 2016 at 6:46 pm #786192

sebastianM-7

Hi Ahmed,

Thanks fro your patience with this.
I doubled check the function.php and the code from you is there (on the very bottom).
Did you see that and do you mean something else? See screenshot attached.

Regards,
Sebastian

January 12, 2016 at 8:23 pm #786268

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi, and thanks for your reply.

Yes I can see the script in your functions.php, but I don't why it doesn't affected your domains settings, I have commented it for now, and please disable your caching plugins and if your server have any cache please disable it for now and also delete any cached files.

Then please go to the download page on your WPML account : https://wpml.org/account/downloads/, and download the latest beta version 3.3.6-beta you will find it under the beta section, this is a very important steps, may be your issue was resolved in the latest version, then please let me know and I will complete my investigation.

Best Regards.

January 29, 2016 at 12:09 am #799353

sebastianM-7

Hi Ahmed,

Thanks for the next step to got through. I have more time the next week to implement this. Can I just check we you if you know if it is possible to disable the catch on GoDaddy managed WP server? Sorry probably an amateur question.

Also, once we have sorted the UK domain issue, will that solve any future domains that we want to add?

Have a great weekend!

Regards,
Sebastian

February 1, 2016 at 8:53 am #800911

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi, and thanks for your reply.

For deleting the cache files I recommend you to first check your wp-content folder, you could find a folder called cache, delete it, also you can read some articles like those : hidden link.

And about the domain problem, yes I think if we could fix this issue we can add any other domain without problems.

Best Regards.

February 3, 2016 at 8:19 am #803311

sebastianM-7

Hi Ahmed,

Sounds good. We just moved server and it seems to work already a bit better. We are waiting for the full integration tomorrow and hope the issue will be gone but I will let you know either way.. Talk soon.
Thanks,
Sebastian

February 3, 2016 at 7:56 pm #804217

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for the update, hope it will work fine.

Best Regards

February 20, 2016 at 6:17 am #818968

sebastianM-7

Hi Ahmed,
I hope you are well! Good news, since we moved to our new server hidden link is detected as UK however now the hidden link is detected as default language (NZ) and redirects back to the NZ content. Any idea what to do about that, is that a DNS issue?

Also we did some testing (see screenshot) as our backend is still very very slow even since the server move. It turns out that WPML takes causes most of the delay. Is there a way to debug that plugin and speed it up?

Many thanks and have a great day!
Regards,
Sebastian

February 22, 2016 at 9:23 am #819706

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi, and thanks for your reply.

About the DNS question, could you please ask your hosting provider about this, maybe they could have a solution for this to help us, they can use something like parked domains for example. (not sure)

And about your performance issue, I kindly ask you please to open a new ticket for it? It will be difficult to handle two issues at the same time and this will also help other users with similar problems find solutions when searching the forum.

Best Regards.

February 23, 2016 at 8:01 am #820730

sebastianM-7

Hi there,

The www. co.uk domain is now connecting, very cool! not without www but that is not so important. We are waiting currently for the .dk domain to be parked so that we can test it. We should know in the next couple of days...

Thanks for your patience!
Sebastian