This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by Davide 3 weeks, 2 days ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
September 3, 2019 at 4:16 pm

Davide

I've translate in italian all strings inside Overlay, this is a js overlay with plugin developed by the same theme (Uncode) developer.
When i go like new visitor on in incognito window browser mode in one page translated in italian with ICL_LANGUAGE_CODE=it, I should see overlay text translated in italian but content continue to appear in default language (english)

Link to a page where the issue can be seen:
hidden link and all page with ICL_LANGUAGE_CODE = it

I expected to see:
content of overlay translated in italian

Instead, I got:
content of overlay remain partially in english (see picture attached)

For open Overlay, click 'Prefernze Privacy' link near orange button 'Sono d'Accordo'

September 3, 2019 at 8:01 pm #4507191

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I took a detailed look in your website and could noticed the issue, This seems to be a theme/plugin compatibility issue. In these cases, these are the procedures:

  • Install the theme/plugin in a clean installation and reproduce the problem in this new installation. So we can isolate it and do some testing without the interference of server settings or other plugins
  • After this, I will check the problem in this new installation and look for a quick solution
    If I can not find a solution, I will forward the problem to our compatibility team.
  • The compatibility team will do some more testing and will contact the product author to fix the issue

I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload the (theme/plugin) to this test install, setup it the same way as in your website (using the same options) and create some dummy content to reproduce the issue. Please note that we only need the (theme/plugin) and the related functionality, you don't need to setup a entire website or clone your existing site. The fewer plugins the better.

After that, please send us clear steps on how to see/reproduce the issue on this test install. We will run some tests.

Please, let me know when you are ready, thank you for your collaboration, have a nice day.

September 4, 2019 at 10:16 am #4509947

Davide

Hello,

I've installed theme and plugin (non all plugin present in my website) necessary for test.
hidden link

The issue here does not occur
I checked the WPML settings and they are the same on my site.
I am now processing Translate Link Targets (more of 32.000) on my site to see if something changes.

September 4, 2019 at 5:52 pm #4513371

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a detailed look at the sandbox environment and confirmed it is compatible, in your case, please proceed this way:

1 - Make sure all your WPML related plugins are fully updated to their latest versios. See: https://wpml.org/faq/install-wpml/#automated-updates

2 - Disable all your plugins except those directly related to your theme and the 'Uncode Privacy' itself.

3 - Delete your current translation for those strings in your WordPress Dashboard > WPML > Strings Translations and recreate them. (This is step is needed in case we have some kind of persistent cache for those strings). See: https://wpml.org/documentation/getting-started-guide/string-translation/

Please, let me know if it works for you, have a nice day.

September 6, 2019 at 10:08 am #4524701

Davide

Hello,

1 - All WPML related plugins are registered, fully updated to their latest versions.
2 - Coming soon I proceed with copy all website to subdomain and make necessary proofs disabling all plugins except those directly related the theme functionality and the 'Uncode Privacy'.
3 - Later I will also try to delete some strings and re-create them, I have WpRocket plugin installed and before opening the gate ticket I always cache the page, the browser and often the PC too.

NOTE
I noticed today and it happened to me to see it before that between the Translation Priorities is present in addition to the 3 standard options: Not needed, Optional and Required also a '160' option.
Has it already happened some other ticket that signaled this?

Have a nice day.

September 6, 2019 at 5:42 pm #4526923

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Davide,

Thank you for the updates. Please, let me know the results once you are done. As regarding your request:

"I noticed today and it happened to me to see it before that between the Translation Priorities is present in addition to the 3 standard options: Not needed, Optional and Required also a '160' option."

I would need some more details where you see it and how to reproduce it before giving a detailed and accurate answer. In any case, let's solve one issue at a time to keep things organized and more effective.

Thank you for your collaboration and understanding, have a nice day.

September 12, 2019 at 2:46 pm #4561945

Davide

Hi,

here's an update:

1 - I have cloned a website on a sub-directory
2 - disabled all plugins apart from those needed for the theme
3 - deleted wpml cache
4 - deleted wprocket folder cache
4 - deleted the strings with issue
5 - regenerate strings with issue with theme and plugins localization
6 - assigned language En
7 - assigned optional translation priority or required

Translated again but does not change anything, they are not displayed in Italian.

The only plugin that I can't turn off is WooCommerce, if I do it generates an error in the system site.

September 13, 2019 at 1:00 am #4564539

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.
Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.I will also need the username and password of an account that was created BEFORE creating the duplicator package.I will enable the next reply to be private so only you and I have access to it!

Thank you for your collaboration. Have a nice day.

September 17, 2019 at 2:21 pm #4589127

Davide

Hello,

as I wrote, I cloned the site into a sub directory, it's a new instance of wordpress that uses a copy of the production site data but with a new database. On this clone site you can do all the necessary tests without the risk of compromising the production site.

I have in the meantime done other tests.

Deleted Uncode-Privacy specific plugin,
Deleted plugin strings in WPML
Deleted plugin cache with WPRocket,
Deleted WPML cache ...

as soon as I install it again, I find the strings again even without the plugin scan, but if I translate the strings into Italian the issue recurs as it is.
I keep seeing the strings only in English!

The plugin is included in the homonymous theme that was sold in 56.5K licenses,
it's possible that no one else has found my issue? impossible!!

September 18, 2019 at 2:16 pm #4597521

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Davide,

Thank you for the updates. I am debugging your test website (/wp) however I would also need the FTP access, I bulk disabled the plugins to keep only the necessary ones, this action deactivated the WooCommerce plugin which made the website broken since you call a class in your child theme without checking if it exists, the recommended method of calling plugin code without break the site when the plugin is deactivated is to check the class if it exists before calling it.

In any case the FTP access will help me to temporary change theme and then activate WooComerce again, this way I will be able to proceed with the debug process. I will enable a private reply for you, so you can safely send any access details. Thank you for your collaboration and understanding, have a nice day.

September 18, 2019 at 2:24 pm #4597537

Davide

Sorry Marcos,

I wrote that I cloned the site and that your tests were done on staging and not on the main site.
I had also written previously, because I had tried, that by disabling the woocommerce plugin the site broke.

I was waiting for your response to provide credentials to access the staging site ...

September 18, 2019 at 2:30 pm #4597607

Davide

The class added to child theme function.php I have called WC_Product_Custom and extend existing WC_Product. I've forgot to add _class to WC_Product...

Please sent to me private reply, so I can send to you ftp credentials.

Thanks!

September 18, 2019 at 2:48 pm #4597705

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I really sorry for the confusion I interpreted your message as referering to (domain/wp) site as the subdirectory stagging website. In any case I am able to fix that with a FTP access so I can proceed like that to restore your website:

1 - Access your host wp-content/themes and rename your active theme folder in order to force a deactivation and makes WordPress to use the standard theme (TwentyNineeteen).

2 - Access the WordPress Dashboard and enable the plugins again.

3 - Rename your previous used theme again to its original name.

4 - Activate it again in your WordPress Dashboard.

If you are not able to proceed with the steps below, please, let me know I am happy to help. Once again please, accept my apologies regarding this confusion.

The real stagging website will help me to proceed with the investigation process. A private reply is now enabled for you, so you can safely send any access details. Thank you for your understanding and patience, have a nice day.

September 18, 2019 at 3:05 pm
September 19, 2019 at 6:36 pm #4607941

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello David,

Thank you for continued patience while waiting for a solution. I took a detailed investigation in your staging environment and unfortunately the issue persists, it is really weirds for me how everything works well in a different server environment, but no in your case, even using the exact same settings and server resources. I forwarded this ticket to our second level support so they can proceed with more details, I will update you here as soon as a reply from them is given. Thank you for your understanding and patience, have a nice day.