This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 9.62 hours from now. Thank you for your understanding.

This topic contains 38 replies, has 3 voices.

Last updated by olofs 5 years, 8 months ago.

Assigned support staff: Konrad Karpieszuk.

Author Posts
November 13, 2013 at 5:32 am #291170

olofs

Hi and OK. I know that you closed the ticket about compatiblity problems between Templatics RealEstate2 and WPML, but I have a very seroius problems now!.
My host reduced my CPU limits because the site hits the roof all the time.
Make's my sites load extremely slow, and no help from Crocweb support.
Here's the strange thing, even when it's no traffic at all, the CPU has 100% peaks and never get below 25%?
When I disable every WPML- plugin the CPU% get down to zero.
Pls take a look what's happening, can not use the site as it is now
My live site hidden link and the sandbox where I have disabled WPML at hidden link
The P3 test show that it is Sitepress Multilingual CMS thats the big CPU hog
Best Ola

November 13, 2013 at 7:57 am #291245

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Hello Ola,

Our developers are working on a number of performance improvements in the upcoming versions of WPML so speed will improve.

In the meantime I would encourage you to have a look at this article: http://wpml.org/2012/01/can-your-site-run-faster/ and especially under the section "Using WPML Better" and "Separate WPML’s Impact"

November 13, 2013 at 8:22 am #291274

olofs

Hi
And that was not the type of answer I wanted! I am not a programmer but as I told in my ticket my site is pretty unusable right now. I need help, not a tip what I can read at nighttime.
YOU LEFT ONE QUESTION WITHOUT TRYING TO ANSWER:
"Here's the strange thing, even when it's no traffic at all, the CPU has 100% peaks and never get below 25%?"
And I think something is really wrong, so if someone at WPML can give me some REAL help I would be happy

November 13, 2013 at 9:28 am #291349

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Ola,

You wrote: "I am not a programmer"

The article I pointed you to was not written with programmers in mind so this should not be a problem.

***

You asked: "Here's the strange thing, even when it's no traffic at all, the CPU has 100% peaks and never get below 25%?"

Do you have the same results with the WordPress Twenty Thirteen default theme?

November 13, 2013 at 9:35 am #291355

olofs

When I disable every WPML- plugin the CPU% get down to zero.
And of course if I change template

November 13, 2013 at 9:42 am #291366

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Thank you for getting back to me Ola.

So do I understand this correctly? If you switch to the WordPress default theme with the WPML plugins active you do not get the same CPU results as you do when you use your custom theme.

If this is correct then the problem is the theme you are using and not WPML.

As fixing theme issues is beyond the scope of support we offer here at the WPML support forum I would suggest that you either contact your theme author or you request custom work assistance.

If you choose to go with custom work assistance I would suggest you try this new service we have available: hidden link
You will get the custom assistance you need to get on with your project.

Alternatively you may like to consider contacting one of our certified partners from this link: http://wpml.org/documentation/support/wpml-contractors/
Before doing so please have a look also here: http://wpml.org/documentation/support/wpml-contractors/guidelines-for-people-looking-for-consulting-help/

November 13, 2013 at 11:16 am #291471

olofs

Now this starts to feel more and more wrong.
First, you do not read my ticket at all, and I do not think you have opened and looked at the picture I sent.
Now it seems you're not even trying to read what I write!
In standard mode, the CPU peaks without any traffic, but if I deselect all WPML plugins the CPU goes down to zero. It is never down to zero with WPML active, stays at approx 25 %
I have neither the time nor the desire to have contact with a support that only read half the text in the tickats and then draw the wrong conclusions.
As you also seems to have missed, I set up a Sandbox site, it might be a good idea if you open the fields for Logins and cPanel details, so you can try out your ideas yourself.
But now I ask you to read my reply properly and not waste any more time on your strange answers or solutions.

November 13, 2013 at 11:51 am #291547

olofs

Some more info to my reply above 11:16 AM
I run 3 Plugin profiler with (earlier pic) and with WPML string and mulilingual deselected.
MySQL MYSQL
2193 314

Pluginload
80.9 0.089

Load time
7.12 sec 1.04 sec

Still the theme?

November 13, 2013 at 1:13 pm #291652

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Ola,

I am reading carefully everything your write.

I have enabled the private details form fields.
Please make sure that you have the default theme active and only WPML and WPML String Translation plugins.

Thank you.

November 13, 2013 at 2:35 pm #291724

olofs

Nah. Sarah, it's up to you to set the values and plugins to what you want.
In the backend I have installed the plugin 3 Performance and I recomend you to take a look at the Resource Usage in cPanel. The site is a sandbox and not my live site..... so play around, and freethaiproperty.com is the only site in this account!
cPanel is available at "FTP Host/Server":2082/cpsess8246550171/frontend/x3/index.html and FTP credentials

November 14, 2013 at 8:23 am #292153

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Ola,

I will go ahead and run some tests on the site whose details you provided and let you know when done.

November 14, 2013 at 8:28 am #292160

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Could I ask you please to add the access details back in? I just edited my previous comment that that seems to have removed the details. (a bug that I must report to our forum developer)

Sorry about this!

November 14, 2013 at 10:09 am #292261

olofs

Yeah I could see that you did not check anything yesterday................. I would like to remind you that my live site it unusuable since a couple of weeks back

November 14, 2013 at 10:12 am #292264

olofs

Don't miss again pls

November 14, 2013 at 11:40 am #292337

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Thank you.

I took the liberty and I update WPML and its add-ons to their latest versions.

I am running some tests right now following the information provided for us here: http://wpml.org/2012/01/can-your-site-run-faster/ and especially under the sections "Using WPML Better" and "Separate WPML’s Impact"

1. Default theme, WPML and WPML String Translation

2. Templatic theme, WPML and WPML String Translation

3. Templatic theme, WPML and WPML String Translation + your other plugins

4. Default theme, WPML and WPML String Translation + your other plugins

I will upload the screenshots of the results when finished.