Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 38 replies, has 3 voices.

Last updated by olofs 5 years, 11 months ago.

Assigned support staff: Konrad Karpieszuk.

Author Posts
November 14, 2013 at 12:23 pm #292381

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

These are my test results Ola - please see the attached screenshots.

It appears to me that the problem is indeed the combination of the Templatic theme with WPML.

On a positive note, I feel that once your theme is made fully compatible the situation will very likely improve!
Add to this the improvements our developers are planning for the next version of WPML I am confident performance will improve further.

In the meantime, what you can do is to ensure that WPML settings are adjusted as you see below:

Track where strings appear on the site OFF (/wp-admin/admin.php?page=wpml-string-translation/menu/string-translation.php)
Disable auto-register strings ON (/wp-admin/admin.php?page=wpml-string-translation/menu/string-translation.php)

Adjust IDs for multilingual functionality OFF (/wp-admin/admin.php?page=sitepress-multilingual-cms/menu/languages.php)

November 16, 2013 at 8:39 am #293346

olofs

Dunno why you open a new ticket? What new WPML plugins? I thought I had the last ones? You still haven't answered why the CPU load never go down to zero when WPMN is active
/Ola

November 16, 2013 at 8:45 am #293348

olofs

Pls see answer earlier above
This I dont understad at all Track where strings appear on the site OFF (/wp-admin/admin.php?page=wpml-string-translation/menu/string-translation.php)
Disable auto-register strings ON (/wp-admin/admin.php?page=wpml-string-translation/menu/string-translation.php)

Adjust IDs for multilingual functionality OFF (/wp-admin/admin.php?page=sitepress-multilingual-cms/menu/languages.php)

Time schedule for next version of WPML?

/Ola

November 18, 2013 at 8:37 am #293796

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+01:00)

Dear Olaf,

my name is Konrad, Sarah is on her vacation in this week, that is why answer to your ticket.

First thing: Sarah didn't open new ticket - this is just second page of your topic. That is why you see her post at top of the screen.

"You still haven't answered why the CPU load never go down to zero when WPMN is active"

Every software uses CPU, this is normal. And you cannot make CPU usage equal to zero. If you really want to has this on zero, you have to turn off server.

In this part which you didn't understand Sarah ask you to go to your WordPress dashboard to make sure that you have everything set OK. Once again:

1. please go to WPML > String translation, find "Track where strings appear on the site" and make sure that this option is Off.

2. At the same site find "Disable auto-register strings" and make sure that this option is On.

3. Now go to WPML > Languages, find "Adjust IDs for multilingual functionality" and make sure that this option is Off

Those are three and only three options which can make your site slow if it is configured in opposite, so please check this. Everything else what makes your site slow is relative to theme which you use - you see this on screenshots. Now we are in contact with this theme author and we work on this, but I cannot tell you when it will be done: it depends on how fast theme author will make some improvements in his code.

Also as you know we work on WPML 3.1 which will be published soon (again I cannot say exact date) and will bring some speed improvements, but please don't expect magic here. WPML/WordPress site can be as fast, as other components (other plugins and theme) allow it. If you use template which makes a lot of queries to database, WPML cannot forbid this.

Please let me know if you are satisfied with my answer and if I can help you with any other questions you might have

November 18, 2013 at 10:34 am #293873

olofs

Thank's for answer. I was not 100% OK and still are not. Had a Stroke yesterday so it is notone of my best days. But one thing, about CPU, with WPML it's mostrly over 25% and with WPML deselected close tp o% Best Ola

November 18, 2013 at 10:41 am #293878

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+01:00)

Dear Ola, i think 25% it is value which we have to agree. There is no any other way to translate content and not use CPU for now. As i said next WPML release will make it better, but we have to wait, ok?

I hope you health will be better! I wish you this!

November 19, 2013 at 7:19 am #294440

olofs

Hi Konrad. I still don't understand why WPML need 25 % CPU when it's no traffic! It's not a realtime system or working in the background?

Ola

November 19, 2013 at 10:16 am #294596

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+01:00)

Hi Ola,

the only reason is that theme which you use makes tens of database queries. Every query, when is launched is filtered by WPML and it uses CPU.

If your theme will not make those queries, there will be nothing for WPML to filter and CPU will not be used.

November 25, 2013 at 8:30 am #297358

olofs

Ehhhh, as I asked before but you did not read? Without any traffic at all the CPU should be at zero. No queries, nothing for WPML to do but anyhow 25% CPU?

November 25, 2013 at 8:49 am #297372

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+01:00)

Olo, I think when you connect to site to check CPU you made a traffic. Also remember that PHP interpreter runs after traffic stops: somebody visit your site, PHP starts to work, he leave a site, but PHP still works (until max_time_limit will be exceed).

Next layer is database: PHP delegates some tasks to mySQL and it also uses CPU (even more than CPU but it depends on configuration)

And next, separate layer is cronjobs: server system - when see that PHP and MySQL is not doing anything starts some system administration jobs (but it shouldn't take 25% CPU, only maybe on some peaks)

Also: if your site is not on separate private dedicated server but on shared hosting CPU works because other websites (not your but other people) can be visited.

December 1, 2013 at 12:52 pm #300401

olofs

Thanks for answer but I am afraid most of them are wrong.
I wrote that the site has NO TRAFFIC AT ALL, and WPML is not a real time system and when I DISCONNECT wpml the CPU goes down to Zero

See attached graph that show my sites use of CPU NOT all the others

December 2, 2013 at 6:36 am #300555

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+01:00)

Dear Olo,

as we said we work on WPML 3.1 which will work faster, so be patient but also don't expect that CPU usage will go down to zero. Operating on data must use CPU

December 6, 2013 at 9:42 am #303322

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+01:00)

Dear Olo,

we are testing now WPML 3.1 for performance and we want to test it at copy of your site. Could you tell me where I can find phpmyadmin at your server? I want to download copy of your site (inluding database) and test it here locally. To do this, I need to know what is the address for phpmyadmin. You can write it at forum publicaly, but don't write login and password to this (i see them at your ftp server, I don't need you type it again)

December 6, 2013 at 9:44 am #303324

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+01:00)

And also please update login data to wp-admin, I see this is not working now

December 6, 2013 at 11:02 am #303384

olofs

Well I have made a sandbox site where you can play around. And Konrad, pls read my comments more thoroughly next time. When i write it is no traffic it is no traffic and hence nothing for the CPU to do AND as extra info I write when I disconnect WPML the CPU go down to zero. See login details below. In cPanel take a look at "Resource Usage"

I am also curious how the cooperion with Templatic goes ahead (or if it does at all)
Best Ola